summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-22 23:45:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-22 23:45:23 +0000
commit2e88705eef44312c2f4cfd72880558c82b82870e (patch)
tree83c51f03890fd928ec5637ad6c8046d11df8bfae /sys-devel/automake-wrapper
parentcleanup, and hence avoid intltool issues (Manifest recommit) (diff)
downloadgentoo-2-2e88705eef44312c2f4cfd72880558c82b82870e.tar.gz
gentoo-2-2e88705eef44312c2f4cfd72880558c82b82870e.tar.bz2
gentoo-2-2e88705eef44312c2f4cfd72880558c82b82870e.zip
initial ebuild
Diffstat (limited to 'sys-devel/automake-wrapper')
-rw-r--r--sys-devel/automake-wrapper/ChangeLog8
-rw-r--r--sys-devel/automake-wrapper/Manifest6
-rw-r--r--sys-devel/automake-wrapper/automake-wrapper-1.ebuild29
-rw-r--r--sys-devel/automake-wrapper/files/am-wrapper-1.pl137
-rw-r--r--sys-devel/automake-wrapper/files/digest-automake-wrapper-10
-rw-r--r--sys-devel/automake-wrapper/metadata.xml5
6 files changed, 185 insertions, 0 deletions
diff --git a/sys-devel/automake-wrapper/ChangeLog b/sys-devel/automake-wrapper/ChangeLog
new file mode 100644
index 000000000000..182677264070
--- /dev/null
+++ b/sys-devel/automake-wrapper/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-devel/automake-wrapper
+# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/ChangeLog,v 1.1 2004/10/22 23:45:23 vapier Exp $
+
+*automake-wrapper-1 (22 Oct 2004)
+
+ 22 Oct 2004; Mike Frysinger <vapier@gentoo.org>:
+ Break the automake wrapper (am-wrapper.pl) off into its own package.
diff --git a/sys-devel/automake-wrapper/Manifest b/sys-devel/automake-wrapper/Manifest
new file mode 100644
index 000000000000..6c845ad65d0a
--- /dev/null
+++ b/sys-devel/automake-wrapper/Manifest
@@ -0,0 +1,6 @@
+MD5 b2f103286c8fc6e346a9b2f300b1ac5d automake-wrapper-1.ebuild 627
+MD5 2b5aa34b9c688d919f6b06df0c428cc4 files/am-wrapper-1.pl 6165
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-automake-wrapper-1 0
+MD5 98d5ab8800a53d3e713fd5b083be1e9f f/am-wrapper.pl 4654
+MD5 1834b6d845aa175efd08cfb813a361d2 f/attachment.cgi?id=41195 8685
+MD5 555bbf3a7b5cddb99a45e87655e666c7 f/attachment.cgi?id=41207 3231
diff --git a/sys-devel/automake-wrapper/automake-wrapper-1.ebuild b/sys-devel/automake-wrapper/automake-wrapper-1.ebuild
new file mode 100644
index 000000000000..49ad375a42fa
--- /dev/null
+++ b/sys-devel/automake-wrapper/automake-wrapper-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake-wrapper/automake-wrapper-1.ebuild,v 1.1 2004/10/22 23:45:23 vapier Exp $
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+
+src_install() {
+ exeinto /usr/lib/misc
+ newexe ${FILESDIR}/am-wrapper-${PV}.pl am-wrapper.pl || die
+
+ keepdir /usr/share/aclocal
+
+ dodir /usr/bin
+ local x=
+ for x in aclocal automake ; do
+ dosym ../lib/misc/am-wrapper.pl /usr/bin/${x}
+ done
+}
diff --git a/sys-devel/automake-wrapper/files/am-wrapper-1.pl b/sys-devel/automake-wrapper/files/am-wrapper-1.pl
new file mode 100644
index 000000000000..4deff78df3b2
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/am-wrapper-1.pl
@@ -0,0 +1,137 @@
+#!/usr/bin/perl
+#
+#
+# Author: Guillaume Cottenceau (gc@mandrakesoft.com)
+# Modified by: Martin Schlemmer (azarah@gentoo.org)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.8 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.8'
+# -or-
+# - `Makefile.in' was generated by automake-1.8 or superior, which
+# specifically needs automake-1.8
+# -or_
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.8
+# - runs automake-1.7 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.7'
+# -or-
+# - `Makefile.in' was generated by automake-1.7 or superior, which
+# specifically needs automake-1.7
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.7
+# -or-
+# - runs automake-1.6 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.6'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.6
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.53c'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.53c'
+# - runs automake-1.5 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.5'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.13'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.13'
+# -or-
+# - `Makefile.in' was generated by automake-1.5 or superior, which
+# specifically needs automake-1.5
+#
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+sub am_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+sub ac_version {
+ my $file = cat_(shift);
+ return (@versions = $file =~ /^\s*\[?AC_PREREQ\(\[?([^\)]{3}[0-9]?)[^\)]*\]?\)/mg) ? ((sort @versions)[-1]) : '';
+}
+
+
+
+my $binary = "$0-1.4";
+my $binary_1_5 = "$0-1.5";
+my $binary_1_6 = "$0-1.6";
+my $binary_1_7 = "$0-1.7";
+my $binary_1_8 = "$0-1.8";
+
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
+if ($ENV{WANT_AUTOMAKE} ne '1.4') {
+ if (-x $binary_1_8 # user may not have _1_8 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.8')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.8'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.8'
+ || am_version('aclocal.m4') ge '1.8')) {
+ $ENV{WANT_AUTOMAKE} = '1.8'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_8;
+ } elsif (-x $binary_1_7 # user may not have 1.7 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.7')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.7'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.7'
+ || am_version('aclocal.m4') ge '1.7')) {
+ $ENV{WANT_AUTOMAKE} = '1.7'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_7;
+ } elsif (-x $binary_1_6 # user may not have 1.6 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.6')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.6'
+ || am_version('aclocal.m4') ge '1.6'
+ # Autoconf 2.53d and later need automake-1.6c, so enable 1.6 for 2.53
+ # and up .....
+ || ac_version('configure.in') gt '2.52'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.52'
+ || ac_version('aclocal.m4') gt '2.52')) {
+ $ENV{WANT_AUTOMAKE} = '1.6'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_6;
+ } elsif (-x $binary_1_5 # user may have only 1.4 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.5')
+ || -r 'configure.ac'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.5'
+ || ac_version('configure.in') gt '2.13'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.13'
+ || ac_version('aclocal.m4') gt '2.13')) {
+ $ENV{WANT_AUTOMAKE} = '1.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_5;
+ } else {
+ if (-r 'configure.in' || -r 'configure.ac') {
+ $ENV{WANT_AUTOMAKE} = '1.4'; # for further consistency
+ } else {
+ $ENV{WANT_AUTOMAKE} = '1.8';
+ $binary = $binary_1_8;
+ }
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake-wrapper/files/digest-automake-wrapper-1 b/sys-devel/automake-wrapper/files/digest-automake-wrapper-1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/automake-wrapper/files/digest-automake-wrapper-1
diff --git a/sys-devel/automake-wrapper/metadata.xml b/sys-devel/automake-wrapper/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-devel/automake-wrapper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>