summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-10-18 05:52:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-10-18 05:52:43 +0000
commitf7caafe586c3194e35b882f43cad5779f27b9815 (patch)
treed62e80f0fec1bbb4709e7dbb4661db912fa02051 /sys-cluster
parentAdd fix from newer versions for cp/mv problems on older kernels #289134 by Al... (diff)
downloadgentoo-2-f7caafe586c3194e35b882f43cad5779f27b9815.tar.gz
gentoo-2-f7caafe586c3194e35b882f43cad5779f27b9815.tar.bz2
gentoo-2-f7caafe586c3194e35b882f43cad5779f27b9815.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/ChangeLog12
-rw-r--r--sys-cluster/keepalived/files/keepalived-1.1.19-do-not-need-kernel-sources.patch113
-rw-r--r--sys-cluster/keepalived/files/keepalived-1.1.19-gcc44-fixup.patch53
-rw-r--r--sys-cluster/keepalived/keepalived-1.1.19.ebuild88
4 files changed, 264 insertions, 2 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index 705f57a69221..d247972f80c1 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/keepalived
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.62 2009/09/18 09:40:58 xmerlin Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.63 2009/10/18 05:52:43 robbat2 Exp $
+
+*keepalived-1.1.19 (18 Oct 2009)
+
+ 18 Oct 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +keepalived-1.1.19.ebuild,
+ +files/keepalived-1.1.19-do-not-need-kernel-sources.patch,
+ +files/keepalived-1.1.19-gcc44-fixup.patch:
+ Version bump.
18 Sep 2009; Christian Zoffoli <xmerlin@gentoo.org>
keepalived-1.1.17.ebuild:
diff --git a/sys-cluster/keepalived/files/keepalived-1.1.19-do-not-need-kernel-sources.patch b/sys-cluster/keepalived/files/keepalived-1.1.19-do-not-need-kernel-sources.patch
new file mode 100644
index 000000000000..8cec602a9c4b
--- /dev/null
+++ b/sys-cluster/keepalived/files/keepalived-1.1.19-do-not-need-kernel-sources.patch
@@ -0,0 +1,113 @@
+diff -Nuar --exclude '*.orig' --exclude '*.rej' keepalived-1.1.19.orig/configure.in keepalived-1.1.19/configure.in
+--- keepalived-1.1.19.orig/configure.in 2009-09-28 10:56:54.000000000 +0000
++++ keepalived-1.1.19/configure.in 2009-10-18 04:05:42.000000000 +0000
+@@ -51,106 +51,18 @@
+ AC_CHECK_LIB(popt, poptGetContext,,AC_MSG_ERROR([Popt libraries is required]))
+
+ dnl ----[ Kernel version check ]----
+-CPPFLAGS="$CPPFLAGS -I$kernelinc"
+-AC_MSG_CHECKING([for kernel version])
+-AC_TRY_RUN([
+- #include <stdlib.h>
+- #include <stdio.h>
+- #include <linux/version.h>
+- #if !defined(UTS_RELEASE) && !defined(LINUX_VERSION_CODE)
+- #include <linux/utsrelease.h>
+- #endif
+- int main (void) {
+- FILE *fp = fopen ("linuxinfo", "w");
+- if (!fp) return 1;
+- #if defined(UTS_RELEASE)
+- fprintf (fp, "%s\n", UTS_RELEASE);
+- #elif defined(LINUX_VERSION_CODE)
+- fprintf (fp, "%d.%d.%d\n", LINUX_VERSION_CODE >> 16, (LINUX_VERSION_CODE >> 8) & 0xFF, LINUX_VERSION_CODE & 0xFF);
+- #else
+- fprintf (fp, "0.0.0\n"); /* Let's fail gently */
+- #endif
+- fclose (fp);
+- return 0;
+- }
+- ], [
+- LINUX_MAJOR=`cat linuxinfo | cut -d'.' -f1`
+- LINUX_MINOR=`cat linuxinfo | cut -d'.' -f2`
+- LINUX_PATCH=`cat linuxinfo | cut -d'.' -f3`
+- ], [
+- LINUX_MAJOR="0"
+- LINUX_MINOR="0"
+- LINUX_PATCH="0"
+- ], [
+- LINUX_MAJOR="0"
+- LINUX_MINOR="0"
+- LINUX_PATCH="0"
+- ])
+- rm -f linuxinfo
+-
+- if test "$kernelversion" = "2.2"; then
+- KERN="_KRNL_2_2_"
+- AC_MSG_RESULT([2.2])
+- elif test "$kernelversion" = "2.4"; then
+- KERN="_KRNL_2_4_"
+- AC_MSG_RESULT([2.4])
+- elif test "$kernelversion" = "2.6"; then
+- KERN="_KRNL_2_6_"
+- AC_MSG_RESULT([2.6])
+- else
+- AC_MSG_RESULT([$LINUX_MAJOR.$LINUX_MINOR.$LINUX_PATCH])
+- if test "$LINUX_MINOR" = "6"; then
+- KERN="_KRNL_2_6_"
+- elif test "$LINUX_MINOR" = "4"; then
+- KERN="_KRNL_2_4_"
+- else
+- KERN="_KRNL_2_2_"
+- fi
+- if test "$LINUX_MAJOR" = "0" -a "$LINUX_MINOR" = "0" -a "$LINUX_PATCH" = "0"; then
+- AC_MSG_WARN([Cannot determine Linux Kernel version.])
+- fi
+- fi
+-
++KERN="_KRNL_2_6_"
+ AC_SUBST(KERN)
+
+ dnl ----[ Checks for LVS and VRRP support ]----
+-IPVS_SUPPORT="_WITHOUT_LVS_"
+-if test "$enable_lvs" != "no"; then
+- AC_CHECK_HEADER([net/ip_vs.h],
+- [IPVS_SUPPORT="_WITH_LVS_"],
+- [
+- IPVS_SUPPORT="_WITHOUT_LVS_"
+- AC_MSG_WARN([keepalived will be built without LVS support.])
+- ])
+-fi
++IPVS_SUPPORT="_WITH_LVS_"
+
+ if test "$IPVS_SUPPORT" = "_WITHOUT_LVS_" -a "$enable_vrrp" = "no"; then
+ AC_MSG_ERROR([keepalived MUST be compiled at least with LVS or VRRP framework])
+ fi
+
+ dnl ----[ IPVS syncd support probe ]---
+-IPVS_SYNCD="_WITHOUT_IPVS_SYNCD_"
+-if test "$IPVS_SUPPORT" = "_WITH_LVS_"; then
+- AC_MSG_CHECKING([for IPVS syncd support])
+- if test "$KERN" = "_KRNL_2_6_"; then
+- IPVS_SYNCD="_HAVE_IPVS_SYNCD_"
+- elif test "_KRNL_2_4_"; then
+- IPVS_SYNCD="_HAVE_IPVS_SYNCD_"
+- else
+- IPVS_SYNCD="_WITHOUT_IPVS_SYNCD_"
+- fi
+-
+- if test "${IPVS_SUPPORT}" = "_WITHOUT_LVS_" -o "$enable_lvs_syncd" = "no"; then
+- IPVS_SYNCD="_WITHOUT_IPVS_SYNCD_"
+- fi
+-
+- if test "$IPVS_SYNCD" = "_HAVE_IPVS_SYNCD_"; then
+- AC_MSG_RESULT([yes])
+- else
+- AC_MSG_RESULT([no])
+- fi
+-fi
+-
++IPVS_SYNCD="_HAVE_IPVS_SYNCD_"
+ AC_SUBST(IPVS_SYNCD)
+
+ dnl ----[ Checks for kernel netlink support ]----
diff --git a/sys-cluster/keepalived/files/keepalived-1.1.19-gcc44-fixup.patch b/sys-cluster/keepalived/files/keepalived-1.1.19-gcc44-fixup.patch
new file mode 100644
index 000000000000..931027190294
--- /dev/null
+++ b/sys-cluster/keepalived/files/keepalived-1.1.19-gcc44-fixup.patch
@@ -0,0 +1,53 @@
+diff -Nuar keepalived-1.1.19.orig/configure.in keepalived-1.1.19/configure.in
+--- keepalived-1.1.19.orig/configure.in 2009-10-18 04:10:04.429512827 +0000
++++ keepalived-1.1.19/configure.in 2009-10-18 05:23:47.096569655 +0000
+@@ -145,7 +145,7 @@
+ else
+ echo "Use VRRP Framework : No"
+ fi
+-if test "${DFLAGS}" = "-D_DEBUG_"; then
++if test "${DFLAGS}" = "-D_DEBUG_=1"; then
+ echo "Use Debug flags : Yes"
+ else
+ echo "Use Debug flags : No"
+diff -Nuar keepalived-1.1.19.orig/keepalived/check/Makefile.in keepalived-1.1.19/keepalived/check/Makefile.in
+--- keepalived-1.1.19.orig/keepalived/check/Makefile.in 2009-09-28 11:03:47.000000000 +0000
++++ keepalived-1.1.19/keepalived/check/Makefile.in 2009-10-18 05:31:10.359046695 +0000
+@@ -9,7 +9,8 @@
+ INCLUDES = -I../include -I../../lib
+ CFLAGS = @CFLAGS@ @CPPFLAGS@ $(INCLUDES) \
+ -Wall -Wunused -Wstrict-prototypes
+-DEFS = -D$(KERNEL) -D@IPVS_SUPPORT@ -D@IPVS_SYNCD@ -D@VRRP_SUPPORT@ @DFLAGS@
++DEF_EXPNS = @KERN@ @IPVS_SUPPORT@ @IPVS_SYNCD@ @VRRP_SUPPORT@
++DEFS = $(foreach def,$(DEF_EXPNS),-D$(def)=1) @DFLAGS@
+ COMPILE = $(CC) $(CFLAGS) $(DEFS)
+
+ OBJS = check_daemon.o check_data.o check_parser.o \
+diff -Nuar keepalived-1.1.19.orig/keepalived/core/Makefile.in keepalived-1.1.19/keepalived/core/Makefile.in
+--- keepalived-1.1.19.orig/keepalived/core/Makefile.in 2009-09-28 10:56:54.000000000 +0000
++++ keepalived-1.1.19/keepalived/core/Makefile.in 2009-10-18 05:30:23.622384728 +0000
+@@ -8,7 +8,10 @@
+ INCLUDES = -I../include -I../../lib
+ CFLAGS = @CFLAGS@ @CPPFLAGS@ $(INCLUDES) \
+ -Wall -Wunused -Wstrict-prototypes
+-DEFS = -D@KERN@ -D@IPVS_SUPPORT@ -D@VRRP_SUPPORT@ @DFLAGS@
++
++DEF_EXPNS = @KERN@ @IPVS_SUPPORT@ @VRRP_SUPPORT@
++DEFS = $(foreach def,$(DEF_EXPNS),-D$(def)=1) @DFLAGS@
++
+ COMPILE = $(CC) $(CFLAGS) $(DEFS)
+
+ OBJS = main.o daemon.o pidfile.o layer4.o smtp.o \
+diff -Nuar keepalived-1.1.19.orig/keepalived/vrrp/Makefile.in keepalived-1.1.19/keepalived/vrrp/Makefile.in
+--- keepalived-1.1.19.orig/keepalived/vrrp/Makefile.in 2009-09-28 10:56:54.000000000 +0000
++++ keepalived-1.1.19/keepalived/vrrp/Makefile.in 2009-10-18 05:31:32.520274208 +0000
+@@ -8,7 +8,8 @@
+ INCLUDES = -I../include -I../../lib
+ CFLAGS = @CFLAGS@ @CPPFLAGS@ $(INCLUDES) \
+ -Wall -Wunused -Wstrict-prototypes
+-DEFS = -D@KERN@ -D@IPVS_SUPPORT@ -D@IPVS_SYNCD@ @DFLAGS@
++DEFS_EXPNS = @KERN@ @IPVS_SUPPORT@ @IPVS_SYNCD@
++DEFS = $(foreach def,$(DEF_EXPNS),-D$(def)=1) @DFLAGS@
+ COMPILE = $(CC) $(CFLAGS) $(DEFS)
+
+ OBJS = vrrp_daemon.o vrrp_data.o vrrp_parser.o \
diff --git a/sys-cluster/keepalived/keepalived-1.1.19.ebuild b/sys-cluster/keepalived/keepalived-1.1.19.ebuild
new file mode 100644
index 000000000000..7f6a6d33dac1
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.1.19.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.1.19.ebuild,v 1.1 2009/10/18 05:52:43 robbat2 Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="add a strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug profile"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ =sys-kernel/linux-headers-2.6*"
+
+src_unpack() {
+ unpack ${A}
+
+ # This patch allows us to avoid needing kernel sources for the configure phase
+ EPATCH_OPTS="-p1 -d${S}" epatch \
+ "${FILESDIR}"/${PN}-1.1.19-do-not-need-kernel-sources.patch
+ # Make GCC4.4 happy with the -D usage.
+ EPATCH_OPTS="-p1 -d${S}" epatch \
+ "${FILESDIR}"/${PN}-1.1.19-gcc44-fixup.patch
+
+ cd "${S}"
+ eautoreconf
+
+ # Prepare a suitable copy of the IPVS headers
+ # So that we don't need kernel sources at all!
+ mkdir -p "${S}"/include/net || die "Failed to prepare ipvs header directory"
+ cp -f "${FILESDIR}"/${PN}-1.1.13-linux-2.6.21-ip_vs.h \
+ "${S}"/include/net/ip_vs.h || die "Failed to add ipvs header"
+
+ # Ensure that keepalived can find the header that we are injecting
+ append-flags -I"${S}"/include
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--enable-vrrp"
+
+ # This is not an error
+ # The upstream makefile used to add man/, but doesn't anymore
+ myconf="${myconf} --mandir=/usr/share/man"
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ # disable -fomit-frame-pointer for profiling
+ if use profile; then
+ filter-flags -fomit-frame-pointer
+ myconf="${myconf} --enable-profile"
+ fi
+
+ econf ${myconf} STRIP=/bin/true || die "configure failed"
+ emake || die "emake failed (myconf=${myconf})"
+}
+
+src_install() {
+ # Not parallel safe
+ emake -j1 install DESTDIR="${D}" || die "emake install failed"
+
+ newinitd "${FILESDIR}"/init-keepalived keepalived
+
+ dodoc doc/keepalived.conf.SYNOPSIS
+ dodoc README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Security risk to bundle SSL certs
+ rm -f "${D}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${D}"/etc/sysconfig "${D}"/etc/rc.d/
+}
+
+pkg_postinst() {
+ elog "For internal debug support, compile with USE=debug via package.use"
+}