summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-03-23 19:54:11 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-03-23 19:54:11 +0000
commitcf34d513abf714ab17b4b4b95aac4bffb2af5393 (patch)
treeb54cae5883f4f619f30fa04e79520a4ef9e7f645 /sys-cluster
parentSet IUSE=custom-cflags in the eclass so we can reference it in the die hook. (diff)
downloadgentoo-2-cf34d513abf714ab17b4b4b95aac4bffb2af5393.tar.gz
gentoo-2-cf34d513abf714ab17b4b4b95aac4bffb2af5393.tar.bz2
gentoo-2-cf34d513abf714ab17b4b4b95aac4bffb2af5393.zip
[sys-cluster/ceph] Version bump
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ChangeLog7
-rw-r--r--sys-cluster/ceph/ceph-0.44.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 41b7902eacb4..f51332d601a6 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.18 2012/03/11 14:47:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.19 2012/03/23 19:54:11 alexxy Exp $
+
+*ceph-0.44 (23 Mar 2012)
+
+ 23 Mar 2012; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.44.ebuild:
+ [sys-cluster/ceph] Version bump
11 Mar 2012; Agostino Sarubbo <ago@gentoo.org> ceph-0.41.ebuild:
Stable for amd64, wrt bug #369625
diff --git a/sys-cluster/ceph/ceph-0.44.ebuild b/sys-cluster/ceph/ceph-0.44.ebuild
new file mode 100644
index 000000000000..f7cd0a77050a
--- /dev/null
+++ b/sys-cluster/ceph/ceph-0.44.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.44.ebuild,v 1.1 2012/03/23 19:54:11 alexxy Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="http://ceph.newdream.net/"
+SRC_URI="http://ceph.newdream.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fuse gtk libatomic radosgw static-libs tcmalloc"
+
+CDEPEND="
+ dev-libs/boost
+ dev-libs/libedit
+ dev-libs/crypto++
+ sys-apps/keyutils
+ fuse? ( sys-fs/fuse )
+ libatomic? ( dev-libs/libatomic_ops )
+ gtk? (
+ x11-libs/gtk+:2
+ dev-cpp/gtkmm:2.4
+ gnome-base/librsvg
+ )
+ radosgw? (
+ dev-libs/fcgi
+ dev-libs/expat
+ )
+ tcmalloc? ( dev-util/google-perftools )
+ "
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ sys-fs/btrfs-progs"
+
+STRIP_MASK="/usr/lib*/rados-classes/*"
+
+src_prepare() {
+ sed -e 's:invoke-rc\.d.*:/etc/init.d/ceph reload >/dev/null:' \
+ -i src/logrotate.conf || die
+ sed -i "/^docdir =/d" src/Makefile.am || die #fix doc path
+ # disable testsnaps
+ sed -e '/testsnaps/d' -i src/Makefile.am || die
+ sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
+ > "${T}"/${PN}.initd || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-hadoop \
+ --docdir=/usr/share/doc/${PF} \
+ --includedir=/usr/include \
+ $(use_with debug) \
+ $(use_with fuse) \
+ $(use_with libatomic libatomic-ops) \
+ $(use_with radosgw) \
+ $(use_with gtk gtk2) \
+ $(use_enable static-libs static) \
+ $(use_with tcmalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -type f -name "*.la" -exec rm -f {} \;
+
+ rmdir "${D}/usr/sbin"
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe src/init-ceph ceph_init.sh
+
+ insinto /etc/logrotate.d/
+ newins src/logrotate.conf ${PN}
+
+ chmod 644 "${D}"/usr/share/doc/${PF}/sample.*
+
+ keepdir /var/lib/${PN}
+ keepdir /var/lib/${PN}/tmp
+ keepdir /var/log/${PN}/stat
+
+ newinitd "${T}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}