summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2010-08-05 04:03:10 +0000
committerJustin Bronder <jsbronder@gentoo.org>2010-08-05 04:03:10 +0000
commitaa6932070f0ba14088360ea28b017bc30d4a2c5b (patch)
tree5d1f2c975001038d60da8e2363f56e3c3c8f6d16 /sys-cluster
parentRename the init and env files, the versioning hasn't made sense for a while. (diff)
downloadgentoo-2-aa6932070f0ba14088360ea28b017bc30d4a2c5b.tar.gz
gentoo-2-aa6932070f0ba14088360ea28b017bc30d4a2c5b.tar.bz2
gentoo-2-aa6932070f0ba14088360ea28b017bc30d4a2c5b.zip
Fix #313045, add missing libs during linking
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/ChangeLog9
-rw-r--r--sys-cluster/mpich2/files/mpich2-1.2.1-fix-missing-libs.patch33
-rw-r--r--sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild (renamed from sys-cluster/mpich2/mpich2-1.2.1_p1.ebuild)4
3 files changed, 44 insertions, 2 deletions
diff --git a/sys-cluster/mpich2/ChangeLog b/sys-cluster/mpich2/ChangeLog
index 0bdba2c559c6..9c10971833ef 100644
--- a/sys-cluster/mpich2/ChangeLog
+++ b/sys-cluster/mpich2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/mpich2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.56 2010/07/08 12:58:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/ChangeLog,v 1.57 2010/08/05 04:03:09 jsbronder Exp $
+
+*mpich2-1.2.1_p1-r1 (05 Aug 2010)
+
+ 05 Aug 2010; Justin Bronder <jsbronder@gentoo.org>
+ -mpich2-1.2.1_p1.ebuild, +mpich2-1.2.1_p1-r1.ebuild,
+ +files/mpich2-1.2.1-fix-missing-libs.patch:
+ Fix #313045, add missing libs during linking
08 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
mpich2-1.2.1_p1.ebuild:
diff --git a/sys-cluster/mpich2/files/mpich2-1.2.1-fix-missing-libs.patch b/sys-cluster/mpich2/files/mpich2-1.2.1-fix-missing-libs.patch
new file mode 100644
index 000000000000..1f2ba04cfe1c
--- /dev/null
+++ b/sys-cluster/mpich2/files/mpich2-1.2.1-fix-missing-libs.patch
@@ -0,0 +1,33 @@
+From 94707148dc8c33a1d3245e1f0dd7e28542f91e75 Mon Sep 17 00:00:00 2001
+From: Steve Arnold <nerdboy@gentoo.org>
+Date: Wed, 4 Aug 2010 23:34:06 -0400
+Subject: [PATCH] Added missing library references for the f90 and C++ shared libraries
+
+Backport of upstream r6848. Directly modifies the Makefile.in to avoid
+having to call simplemake to regenerate the entire build system.
+
+http://trac.mcs.anl.gov/projects/mpich2/changeset/6848
+---
+ Makefile.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index cbe4a93..d12babb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -143,10 +143,10 @@ lib/libf${MPILIBNAME}.@SHLIB_EXT@: lib/libf${MPILIBNAME}.la
+ (cd lib && $(CREATESHLIB) --mode=link -version-info "@ABIVERSION@" -o libf${MPILIBNAME}.la -rpath $(libdir) -L. -l$(MPILIBNAME) -ldflags "$(LDFLAGS)" $(LIBS))
+ # Build the shared library from the shared object files
+ lib/lib${MPILIBNAME}f90.@SHLIB_EXT@: lib/lib${MPILIBNAME}f90.la
+- (cd lib && $(CREATESHLIB) --mode=link -version-info "@ABIVERSION@" -o lib${MPILIBNAME}f90.la -rpath $(libdir) -ldflags "$(LDFLAGS)" $(LIBS))
++ (cd lib && $(CREATESHLIB) --mode=link -version-info "@ABIVERSION@" -o lib${MPILIBNAME}f90.la -rpath $(libdir) -L. -l$(MPILIBNAME) -ldflags "$(LDFLAGS)" $(LIBS))
+ # Build the shared library from the shared object files
+ lib/lib${MPICXXLIBNAME}.@SHLIB_EXT@: lib/lib${MPICXXLIBNAME}.la
+- (cd lib && $(CREATESHLIB) --mode=link -version-info "@ABIVERSION@" -o lib${MPICXXLIBNAME}.la -rpath $(libdir) -ldflags "$(LDFLAGS)" $(LIBS))
++ (cd lib && $(CREATESHLIB) --mode=link -version-info "@ABIVERSION@" -o lib${MPICXXLIBNAME}.la -rpath $(libdir) -L. -l$(MPILIBNAME) -ldflags "$(LDFLAGS)" $(LIBS))
+
+ # --------------------------------------------------------------------------
+ .libstamp0:
+--
+1.7.1
+
diff --git a/sys-cluster/mpich2/mpich2-1.2.1_p1.ebuild b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
index 6f2b3609572d..3be1a71f8f39 100644
--- a/sys-cluster/mpich2/mpich2-1.2.1_p1.ebuild
+++ b/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1.ebuild,v 1.5 2010/07/08 12:58:23 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich2/mpich2-1.2.1_p1-r1.ebuild,v 1.1 2010/08/05 04:03:08 jsbronder Exp $
EAPI=2
PYTHON_DEPEND="2"
@@ -54,6 +54,8 @@ src_prepare() {
epatch "${FILESDIR}"/0002-mpd_conf_file-search-order.patch
# Upstream trunk, r5845
epatch "${FILESDIR}"/0003-Fix-pkgconfig-for-mpich2-ch3-v1.2.1.patch
+ # Upstream trunk, r6848 #313045
+ epatch "${FILESDIR}"/mpich2-1.2.1-fix-missing-libs.patch
# We need f90 to include the directory with mods, and to
# fix hardcoded paths for src_test()