summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-10-08 00:17:14 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-10-08 00:17:14 +0000
commit79dae3b55c0378a0ff011bfba38e84ec43b3ba1a (patch)
treeff744b1a3bf98d0954486a037080e3bf297a167f /sys-cluster
parentAdd patch for duplicated inbox/sent-mail folders after kmail 1->2 migration, ... (diff)
downloadgentoo-2-79dae3b55c0378a0ff011bfba38e84ec43b3ba1a.tar.gz
gentoo-2-79dae3b55c0378a0ff011bfba38e84ec43b3ba1a.tar.bz2
gentoo-2-79dae3b55c0378a0ff011bfba38e84ec43b3ba1a.zip
Revision bump, fixes stack smashing due to a silly typo, bug 371903.
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ipvsadm/ChangeLog8
-rw-r--r--sys-cluster/ipvsadm/files/ipvsadm-1.26-stack_smashing.patch32
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild (renamed from sys-cluster/ipvsadm/ipvsadm-1.26-r1.ebuild)3
3 files changed, 41 insertions, 2 deletions
diff --git a/sys-cluster/ipvsadm/ChangeLog b/sys-cluster/ipvsadm/ChangeLog
index 9d9ae6d4923c..da03a0f13188 100644
--- a/sys-cluster/ipvsadm/ChangeLog
+++ b/sys-cluster/ipvsadm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ipvsadm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ChangeLog,v 1.54 2011/10/07 20:33:04 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ChangeLog,v 1.55 2011/10/08 00:17:14 idl0r Exp $
+
+*ipvsadm-1.26-r2 (08 Oct 2011)
+
+ 08 Oct 2011; Christian Ruppert <idl0r@gentoo.org> -ipvsadm-1.26-r1.ebuild,
+ +ipvsadm-1.26-r2.ebuild, +files/ipvsadm-1.26-stack_smashing.patch:
+ Revision bump, fixes stack smashing due to a silly typo, bug 371903.
*ipvsadm-1.24 (07 Oct 2011)
diff --git a/sys-cluster/ipvsadm/files/ipvsadm-1.26-stack_smashing.patch b/sys-cluster/ipvsadm/files/ipvsadm-1.26-stack_smashing.patch
new file mode 100644
index 000000000000..d36b0bf8abe4
--- /dev/null
+++ b/sys-cluster/ipvsadm/files/ipvsadm-1.26-stack_smashing.patch
@@ -0,0 +1,32 @@
+From 81529af388c0f0f4e4b169b7bcb285ef5e798f41 Mon Sep 17 00:00:00 2001
+From: Christian Ruppert <idl0r@gentoo.org>
+Date: Sat, 8 Oct 2011 02:05:37 +0200
+Subject: [PATCH] Fix stack smashing because of a typo
+
+IPVS_CMD_ATTR_MAX was the size of __IPVS_SVC_ATTR_MAX before, which has a
+different size and thus it caused trouble. The right enum to use is
+__IPVS_CMD_ATTR_MAX.
+
+Reported-by: Deniss Gaplevsky <slim@inbox.lv>
+X-Gentoo-Bug: 371903
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/371903
+---
+ libipvs/ip_vs.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/libipvs/ip_vs.h b/libipvs/ip_vs.h
+index 9726a17..5e1d544 100644
+--- a/libipvs/ip_vs.h
++++ b/libipvs/ip_vs.h
+@@ -413,7 +413,7 @@ enum {
+ __IPVS_CMD_ATTR_MAX,
+ };
+
+-#define IPVS_CMD_ATTR_MAX (__IPVS_SVC_ATTR_MAX - 1)
++#define IPVS_CMD_ATTR_MAX (__IPVS_CMD_ATTR_MAX - 1)
+
+ /*
+ * Attributes used to describe a service
+--
+1.7.3.4
+
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.26-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild
index 8507ace5fd97..f51fbb1c4a66 100644
--- a/sys-cluster/ipvsadm/ipvsadm-1.26-r1.ebuild
+++ b/sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.26-r1.ebuild,v 1.6 2011/09/10 09:02:31 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ipvsadm/ipvsadm-1.26-r2.ebuild,v 1.1 2011/10/08 00:17:14 idl0r Exp $
EAPI=4
@@ -30,6 +30,7 @@ pkg_pretend() {
src_prepare() {
epatch "${FILESDIR}"/${P}-buildsystem.patch
+ epatch "${FILESDIR}/${P}-stack_smashing.patch" # bug 371903
use static-libs && export STATIC=1
}