summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-04-20 19:33:40 +0000
committerChristian Heim <phreak@gentoo.org>2006-04-20 19:33:40 +0000
commit576d3b5e152a06131051c34535317c4f608182b4 (patch)
tree53c9ce58bb948c8e8f124698e685934f0cdc78c1 /sys-cluster/vzctl
parentNew revision with the altered version, see ChangeLog, bug #130160. (diff)
downloadgentoo-2-576d3b5e152a06131051c34535317c4f608182b4.tar.gz
gentoo-2-576d3b5e152a06131051c34535317c4f608182b4.tar.bz2
gentoo-2-576d3b5e152a06131051c34535317c4f608182b4.zip
Version bump (vzctl should now support live migration); vzctl is now licensed under GPL-2\!
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.0.76
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.0.7.ebuild74
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 8894d3846775..47ca6161faae 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.19 2006/04/11 11:07:29 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.20 2006/04/20 19:33:40 phreak Exp $
+
+*vzctl-3.0.0.7 (20 Apr 2006)
+
+ 20 Apr 2006; Christian Heim <phreak@gentoo.org> +vzctl-3.0.0.7.ebuild:
+ Version bump (openvz-sources should now support live migration);
+ vzctl is now licensed under GPL-2!
11 Apr 2006; Christian Heim <phreak@gentoo.org> vzctl-3.0.0.4.ebuild:
Marking vzctl-3.0.0.4 stable on amd64/x86
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.0.7 b/sys-cluster/vzctl/files/digest-vzctl-3.0.0.7
new file mode 100644
index 000000000000..05ab9ceb5d7e
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.0.7
@@ -0,0 +1,6 @@
+MD5 7a1c65dcc0dcd4f6930e96495c09ddc5 vzctl-3.0.0-7.tar.bz2 114219
+RMD160 f2f0ab5c5ef52ed9f82086539c83ba45a6612bc6 vzctl-3.0.0-7.tar.bz2 114219
+SHA256 b06b647d62f8b5d8c924f3e9b2ecf4716a38b5ae1292a8338692b9c528e18a29 vzctl-3.0.0-7.tar.bz2 114219
+MD5 dae7b93a4b79f75c8927cfdd47e6102f vzctl-3.0.0.7-patches-r0.tar.bz2 3822
+RMD160 81ef3c67b2e585bd4cb2094252614290623db647 vzctl-3.0.0.7-patches-r0.tar.bz2 3822
+SHA256 29f6f89c17ea8bedbe5e35fcb60731cfafbcccb9d2336b126968a9f586358006 vzctl-3.0.0.7-patches-r0.tar.bz2 3822
diff --git a/sys-cluster/vzctl/vzctl-3.0.0.7.ebuild b/sys-cluster/vzctl/vzctl-3.0.0.7.ebuild
new file mode 100644
index 000000000000..b77720fc67ac
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.0.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.0.7.ebuild,v 1.1 2006/04/20 19:33:40 phreak Exp $
+
+inherit eutils toolchain-funcs versionator linux-info
+
+VVER="$(get_version_component_range 1-3 ${PV})"
+VREL="$(get_version_component_range 4 ${PV})"
+MY_PV="${VVER}-${VREL}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${MY_PV}/src/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PR}.tar.bz2
+ http://dev.gentoo.org/~hollow/distfiles/${P}-patches-${PR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/logrotate
+ app-shells/bash
+ sys-apps/sed
+ sys-apps/ed
+ sys-apps/grep
+ sys-apps/gawk
+ sys-apps/coreutils
+ net-firewall/iptables
+ app-arch/tar
+ sys-fs/vzquota
+ sys-process/procps
+ sys-apps/iproute2"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="FAIRSCHED VE VE_CALLS VE_NETDEV VE_IPTABLES"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ check_kernel_built
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-gentoo_conf_d.patch
+ epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-gentoo_etc_vz.patch
+
+ # fix hardcoded lib paths
+ use amd64 && epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-amd64.patch
+}
+
+src_compile() {
+ emake VZKERNEL_HEADERS=${KV_DIR}/include || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" VZCONFDIR=/etc/conf.d/ install || die "make install failed"
+
+ # sysconfig is vendor specific
+ rm -rf ${D}/etc/sysconfig
+
+ # Install gentoo specific init script
+ rm -f ${D}/etc/init.d/*
+ newinitd ${FILESDIR}/vz.initd vz
+
+ # Fix permissions on cron.d files
+ chmod 0644 ${D}/etc/cron.d/*
+}