summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-04-23 14:31:44 +0000
committerMichael Imhof <tantive@gentoo.org>2004-04-23 14:31:44 +0000
commitb05a944ba9ae64e56473aa919d19d14fcac31fb7 (patch)
tree1c3ea1f96356641b47c6f04cd560241b4297dde5 /sys-cluster/torque
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-b05a944ba9ae64e56473aa919d19d14fcac31fb7.tar.gz
gentoo-2-b05a944ba9ae64e56473aa919d19d14fcac31fb7.tar.bz2
gentoo-2-b05a944ba9ae64e56473aa919d19d14fcac31fb7.zip
New ebuild. Submitted by Joseph Spadavecchia <j.spadavecchia@ed.ac.uk>.
Diffstat (limited to 'sys-cluster/torque')
-rw-r--r--sys-cluster/torque/ChangeLog10
-rw-r--r--sys-cluster/torque/Manifest3
-rw-r--r--sys-cluster/torque/files/digest-torque-1.0.1-r61
-rw-r--r--sys-cluster/torque/files/pbs.rc88
-rw-r--r--sys-cluster/torque/torque-1.0.1-r6.ebuild61
5 files changed, 163 insertions, 0 deletions
diff --git a/sys-cluster/torque/ChangeLog b/sys-cluster/torque/ChangeLog
new file mode 100644
index 000000000000..3cf39f856a49
--- /dev/null
+++ b/sys-cluster/torque/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-cluster/torque
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/ChangeLog,v 1.1 2004/04/23 14:31:44 tantive Exp $
+
+*torque-1.0.1-r6 (23 Apr 2004)
+
+ 23 Apr 2004; Michael Imhof <tantive@gentoo.org> torque-1.0.1-r6.ebuild, files/pbs.rc:
+ New ebuild. Submitted by Joseph Spadavecchia <j.spadavecchia@ed.ac.uk>.
+ Closes #47986.
+
diff --git a/sys-cluster/torque/Manifest b/sys-cluster/torque/Manifest
new file mode 100644
index 000000000000..ecb431e52651
--- /dev/null
+++ b/sys-cluster/torque/Manifest
@@ -0,0 +1,3 @@
+MD5 54e671ad9c27eefe20d54207f95b6ad4 torque-1.0.1-r6.ebuild 1803
+MD5 e1baa6137118011e3c37ea4525b1fcce files/pbs.rc 2146
+MD5 49d4d243a6dd96ba20531b240a7a32b6 files/digest-torque-1.0.1-r6 67
diff --git a/sys-cluster/torque/files/digest-torque-1.0.1-r6 b/sys-cluster/torque/files/digest-torque-1.0.1-r6
new file mode 100644
index 000000000000..2bb2c16ed385
--- /dev/null
+++ b/sys-cluster/torque/files/digest-torque-1.0.1-r6
@@ -0,0 +1 @@
+MD5 66f479ae8ad02cc77b00d4057bae2f9e torque-1.0.1p6.tar.gz 2063729
diff --git a/sys-cluster/torque/files/pbs.rc b/sys-cluster/torque/files/pbs.rc
new file mode 100644
index 000000000000..9932bfde076f
--- /dev/null
+++ b/sys-cluster/torque/files/pbs.rc
@@ -0,0 +1,88 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+opts="start stop restart"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+
+ HOSTNAME=`hostname`
+
+ if [ ! -e /usr/spool/PBS/server_name ] ; then
+ eerror "Missing config file /usr/spool/PBS/server_name"
+ return 1
+ else
+ PBS_SERVER_NAME=`cat /usr/spool/PBS/server_name`
+ if [ ${HOSTNAME} == ${PBS_SERVER_NAME} ] ; then
+ PBS_START_SERVER=1;
+ else
+ PBS_START_SERVER=0;
+ fi
+ fi
+
+ if [ ! -e /usr/spool/PBS/mom_priv/config ] ; then
+ eerror "Missing config file /usr/spool/PBS/mom_priv/config"
+ return 1
+ else
+ PBS_START_MOM=1;
+ fi
+
+ if [ "${PBS_START_SERVER}" -eq 1 ] ; then
+ if [ ! -e /usr/spool/PBS/server_priv/nodes ] ; then
+ eerror "The startup script has detected this node is a server"
+ eerror "from the file /usr/spool/PBS/server_name,"
+ eerror "but the config file /usr/spool/PBS/server_priv/nodes is missing"
+ return 1
+ fi
+ fi
+
+}
+
+start() {
+ checkconfig || return 1
+
+ if [ "${PBS_START_MOM}" -gt 0 ] ; then
+ ebegin "Starting pbs_mom"
+ start-stop-daemon --start --pidfile /usr/spool/PBS/mom_priv/mom.lock \
+ --startas /usr/sbin/pbs_mom
+ fi
+
+ if [ "${PBS_START_SERVER}" -gt 0 ] ; then
+ ebegin "Starting pbs_server"
+ start-stop-daemon --start --quiet --pidfile /usr/spool/PBS/server_priv/server.lock \
+ --startas /usr/sbin/pbs_server
+ ebegin "Starting pbs_sched"
+ start-stop-daemon --start --quiet --pidfile /usr/run/pbs_sched.pid \
+ --startas /usr/sbin/pbs_sched
+ fi
+
+ eend $?
+}
+
+stop() {
+ if [ -e /usr/spool/PBS/mom_priv/mom.lock ] ; then
+ ebegin "Stopping pbs_mom"
+ start-stop-daemon --stop --pidfile /usr/spool/PBS/mom_priv/mom.lock
+ rm -f /usr/spool/PBS/mom_priv/mom.lock
+ fi
+
+ if [ -e /usr/spool/PBS/server_priv/server.lock ] ; then
+ ebegin "Stopping pbs_server"
+ qterm -t immediate
+ rm -f /usr/spool/PBS/server_priv/server.lock
+ fi
+
+ if [ -e /usr/spool/PBS/sched_priv/sched.lock ] ; then
+ ebegin "Stopping pbs_sched"
+ start-stop-daemon --stop --pidfile /usr/spool/PBS/sched_priv/sched.lock
+ rm -f /usr/spool/PBS/sched_priv/sched.lock
+ fi
+
+ sleep 3
+
+ eend $?
+}
diff --git a/sys-cluster/torque/torque-1.0.1-r6.ebuild b/sys-cluster/torque/torque-1.0.1-r6.ebuild
new file mode 100644
index 000000000000..8a4a94a034f8
--- /dev/null
+++ b/sys-cluster/torque/torque-1.0.1-r6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+S=${WORKDIR}/`echo ${A} | sed -e 's/\.tar\.gz//g'`
+
+DESCRIPTION="A freely downloadable cluster resource manager and queueing system based on OpenPBS"
+HOMEPAGE="http://www.supercluster.org/torque/"
+SRC_URI="http://supercluster.org/downloads/torque/torque-1.0.1p6.tar.gz"
+LICENSE="openpbs"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="X tcltk"
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )
+ tcltk? ( dev-lang/tcl )"
+RDEPEND="net-misc/openssh"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ # this thing doesn't use make install, but rather it's own install script
+ # fix it here so the install dirs are set to the ${D} directory
+ cd buildutils
+ mv pbs_mkdirs.in pbs_mkdirs.in-orig
+ sed -e "s|prefix=@prefix@|prefix=\${D}@prefix@| ; \
+ s|PBS_SERVER_HOME=@PBS_SERVER_HOME@|PBS_SERVER_HOME=\${D}@PBS_SERVER_HOME@| ; \
+ s|PBS_DEFAULT_FILE=@PBS_DEFAULT_FILE@|PBS_DEFAULT_FILE=\${D}@PBS_DEFAULT_FILE@| ; \
+ s|PBS_ENVIRON=@PBS_ENVIRON@|PBS_ENVIRON=\${D}@PBS_ENVIRON@|" \
+ pbs_mkdirs.in-orig > pbs_mkdirs.in
+}
+
+src_compile() {
+ local myconf
+ use X || myconf="--disable-gui"
+ use tcltk && myconf="${myconf} --with-tcl"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-docs \
+ --enable-server \
+ --enable-mom \
+ --enable-clients \
+ --set-server-home=/usr/spool/PBS \
+ --set-environ=/etc/pbs_environment || die "./configure failed"
+
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ PBS_SERVER_HOME=${D}/usr/spool/PBS \
+ install || die
+
+ dodoc INSTALL PBS_License.text Read.Me Release_Notes
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pbs.rc pbs
+}