summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-19 18:12:39 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-19 18:12:39 +0000
commit67f23684110106a4d4fe99be7bca992083c8622c (patch)
tree7be5e8f9d081e8431fcb6ce26368779e06c3c2c8 /sys-cluster/openmpi
parentVersion bump. (diff)
downloadgentoo-2-67f23684110106a4d4fe99be7bca992083c8622c.tar.gz
gentoo-2-67f23684110106a4d4fe99be7bca992083c8622c.tar.bz2
gentoo-2-67f23684110106a4d4fe99be7bca992083c8622c.zip
Fix for EPREFIX with whitespaces, thanks Arfrever for help
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog6
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.1.ebuild23
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.2.ebuild27
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild25
4 files changed, 41 insertions, 40 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 26076f846e58..551b52984e1c 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.76 2010/12/16 15:59:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.77 2010/12/19 18:12:39 jlec Exp $
+
+ 19 Dec 2010; Justin Lecher <jlec@gentoo.org> openmpi-1.4.1.ebuild,
+ openmpi-1.4.2.ebuild, openmpi-1.4.3.ebuild:
+ Fix for EPREFIX with whitespaces, thanks Arfrever for help
16 Dec 2010; Justin Lecher <jlec@gentoo.org> openmpi-1.4.1.ebuild,
openmpi-1.4.2.ebuild, openmpi-1.4.3.ebuild:
diff --git a/sys-cluster/openmpi/openmpi-1.4.1.ebuild b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
index 8e25c443df6d..c3186de2f7ef 100644
--- a/sys-cluster/openmpi/openmpi-1.4.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.11 2010/12/19 17:51:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.12 2010/12/19 18:12:39 jlec Exp $
EAPI=2
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -58,17 +58,17 @@ src_prepare() {
}
src_configure() {
- local myconf="
+ local myconf=(
--sysconfdir=/etc/${PN}
--without-xgrid
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
- --without-slurm"
+ --without-slurm)
if use mpi-threads; then
- myconf="${myconf}
+ myconf+=(${myconf}
--enable-mpi-threads
- --enable-progress-threads"
+ --enable-progress-threads)
fi
if use fortran; then
@@ -76,28 +76,27 @@ src_configure() {
myconf="${myconf} --disable-mpi-f90"
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
+ myconf+=(${myconf} --with-mpi-f90-size=medium)
fi
else
- myconf="${myconf}
+ myconf+=(${myconf}
--disable-mpi-f90
- --disable-mpi-f77"
+ --disable-mpi-f77)
fi
- ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
+ ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
$(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
+ $(use_enable ipv6)
}
src_install () {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
+ dodoc README AUTHORS NEWS VERSION || die
}
src_test() {
diff --git a/sys-cluster/openmpi/openmpi-1.4.2.ebuild b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
index 44024f00eccf..8919802f4f31 100644
--- a/sys-cluster/openmpi/openmpi-1.4.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.9 2010/12/19 17:51:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.10 2010/12/19 18:12:39 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -54,46 +54,45 @@ src_prepare() {
}
src_configure() {
- local myconf="
- --sysconfdir="${EPREFIX}/etc/${PN}"
+ local myconf=(
+ --sysconfdir=${EPREFIX}/etc/${PN}
--without-xgrid
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
- --without-slurm"
+ --without-slurm)
if use mpi-threads; then
- myconf="${myconf}
+ myconf+=(${myconf}
--enable-mpi-threads
- --enable-progress-threads"
+ --enable-progress-threads)
fi
if use fortran; then
if [[ $(tc-getFC) =~ g77 ]]; then
- myconf="${myconf} --disable-mpi-f90"
+ myconf+=(${myconf} --disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
+ myconf+=(${myconf} --with-mpi-f90-size=medium)
fi
else
- myconf="${myconf}
+ myconf+=(${myconf}
--disable-mpi-f90
- --disable-mpi-f77"
+ --disable-mpi-f77)
fi
- ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
+ ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
$(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
+ $(use_enable ipv6)
}
src_install () {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
+ dodoc README AUTHORS NEWS VERSION || die
}
src_test() {
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index bced64769119..4c3b4177c385 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.4 2010/12/19 17:51:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.5 2010/12/19 18:12:39 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -54,45 +54,44 @@ src_prepare() {
}
src_configure() {
- local myconf="
+ local myconf=(
--sysconfdir="${EPREFIX}/etc/${PN}"
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
- --without-slurm"
+ --without-slurm)
if use mpi-threads; then
- myconf="${myconf}
+ myconf+=(${myconf}
--enable-mpi-threads
- --enable-progress-threads"
+ --enable-progress-threads)
fi
if use fortran; then
if [[ $(tc-getFC) =~ g77 ]]; then
- myconf="${myconf} --disable-mpi-f90"
+ myconf+=(${myconf} --disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
+ myconf+=(${myconf} --with-mpi-f90-size=medium)
fi
else
- myconf="${myconf}
+ myconf+=(${myconf}
--disable-mpi-f90
- --disable-mpi-f77"
+ --disable-mpi-f77)
fi
- ! use vt && myconf="${myconf} --enable-contrib-no-build=vt"
+ ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
$(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
+ $(use_enable ipv6)
}
src_install () {
emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
+ dodoc README AUTHORS NEWS VERSION || die
}
src_test() {