summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-01-27 01:15:58 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-01-27 01:15:58 +0000
commita2af3690de7f35cf243667184dc1cf9b81c8bf6b (patch)
tree0f28e7520e57c916b2b40bd8a4f47d2180e3b178 /sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild
parentrevision bump, NTSC fixes (diff)
downloadgentoo-2-a2af3690de7f35cf243667184dc1cf9b81c8bf6b.tar.gz
gentoo-2-a2af3690de7f35cf243667184dc1cf9b81c8bf6b.tar.bz2
gentoo-2-a2af3690de7f35cf243667184dc1cf9b81c8bf6b.zip
new in portage
Diffstat (limited to 'sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild')
-rw-r--r--sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild b/sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild
new file mode 100644
index 000000000000..7458d84f955e
--- /dev/null
+++ b/sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/feedbackd-master/feedbackd-master-0.4.ebuild,v 1.1 2005/01/27 01:15:58 xmerlin Exp $
+
+inherit eutils
+
+DESCRIPTION="Feedbackd is a client/server system that provides dynamic feedback of server
+load in a Linux Virtual Server (LVS)-based cluster. Monitor plugins are used to
+measure the health of each server, allowing a flexible way to report load back
+to the load balancer. It also facilitates the addition and removal of servers
+from the cluster.
+
+This is the master process for feedbackd, which is run on the LVS director."
+
+HOMEPAGE="http://www.redfishsoftware.com.au/projects/feedbackd/"
+LICENSE="GPL-2"
+DEPEND="virtual/libc
+ >=dev-libs/libxml2
+ >=sys-cluster/ipvsadm
+ >=dev-lang/perl"
+
+SRC_URI="mirror://sourceforge/feedbackd/${P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="x86"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ einfo "Note: feedbackd-master needs a kernel with ipvs support and with ipvs enabled"
+
+ econf \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ || die "bad ./configure"
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog NEWS README
+}