summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-03-20 14:47:36 +0000
committerYixun Lan <dlan@gentoo.org>2015-03-20 14:47:36 +0000
commitc4ad2ea38802998b4cf26919e428741ef2186f98 (patch)
tree794932fafee592886eced211a5418a871acb843f /sys-boot
parentFix ebuild layout (diff)
downloadgentoo-2-c4ad2ea38802998b4cf26919e428741ef2186f98.tar.gz
gentoo-2-c4ad2ea38802998b4cf26919e428741ef2186f98.tar.bz2
gentoo-2-c4ad2ea38802998b4cf26919e428741ef2186f98.zip
version bump, update to gtk3 dep, add systemdunit patch, proxy for Enrico Tagliavini
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/plymouth/ChangeLog11
-rw-r--r--sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch18
-rw-r--r--sys-boot/plymouth/plymouth-0.9.2.ebuild101
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild8
4 files changed, 132 insertions, 6 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index 4116a5c6a6a6..ce228a7ff9d5 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/plymouth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.52 2014/07/06 18:16:51 maksbotan Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.53 2015/03/20 14:47:36 dlan Exp $
+
+*plymouth-0.9.2 (20 Mar 2015)
+
+ 20 Mar 2015; Yixun Lan <dlan@gentoo.org> +plymouth-0.9.2.ebuild,
+ plymouth-9999.ebuild, +files/0.9.2-systemdsystemunitdir.patch:
+ version bump, update to gtk3 dep, add systemdunit patch, proxy for Enrico
+ Tagliavini
*plymouth-0.9.0 (06 Jul 2014)
*plymouth-9999 (06 Jul 2014)
diff --git a/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch b/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch
new file mode 100644
index 000000000000..b5289244232a
--- /dev/null
+++ b/sys-boot/plymouth/files/0.9.2-systemdsystemunitdir.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.ac b/configure.ac
+index aad673e..592be5f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -122,7 +122,12 @@ AM_CONDITIONAL(ENABLE_SYSTEMD_INTEGRATION, [test "$enable_systemd_integration" =
+
+ if test x$enable_systemd_integration = xyes; then
+ AC_DEFINE(PLY_ENABLE_SYSTEMD_INTEGRATION, 1, [Coordinate boot up with systemd])
+- SYSTEMD_UNIT_DIR=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
++ AC_ARG_WITH([systemdsystemunitdir], AC_HELP_STRING([--with-systemdsystemunitdir=DIR],
++ [path to systemd service directory]), [path_systemdunit=${withval}],
++ [path_systemdunit="`$PKG_CONFIG --variable=systemdsystemunitdir systemd`"])
++ if (test -n "${path_systemdunit}"); then
++ SYSTEMD_UNIT_DIR="${path_systemdunit}"
++ fi
+ AC_SUBST(SYSTEMD_UNIT_DIR)
+ fi
+
diff --git a/sys-boot/plymouth/plymouth-0.9.2.ebuild b/sys-boot/plymouth/plymouth-0.9.2.ebuild
new file mode 100644
index 000000000000..d41af507abb6
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.9.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.9.2.ebuild,v 1.1 2015/03/20 14:47:36 dlan Exp $
+
+EAPI=5
+
+SRC_URI="
+ http://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
+
+AUTOTOOLS_AUTORECONF="1"
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/plymouth"
+ inherit git-r3
+else
+ SRC_URI="${SRC_URI} http://www.freedesktop.org/software/plymouth/releases/${P}.tar.bz2"
+fi
+
+inherit autotools-utils readme.gentoo systemd toolchain-funcs
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gdm +gtk +libkms +pango static-libs"
+
+CDEPEND="
+ >=media-libs/libpng-1.2.16:=
+ gtk? (
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.14:3
+ x11-libs/cairo )
+ libkms? ( x11-libs/libdrm[libkms] )
+ pango? ( >=x11-libs/pango-1.21 )
+"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+"
+# Block due bug #383067
+RDEPEND="${CDEPEND}
+ virtual/udev
+ !<sys-kernel/dracut-0.37-r3
+"
+
+DOC_CONTENTS="
+ Follow the following instructions to set up Plymouth:\n
+ http://dev.gentoo.org/~aidecoe/doc/en/plymouth.xml
+"
+
+PATCHES=(
+ "${FILESDIR}/0.9.2-systemdsystemunitdir.patch"
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-system-root-install=no
+ --localstatedir=/var
+ --without-rhgb-compat-link
+ --enable-systemd-integration
+ "$(systemd_with_unitdir)"
+ $(use_enable debug tracing)
+ $(use_enable gtk gtk)
+ $(use_enable libkms drm)
+ $(use_enable pango)
+ $(use_enable gdm gdm-transition)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /usr/share/plymouth
+ newins "${DISTDIR}"/gentoo-logo.png bizcom.png
+
+ # Install compatibility symlinks as some rdeps hardcode the paths
+ dosym /usr/bin/plymouth /bin/plymouth
+ dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym /usr/sbin/plymouthd /sbin/plymouthd
+
+ readme.gentoo_create_doc
+
+ # looks like make install create /var/run/plymouth
+ # this is not needed for systemd, same should hold for openrc
+ # so remove
+ rm -rf "${D}"/var/run
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ if ! has_version "sys-kernel/dracut" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
+ ewarn "If you want initramfs builder with plymouth support, please emerge"
+ ewarn "sys-kernel/dracut or sys-kernel/genkernel-next[plymouth]."
+ fi
+}
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 11d6ce7427d0..3428ed871e5f 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-9999.ebuild,v 1.1 2014/07/06 18:16:51 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-9999.ebuild,v 1.2 2015/03/20 14:47:36 dlan Exp $
EAPI=5
@@ -27,10 +27,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug gdm +gtk +libkms +pango static-libs"
CDEPEND="
- >=media-libs/libpng-1.2.16
+ >=media-libs/libpng-1.2.16:=
gtk? (
dev-libs/glib:2
- >=x11-libs/gtk+-2.12:2
+ >=x11-libs/gtk+-3.14:3
x11-libs/cairo )
libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )