summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-06-04 02:31:38 +0000
committerSteve Dibb <beandog@gentoo.org>2010-06-04 02:31:38 +0000
commitc49c9461852abc0ab4373964f4cc2973375150f2 (patch)
tree23c9728b5ec117c741529abdd8eedf4565f8aadd /sys-boot
parentInitial commit, bug 309929; thanks to Lucian Muresan and Nikoli for ebuilds (diff)
downloadgentoo-2-c49c9461852abc0ab4373964f4cc2973375150f2.tar.gz
gentoo-2-c49c9461852abc0ab4373964f4cc2973375150f2.tar.bz2
gentoo-2-c49c9461852abc0ab4373964f4cc2973375150f2.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/os-prober/ChangeLog7
-rw-r--r--sys-boot/os-prober/os-prober-1.38.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-boot/os-prober/ChangeLog b/sys-boot/os-prober/ChangeLog
index 136152686a97..e3ff4f025e7d 100644
--- a/sys-boot/os-prober/ChangeLog
+++ b/sys-boot/os-prober/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/os-prober
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.3 2010/03/06 21:25:32 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/ChangeLog,v 1.4 2010/06/04 02:31:38 beandog Exp $
+
+*os-prober-1.38 (04 Jun 2010)
+
+ 04 Jun 2010; Steve Dibb <beandog@gentoo.org> +os-prober-1.38.ebuild:
+ Version bump
*os-prober-1.36 (06 Mar 2010)
diff --git a/sys-boot/os-prober/os-prober-1.38.ebuild b/sys-boot/os-prober/os-prober-1.38.ebuild
new file mode 100644
index 000000000000..8194b88791bd
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.38.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/os-prober/os-prober-1.38.ebuild,v 1.1 2010/06/04 02:31:38 beandog Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e "s:/lib/udev:/$(get_libdir)/udev:g" common.sh || die "sed failed on common.sh"
+ find "${S}" -type f -exec sed -i -e "s:/usr/lib/:/usr/libexec/:g" {} + || die "failed on find and sed lib->libexec"
+ sed -i -e "s:/lib/ld\*\.so\*:/lib*/ld*.so*:g" os-probes/mounted/common/90linux-distro || die "sed failed on 90linux-distro"
+
+ # Just use the default rules provided by GNU Make
+ rm Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake newns || die "emake failed"
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober || die "dobin failed"
+
+ exeinto /usr/libexec/os-prober
+ doexe newns || die "doexe newns failed"
+
+ insinto /usr/share/os-prober
+ doins common.sh || die "doins common.sh failed"
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/libexec/$dir
+ doexe $dir/common/* || die "doexe failed in $dir/common"
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/* || die "doexe failed in $dir/$debarch"
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/libexec/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx || die "doexe failed on 20macosx"
+ fi
+
+ dodoc README TODO debian/changelog || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}