summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-08 16:50:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-08 16:50:54 +0000
commit87807c224c1aafb294a786dea7f0d605e73ca3a6 (patch)
tree34039ca64021f3d6ffd2932100c5ec0d356e4cf9 /sys-boot
parentold (diff)
downloadgentoo-2-87807c224c1aafb294a786dea7f0d605e73ca3a6.tar.gz
gentoo-2-87807c224c1aafb294a786dea7f0d605e73ca3a6.tar.bz2
gentoo-2-87807c224c1aafb294a786dea7f0d605e73ca3a6.zip
Version bump #108505 by Michael Cramer.
(Portage version: 2.0.53_rc4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog9
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-3.111
-rw-r--r--sys-boot/syslinux/files/syslinux-3.11-nopie.patch22
-rw-r--r--sys-boot/syslinux/files/syslinux-3.11-nossp.patch172
-rw-r--r--sys-boot/syslinux/syslinux-3.11.ebuild40
5 files changed, 243 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index 5f56b42c9655..afbf04e5a5f4 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.17 2005/06/25 14:35:40 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.18 2005/10/08 16:50:54 vapier Exp $
+
+*syslinux-3.11 (08 Oct 2005)
+
+ 08 Oct 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/syslinux-3.11-nopie.patch, +files/syslinux-3.11-nossp.patch,
+ +syslinux-3.11.ebuild:
+ Version bump #108505 by Michael Cramer.
*syslinux-3.09 (25 Jun 2005)
diff --git a/sys-boot/syslinux/files/digest-syslinux-3.11 b/sys-boot/syslinux/files/digest-syslinux-3.11
new file mode 100644
index 000000000000..1e9898692317
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-3.11
@@ -0,0 +1 @@
+MD5 513ff71287a4397d507879a1a836c2e8 syslinux-3.11.tar.bz2 1253470
diff --git a/sys-boot/syslinux/files/syslinux-3.11-nopie.patch b/sys-boot/syslinux/files/syslinux-3.11-nopie.patch
new file mode 100644
index 000000000000..f23957ddc921
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-3.11-nopie.patch
@@ -0,0 +1,22 @@
+--- syslinux/com32/libutil/Makefile
++++ syslinux/com32/libutil/Makefile
+@@ -40,7 +40,7 @@
+ AR = ar
+ NASM = nasm
+ RANLIB = ranlib
+-CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -D__COM32__ -W -Wall -march=i386 -Os -fomit-frame-pointer -I./include -I../include $(call gcc_ok,-fno-stack-protector,)
++CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -D__COM32__ -W -Wall -march=i386 -Os -fomit-frame-pointer -I./include -I../include $(call gcc_ok,-fno-stack-protector,) $(call gcc_ok,-nopie,)
+ SFLAGS = $(M32) -D__COM32__ -march=i386
+ LDFLAGS = -T ../lib/com32.ld
+ LNXCFLAGS = -I./include -W -Wall -fno-stack-protector -O -g
+--- syslinux/dos/Makefile
++++ syslinux/dos/Makefile
+@@ -3,7 +3,7 @@
+ OBJCOPY = objcopy
+ OPTFLAGS = -g -Os -march=i386 -falign-functions=0 -falign-jumps=0 -falign-loops=0 -fomit-frame-pointer
+ INCLUDES = -include code16.h -I. -I.. -I../libfat
+-CFLAGS = -W -Wall -fno-stack-protector -ffreestanding -msoft-float $(OPTFLAGS) $(INCLUDES)
++CFLAGS = -W -Wall -nopie -fno-stack-protector -ffreestanding -msoft-float $(OPTFLAGS) $(INCLUDES)
+ LDFLAGS = -T com16.ld
+ AR = ar
+ RANLIB = ranlib
diff --git a/sys-boot/syslinux/files/syslinux-3.11-nossp.patch b/sys-boot/syslinux/files/syslinux-3.11-nossp.patch
new file mode 100644
index 000000000000..33b2867fcfda
--- /dev/null
+++ b/sys-boot/syslinux/files/syslinux-3.11-nossp.patch
@@ -0,0 +1,172 @@
+--- syslinux/Makefile
++++ syslinux/Makefile
+@@ -18,7 +18,7 @@
+ OSTYPE = $(shell uname -msr)
+ CC = gcc
+ INCLUDE =
+-CFLAGS = -W -Wall -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
++CFLAGS = -W -Wall -fno-stack-protector -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+ PIC = -fPIC
+ LDFLAGS = -O2 -s
+ AR = ar
+@@ -194,9 +194,8 @@ libsyslinux.a: bootsect_bin.o ldlinux_bi
+ $(LIB_SO): bootsect_bin.o ldlinux_bin.o syslxmod.o
+ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB_SONAME) -o $@ $^
+
+-gethostip.o: gethostip.c
+-
+-gethostip: gethostip.o
++gethostip: gethostip.c
++ $(CC) $(LDFLAGS) gethostip.c -o gethostip -fno-stack-protector
+
+ mkdiskimage: mkdiskimage.in mbr.bin bin2hex.pl
+ $(PERL) bin2hex.pl < mbr.bin | cat mkdiskimage.in - > $@
+--- syslinux/com32/lib/MCONFIG
++++ syslinux/com32/lib/MCONFIG
+@@ -18,7 +18,7 @@ LIBFLAGS = -DDYNAMIC_CRC_TABLE -DPNG_NO_
+
+ REQFLAGS = -g -m32 -mregparm=3 -DREGPARM=3 -D__COM32__ -I. -I./sys -I../include
+ OPTFLAGS = -Os -march=i386 -falign-functions=0 -falign-jumps=0 \
+- -falign-labels=0
++ -falign-labels=0 -fno-stack-protector
+ WARNFLAGS = -W -Wall -Wpointer-arith -Wwrite-strings -Wstrict-prototypes -Winline
+
+ CFLAGS = -Wp,-MT,$@,-MD,$(dir $@).$(notdir $@).d $(OPTFLAGS) \
+--- syslinux/com32/libutil/Makefile
++++ syslinux/com32/libutil/Makefile
+@@ -40,10 +40,10 @@ LD = ld -m elf_i386
+ AR = ar
+ NASM = nasm
+ RANLIB = ranlib
+-CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -D__COM32__ -W -Wall -march=i386 -Os -fomit-frame-pointer -I./include -I../include
++CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -D__COM32__ -W -Wall -march=i386 -Os -fomit-frame-pointer -I./include -I../include $(call gcc_ok,-fno-stack-protector,)
+ SFLAGS = $(M32) -D__COM32__ -march=i386
+ LDFLAGS = -T ../lib/com32.ld
+-LNXCFLAGS = -I./include -W -Wall -O -g
++LNXCFLAGS = -I./include -W -Wall -O -g $(call gcc_ok,-fno-stack-protector,)
+ LNXSFLAGS = -g
+ LNXLDFLAGS = -g
+ OBJCOPY = objcopy
+--- syslinux/com32/modules/Makefile
++++ syslinux/com32/modules/Makefile
+@@ -25,8 +25,8 @@ LD = ld -m elf_i386
+ AR = ar
+ NASM = nasm
+ RANLIB = ranlib
+-CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I../libutil/include -I../include -D__COM32__
+-LNXCFLAGS = -W -Wall -O -g -I../libutil/include
++CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I../libutil/include -I../include -D__COM32__ $(call gcc_ok,-fno-stack-protector,)
++LNXCFLAGS = -W -Wall -O -g -I../libutil/include $(call gcc_ok,-fno-stack-protector,)
+ LNXSFLAGS = -g
+ LNXLDFLAGS = -g
+ SFLAGS = -D__COM32__ -march=i386
+--- syslinux/com32/samples/Makefile
++++ syslinux/com32/samples/Makefile
+@@ -25,8 +25,8 @@ LD = ld -m elf_i386
+ AR = ar
+ NASM = nasm
+ RANLIB = ranlib
+-CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I../libutil/include -I../include -D__COM32__
+-LNXCFLAGS = -W -Wall -O -g -I../libutil/include
++CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I../libutil/include -I../include -D__COM32__ $(call gcc_ok,-fno-stack-protector,)
++LNXCFLAGS = -W -Wall -O -g -I../libutil/include $(call gcc_ok,-fno-stack-protector,)
+ LNXSFLAGS = -g
+ LNXLDFLAGS = -g
+ SFLAGS = -D__COM32__ -march=i386
+--- syslinux/dos/Makefile
++++ syslinux/dos/Makefile
+@@ -3,7 +3,7 @@ LD = ld -m elf_i386
+ OBJCOPY = objcopy
+ OPTFLAGS = -g -Os -march=i386 -falign-functions=0 -falign-jumps=0 -falign-loops=0 -fomit-frame-pointer
+ INCLUDES = -include code16.h -I. -I.. -I../libfat
+-CFLAGS = -W -Wall -ffreestanding -msoft-float $(OPTFLAGS) $(INCLUDES)
++CFLAGS = -W -Wall -fno-stack-protector -ffreestanding -msoft-float $(OPTFLAGS) $(INCLUDES)
+ LDFLAGS = -T com16.ld
+ AR = ar
+ RANLIB = ranlib
+--- syslinux/extlinux/Makefile
++++ syslinux/extlinux/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libfat
+-CFLAGS = -W -Wall -Wno-sign-compare -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
++CFLAGS = -W -Wall -fno-stack-protector -Wno-sign-compare -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+ LDFLAGS = -s
+
+ SRCS = extlinux.c ../extlinux_bss_bin.c ../extlinux_sys_bin.c
+--- syslinux/memdisk/Makefile
++++ syslinux/memdisk/Makefile
+@@ -20,7 +20,7 @@ M32 := $(call gcc_ok,-m32,)
+ FREE := $(call gcc_ok,-ffreestanding,)
+
+ CC = gcc $(M32) $(FREE)
+-CFLAGS = -g -W -Wall -Wno-sign-compare \
++CFLAGS = -g -W -Wall -Wno-sign-compare $(call gcc_ok,-fno-stack-protector,) \
+ -Os -fomit-frame-pointer -march=i386 $(ALIGN) \
+ -DVERSION='"$(VERSION)"' -DDATE='"$(DATE)"'
+ LDFLAGS = -g
+--- syslinux/menu/Makefile
++++ syslinux/menu/Makefile
+@@ -5,7 +5,7 @@ M32 := $(call gcc_ok,-m32,)
+ COM32DIR = ../com32
+ LUDIR = $(COM32DIR)/libutil
+ LDIR = $(COM32DIR)/lib
+-CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I$(LUDIR)/include -I$(COM32DIR)/include -Ilibmenu -D__COM32__
++CFLAGS = $(M32) -mregparm=3 -DREGPARM=3 -W -Wall -march=i386 -Os -fomit-frame-pointer -I$(LUDIR)/include -I$(COM32DIR)/include -Ilibmenu -D__COM32__ $(call gcc_ok,-fno-stack-protector,)
+ SFLAGS = -D__COM32__ -march=i386
+ LDFLAGS = -T $(LDIR)/com32.ld
+ OBJCOPY = objcopy
+--- syslinux/mtools/Makefile
++++ syslinux/mtools/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libfat
+-CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
++CFLAGS = -W -Wall -fno-stack-protector -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+ LDFLAGS = -s
+
+ SRCS = syslinux.c ../syslxmod.c ../bootsect_bin.c ../ldlinux_bin.c $(wildcard ../libfat/*.c)
+--- syslinux/sample/Makefile
++++ syslinux/sample/Makefile
+@@ -25,7 +25,7 @@ LD = ld -m elf_i386
+ AR = ar
+ NASM = nasm
+ RANLIB = ranlib
+-CFLAGS = -W -Wall -march=i386 -Os -fomit-frame-pointer -I../com32/include
++CFLAGS = -W -Wall -march=i386 -Os -fomit-frame-pointer -I../com32/include $(call gcc_ok,-fno-stack-protector,)
+ SFLAGS = -march=i386
+ LDFLAGS = -s
+ OBJCOPY = objcopy
+--- syslinux/unix/Makefile
++++ syslinux/unix/Makefile
+@@ -1,7 +1,7 @@
+ CC = gcc
+ OPTFLAGS = -g -Os
+ INCLUDES = -I. -I.. -I../libfat
+-CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
++CFLAGS = -W -Wall -fno-stack-protector -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
+ LDFLAGS = -s
+
+ SRCS = syslinux.c ../syslxmod.c ../bootsect_bin.c ../ldlinux_bin.c $(wildcard ../libfat/*.c)
+--- syslinux/win32/Makefile
++++ syslinux/win32/Makefile
+@@ -23,7 +23,7 @@ ifeq ($(findstring CYGWIN,$(OSTYPE)),CYG
+ CC = gcc
+ AR = ar
+ RANLIB = ranlib
+-CFLAGS = -mno-cygwin -W -Wall -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
++CFLAGS = -mno-cygwin -W -Wall -fno-stack-protector -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+ PIC =
+ LDFLAGS = -mno-cygwin -Os -s
+ else
+@@ -37,7 +37,7 @@ AR = mingw-ar
+ RANLIB = mingw-ranlib
+ endif
+
+-CFLAGS = -W -Wall -Wno-sign-compare -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
++CFLAGS = -W -Wall -fno-stack-protector -Wno-sign-compare -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+ PIC =
+ LDFLAGS = -Os -s
+ endif
diff --git a/sys-boot/syslinux/syslinux-3.11.ebuild b/sys-boot/syslinux/syslinux-3.11.ebuild
new file mode 100644
index 000000000000..448b44e0d783
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.11.ebuild,v 1.1 2005/10/08 16:50:54 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/syslinux-3.11-nossp.patch
+ epatch "${FILESDIR}"/syslinux-3.11-nopie.patch
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}