summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-03-17 18:51:49 +0000
committerMike Gilbert <floppym@gentoo.org>2015-03-17 18:51:49 +0000
commit7429bfd3fc39ef786be7e88ba312299ae59a5cf0 (patch)
tree11b8d8a47845492fcb05b86e8d6a6f945f6fbb82 /sys-boot
parentUpdate maintainership information (diff)
downloadgentoo-2-7429bfd3fc39ef786be7e88ba312299ae59a5cf0.tar.gz
gentoo-2-7429bfd3fc39ef786be7e88ba312299ae59a5cf0.tar.bz2
gentoo-2-7429bfd3fc39ef786be7e88ba312299ae59a5cf0.zip
Add postinst message about mdadm.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r3.ebuild13
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r7.ebuild13
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild13
4 files changed, 23 insertions, 22 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 77703cc1bc43..5554c4f87676 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.351 2015/03/17 02:07:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.352 2015/03/17 18:51:49 floppym Exp $
+
+ 17 Mar 2015; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2-r3.ebuild,
+ grub-2.02_beta2-r7.ebuild, grub-9999-r1.ebuild:
+ Add postinst message about mdadm.
17 Mar 2015; Mike Gilbert <floppym@gentoo.org> grub-2.00_p5107-r2.ebuild,
grub-2.02_beta2-r3.ebuild, grub-2.02_beta2-r6.ebuild,
diff --git a/sys-boot/grub/grub-2.02_beta2-r3.ebuild b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
index 12142e1173f5..26a13550f578 100644
--- a/sys-boot/grub/grub-2.02_beta2-r3.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.8 2015/03/17 02:07:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r3.ebuild,v 1.9 2015/03/17 18:51:49 floppym Exp $
EAPI=5
@@ -304,11 +304,10 @@ pkg_postinst() {
fi
if [[ -z ${REPLACING_VERSIONS} ]]; then
- if ! has_version sys-boot/os-prober; then
- elog "Install sys-boot/os-prober to enable detection of other operating systems using grub2-mkconfig."
- fi
- if ! has_version dev-libs/libisoburn; then
- elog "Install dev-libs/libisoburn to enable creation of rescue media using grub2-mkrescue."
- fi
+ elog
+ elog "You may consider installing the following optional packages:"
+ optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
+ optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
+ optfeature "Enable RAID device detection" sys-fs/mdadm
fi
}
diff --git a/sys-boot/grub/grub-2.02_beta2-r7.ebuild b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
index a6d15edc1e96..1fe729ed7811 100644
--- a/sys-boot/grub/grub-2.02_beta2-r7.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.9 2015/03/17 02:07:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.10 2015/03/17 18:51:49 floppym Exp $
EAPI=5
@@ -317,11 +317,10 @@ pkg_postinst() {
fi
if [[ -z ${REPLACING_VERSIONS} ]]; then
- if ! has_version sys-boot/os-prober; then
- elog "Install sys-boot/os-prober to enable detection of other operating systems using grub2-mkconfig."
- fi
- if ! has_version dev-libs/libisoburn; then
- elog "Install dev-libs/libisoburn to enable creation of rescue media using grub2-mkrescue."
- fi
+ elog
+ elog "You may consider installing the following optional packages:"
+ optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
+ optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
+ optfeature "Enable RAID device detection" sys-fs/mdadm
fi
}
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index e4e989ad9891..a197c54ef3cc 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.32 2015/03/17 02:07:08 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.33 2015/03/17 18:51:49 floppym Exp $
EAPI=5
@@ -312,11 +312,10 @@ pkg_postinst() {
fi
if [[ -z ${REPLACING_VERSIONS} ]]; then
- if ! has_version sys-boot/os-prober; then
- elog "Install sys-boot/os-prober to enable detection of other operating systems using grub2-mkconfig."
- fi
- if ! has_version dev-libs/libisoburn; then
- elog "Install dev-libs/libisoburn to enable creation of rescue media using grub2-mkrescue."
- fi
+ elog
+ elog "You may consider installing the following optional packages:"
+ optfeature "Detect other operating systems (grub-mkconfig)" sys-boot/os-prober
+ optfeature "Create rescue media (grub-mkrescue)" dev-libs/libisoburn
+ optfeature "Enable RAID device detection" sys-fs/mdadm
fi
}