summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-10-20 21:46:34 +0000
committerMike Gilbert <floppym@gentoo.org>2012-10-20 21:46:34 +0000
commit6c648dd71b2d75cf1194cd0d215995af5e0c9b3f (patch)
treeab0d022ad5cfd651402772171a6d51b8951838a0 /sys-boot
parentRe-add ~x86-fbsd after keywording python-exec. (diff)
downloadgentoo-2-6c648dd71b2d75cf1194cd0d215995af5e0c9b3f.tar.gz
gentoo-2-6c648dd71b2d75cf1194cd0d215995af5e0c9b3f.tar.bz2
gentoo-2-6c648dd71b2d75cf1194cd0d215995af5e0c9b3f.zip
Add pkg_pretend check to bail out if we are using the gold linker. Bug 439082 by Ambroz Bizjak.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.00-r1.ebuild13
-rw-r--r--sys-boot/grub/grub-9999.ebuild13
3 files changed, 30 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 981925b1ba1c..4fe1fa45a918 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.240 2012/10/18 12:41:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.241 2012/10/20 21:46:34 floppym Exp $
+
+ 20 Oct 2012; Mike Gilbert <floppym@gentoo.org> grub-2.00-r1.ebuild,
+ grub-9999.ebuild:
+ Add pkg_pretend check to bail out if we are using the gold linker. Bug 439082
+ by Ambroz Bizjak.
18 Oct 2012; Christoph Junghans <ottxor@gentoo.org>
+files/grub-2.00-hardcoded-awk.patch, grub-2.00-r1.ebuild, grub-9999.ebuild:
diff --git a/sys-boot/grub/grub-2.00-r1.ebuild b/sys-boot/grub/grub-2.00-r1.ebuild
index 9f7a6becacc6..15eee11c8010 100644
--- a/sys-boot/grub/grub-2.00-r1.ebuild
+++ b/sys-boot/grub/grub-2.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r1.ebuild,v 1.2 2012/10/18 12:41:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r1.ebuild,v 1.3 2012/10/20 21:46:34 floppym Exp $
EAPI=4
@@ -216,6 +216,17 @@ grub_install_docs() {
emake -C docs DESTDIR="${D}" install-html
}
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug 439082
+ if $(tc-getLD) --version | grep -q "GNU gold"; then
+ eerror "GRUB does not function correctly when built with the gold linker."
+ eerror "Please select the bfd linker with binutils-config."
+ die "GNU gold detected"
+ fi
+ fi
+}
+
src_prepare() {
if [[ ${PV} != 9999 ]]; then
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 31ca532cb99e..db2e902b8407 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.84 2012/10/18 12:41:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.85 2012/10/20 21:46:34 floppym Exp $
EAPI=4
@@ -216,6 +216,17 @@ grub_install_docs() {
emake -C docs DESTDIR="${D}" install-html
}
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ # Bug 439082
+ if $(tc-getLD) --version | grep -q "GNU gold"; then
+ eerror "GRUB does not function correctly when built with the gold linker."
+ eerror "Please select the bfd linker with binutils-config."
+ die "GNU gold detected"
+ fi
+ fi
+}
+
src_prepare() {
if [[ ${PV} != 9999 ]]; then
epatch "${FILESDIR}/${P}-parallel-make.patch" #424231