summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-12-04 21:51:40 +0000
committerBrian Jackson <iggy@gentoo.org>2004-12-04 21:51:40 +0000
commit67dd1fbb8157b3eae8444f13360a63801c7c961b (patch)
treeb0ba7920baa79859d55448169f93ee30ce22487b /sys-boot
parentversion bump; we now build differently, more inline with what hpa suggests (diff)
downloadgentoo-2-67dd1fbb8157b3eae8444f13360a63801c7c961b.tar.gz
gentoo-2-67dd1fbb8157b3eae8444f13360a63801c7c961b.tar.bz2
gentoo-2-67dd1fbb8157b3eae8444f13360a63801c7c961b.zip
version bump; we now build differently, more inline with what hpa suggests
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/Manifest4
-rw-r--r--sys-boot/syslinux/files/digest-syslinux-2.111
-rw-r--r--sys-boot/syslinux/syslinux-2.11.ebuild32
4 files changed, 41 insertions, 3 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index fa3ec3592c55..32b2c4f93486 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.8 2004/10/02 15:37:03 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.9 2004/12/04 21:51:09 iggy Exp $
+
+*syslinux-2.11 (04 Dec 2004)
+
+ 04 Dec 2004; Brian Jackson <iggy@gentoo.org> +syslinux-2.11.ebuild:
+ version bump; we now build differently, more inline with what hpa suggests
11 May 2004; <solar@gentoo.org> syslinux-2.06.ebuild, syslinux-2.09.ebuild:
add ssp check before patching in nossp patches. This prevents breakage if your
diff --git a/sys-boot/syslinux/Manifest b/sys-boot/syslinux/Manifest
index f2d111b87bb0..e112d8047f8a 100644
--- a/sys-boot/syslinux/Manifest
+++ b/sys-boot/syslinux/Manifest
@@ -1,8 +1,8 @@
-MD5 94644b2177c345ac8e8fc962aa340497 syslinux-2.11.ebuild 929
+MD5 0b4231c1d0d54aa83e898423d7817250 syslinux-2.11.ebuild 928
MD5 fb127e3771758b377a7016d8e29c9fa1 syslinux-1.75.ebuild 589
MD5 a6586885f8bdf5bf7cf46eb37fc50085 syslinux-2.09.ebuild 953
MD5 3c78ed9ea6a975773840c1edf9654c02 syslinux-2.06.ebuild 965
-MD5 197a479468d53426e9e2aebc77088f88 ChangeLog 2714
+MD5 f5b73324fa926cd181119c007bb09b6b ChangeLog 2888
MD5 4d2f3c3e817a13b9c33b5607604fd060 syslinux-2.05.ebuild 759
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 f38ec993dba486ddbaf4a50773db388e files/syslinux-2.09-nossp.patch 2257
diff --git a/sys-boot/syslinux/files/digest-syslinux-2.11 b/sys-boot/syslinux/files/digest-syslinux-2.11
new file mode 100644
index 000000000000..19abb0abd792
--- /dev/null
+++ b/sys-boot/syslinux/files/digest-syslinux-2.11
@@ -0,0 +1 @@
+MD5 38a30cc790265f19f80330330ffaa527 syslinux-2.11.tar.bz2 385838
diff --git a/sys-boot/syslinux/syslinux-2.11.ebuild b/sys-boot/syslinux/syslinux-2.11.ebuild
new file mode 100644
index 000000000000..9d60533d85f2
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-2.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-2.11.ebuild,v 1.1 2004/12/04 21:51:09 iggy Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="dev-lang/nasm
+ sys-fs/mtools"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ make INSTALLROOT=${D} install || die
+ dodoc README NEWS TODO *.doc memdisk/memdisk.doc
+}