summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-30 00:12:52 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-30 00:12:52 +0000
commit1dfa263c07e60a59f4a23922ed9415ac71271647 (patch)
tree125879073acd6ebd4111a593b9219ff6cbb6cb9d /sys-boot
parentadd upstream url (diff)
downloadgentoo-2-1dfa263c07e60a59f4a23922ed9415ac71271647.tar.gz
gentoo-2-1dfa263c07e60a59f4a23922ed9415ac71271647.tar.bz2
gentoo-2-1dfa263c07e60a59f4a23922ed9415ac71271647.zip
Add a live svn ebuild by roger #252769. This also fixes stripping issues #231935 by Alexey Shvetsov.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog9
-rw-r--r--sys-boot/grub/grub-1.96.ebuild16
-rw-r--r--sys-boot/grub/grub-9999.ebuild46
3 files changed, 67 insertions, 4 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 71c0f6dc8fbf..6d4b5e371f12 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.105 2008/11/10 14:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.106 2008/12/30 00:12:52 vapier Exp $
+
+*grub-9999 (30 Dec 2008)
+
+ 30 Dec 2008; Mike Frysinger <vapier@gentoo.org> grub-1.96.ebuild,
+ +grub-9999.ebuild:
+ Add a live svn ebuild by roger #252769. This also fixes stripping issues
+ #231935 by Alexey Shvetsov.
10 Nov 2008; Mike Frysinger <vapier@gentoo.org> grub-1.96.ebuild:
Drop USE=netboot and fixup DEPEND #234182.
diff --git a/sys-boot/grub/grub-1.96.ebuild b/sys-boot/grub/grub-1.96.ebuild
index 00bd42372a55..f7076657b7fe 100644
--- a/sys-boot/grub/grub-1.96.ebuild
+++ b/sys-boot/grub/grub-1.96.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.96.ebuild,v 1.5 2008/11/10 14:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.96.ebuild,v 1.6 2008/12/30 00:12:52 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.sv.gnu.org/grub/trunk/grub2"
+ inherit subversion
+fi
+
DESCRIPTION="GNU GRUB 2 boot loader"
HOMEPAGE="http://www.gnu.org/software/grub/"
-SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
- mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -18,6 +21,8 @@ DEPEND=">=sys-libs/ncurses-5.2-r5
dev-libs/lzo"
PROVIDE="virtual/bootloader"
+STRIP_MASK="/lib*/grub/*/*.mod"
+
src_compile() {
use amd64 && multilib_toolchain_setup x86
use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
@@ -34,3 +39,8 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
}
+
+pkg_postinst() {
+ elog "To automatically generate a grub configuration file:"
+ elog "# /sbin/grub-mkconfig -o /boot/grub/grub.cfg"
+}
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
new file mode 100644
index 000000000000..a99f2ac9b021
--- /dev/null
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.1 2008/12/30 00:12:52 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="svn://svn.sv.gnu.org/grub/trunk/grub2"
+ inherit subversion
+fi
+
+DESCRIPTION="GNU GRUB 2 boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="static custom-cflags"
+
+DEPEND=">=sys-libs/ncurses-5.2-r5
+ dev-libs/lzo"
+PROVIDE="virtual/bootloader"
+
+STRIP_MASK="/lib*/grub/*/*.mod"
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
+ use static && append-ldflags -static
+
+ econf \
+ --prefix=/ \
+ --datadir=/usr/lib \
+ || die "econf failed"
+ emake -j1 || die "making regular stuff"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}
+
+pkg_postinst() {
+ elog "To automatically generate a grub configuration file:"
+ elog "# /sbin/grub-mkconfig -o /boot/grub/grub.cfg"
+}