summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-06-19 11:12:11 +0000
committerDaniel Goller <morfic@gentoo.org>2005-06-19 11:12:11 +0000
commit1eead5cadd78f2189f77d9f314ef89896e7390c0 (patch)
treeac59483f4bb6c0f9b79b95f6394ec7ffe81d84a8 /sys-boot/yaboot
parentUpdated to use virtual/glut (diff)
downloadgentoo-2-1eead5cadd78f2189f77d9f314ef89896e7390c0.tar.gz
gentoo-2-1eead5cadd78f2189f77d9f314ef89896e7390c0.tar.bz2
gentoo-2-1eead5cadd78f2189f77d9f314ef89896e7390c0.zip
applying nopiessp patch
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'sys-boot/yaboot')
-rw-r--r--sys-boot/yaboot/ChangeLog6
-rw-r--r--sys-boot/yaboot/files/yaboot-nopiessp.patch51
-rw-r--r--sys-boot/yaboot/yaboot-1.3.13.ebuild3
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-boot/yaboot/ChangeLog b/sys-boot/yaboot/ChangeLog
index 76d22aa464e4..c9477b69abf4 100644
--- a/sys-boot/yaboot/ChangeLog
+++ b/sys-boot/yaboot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/yaboot
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.15 2005/01/21 20:08:37 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/ChangeLog,v 1.16 2005/06/19 11:12:11 morfic Exp $
+
+ 19 Jun 2005; Daniel Goller <morfic@gentoo.org>
+ +files/yaboot-nopiessp.patch, yaboot-1.3.13.ebuild:
+ adding nopiessp patch after confirmation
21 Jan 2005; Lars Weiler <pylon@gentoo.org> -yaboot-1.3.10-r1.ebuild,
-yaboot-1.3.10-r2.ebuild, -yaboot-1.3.10.ebuild, -yaboot-1.3.11.ebuild,
diff --git a/sys-boot/yaboot/files/yaboot-nopiessp.patch b/sys-boot/yaboot/files/yaboot-nopiessp.patch
new file mode 100644
index 000000000000..1fd8ea42e6d0
--- /dev/null
+++ b/sys-boot/yaboot/files/yaboot-nopiessp.patch
@@ -0,0 +1,51 @@
+diff -Nrup yaboot-1.3.13.orig/Config.gentoo yaboot-1.3.13/Config.gentoo
+--- yaboot-1.3.13.orig/Config.gentoo 1970-01-01 00:00:00.000000000 +0000
++++ yaboot-1.3.13/Config.gentoo 2005-06-12 00:41:14.889576152 +0000
+@@ -0,0 +1,6 @@
++check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
++ then echo "$(1)"; else echo "$(2)"; fi)
++
++CFLAGS += $(call check_gcc, -fno-stack-protector)
++CFLAGS += $(call check_gcc, -nopie)
++
+diff -Nrup yaboot-1.3.13.orig/Makefile yaboot-1.3.13/Makefile
+--- yaboot-1.3.13.orig/Makefile 2004-07-11 20:12:03.000000000 +0000
++++ yaboot-1.3.13/Makefile 2005-06-12 00:41:14.890576000 +0000
+@@ -1,6 +1,7 @@
+ ## Setup
+
+ include Config
++include Config.gentoo
+
+ VERSION = 1.3.13
+ # Debug mode (spam/verbose)
+@@ -79,7 +80,7 @@ HOSTCFLAGS = -O2 $(CFLAGS) -Wall -I/usr/
+ OBJS = second/crt0.o second/yaboot.o second/cache.o second/prom.o second/file.o \
+ second/partition.o second/fs.o second/cfg.o second/setjmp.o second/cmdline.o \
+ second/fs_of.o second/fs_ext2.o second/fs_iso.o second/iso_util.o \
+- lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o
++ lib/nosys.o lib/string.o lib/strtol.o lib/vsprintf.o lib/ctype.o lib/malloc.o lib/strstr.o lib/ssp.o
+
+ ifeq ($(USE_MD5_PASSWORDS),y)
+ OBJS += second/md5.o
+diff -Nrup yaboot-1.3.13.orig/lib/ssp.c yaboot-1.3.13/lib/ssp.c
+--- yaboot-1.3.13.orig/lib/ssp.c 1970-01-01 00:00:00.000000000 +0000
++++ yaboot-1.3.13/lib/ssp.c 2005-06-12 00:42:17.087120688 +0000
+@@ -0,0 +1,17 @@
++unsigned long __guard = 0UL;
++static void __guard_setup (void) __attribute__ ((constructor));
++void __stack_smash_handler (char func[], int damaged
++ __attribute__ ((unused)));
++static void
++__guard_setup (void)
++{
++ if (__guard != 0UL)
++ return;
++ __guard = 0xFF0A0D00UL;
++}
++
++void
++__stack_smash_handler (char func[], int damaged)
++{
++ return;
++}
diff --git a/sys-boot/yaboot/yaboot-1.3.13.ebuild b/sys-boot/yaboot/yaboot-1.3.13.ebuild
index 1040d6539fca..99b74e8f96f2 100644
--- a/sys-boot/yaboot/yaboot-1.3.13.ebuild
+++ b/sys-boot/yaboot/yaboot-1.3.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.13.ebuild,v 1.3 2005/01/21 20:08:37 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.13.ebuild,v 1.4 2005/06/19 11:12:11 morfic Exp $
inherit eutils toolchain-funcs
@@ -42,6 +42,7 @@ src_compile() {
epatch ${FILESDIR}/chrpfix.patch
epatch ${FILESDIR}/yaboot-3.4.patch
epatch ${FILESDIR}/yaboot-${PV}-ofpath.patch
+ epatch ${FILESDIR}/yaboot-nopiessp.patch
emake ${MAKEOPTS} CC="$(tc-getCC)" || die
}