summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2004-10-06 05:40:12 +0000
committerJohn P. Davis <zhen@gentoo.org>2004-10-06 05:40:12 +0000
commitce9b4e885a40e504889531f4ca9ca012efa3a931 (patch)
treeed2d4b8b222e50c3fd3e46b344faaa02eda4fec0 /sys-boot/netboot
parentfix compile error with gcc34 (bug #66142) (again) (Manifest recommit) (diff)
downloadgentoo-2-ce9b4e885a40e504889531f4ca9ca012efa3a931.tar.gz
gentoo-2-ce9b4e885a40e504889531f4ca9ca012efa3a931.tar.bz2
gentoo-2-ce9b4e885a40e504889531f4ca9ca012efa3a931.zip
initial import
Diffstat (limited to 'sys-boot/netboot')
-rw-r--r--sys-boot/netboot/ChangeLog3
-rw-r--r--sys-boot/netboot/Manifest4
-rw-r--r--sys-boot/netboot/files/digest-netboot-0.9.81
-rw-r--r--sys-boot/netboot/metadata.xml5
-rw-r--r--sys-boot/netboot/netboot-0.9.8.ebuild28
5 files changed, 41 insertions, 0 deletions
diff --git a/sys-boot/netboot/ChangeLog b/sys-boot/netboot/ChangeLog
new file mode 100644
index 000000000000..04c08143873d
--- /dev/null
+++ b/sys-boot/netboot/ChangeLog
@@ -0,0 +1,3 @@
+# ChangeLog for sys-boot/netboot
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.1 2004/10/06 05:40:12 zhen Exp $
diff --git a/sys-boot/netboot/Manifest b/sys-boot/netboot/Manifest
new file mode 100644
index 000000000000..d0607726f2ef
--- /dev/null
+++ b/sys-boot/netboot/Manifest
@@ -0,0 +1,4 @@
+MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
+MD5 25e6ad84f1254009bf80e30d49500bca ChangeLog 116
+MD5 db32d243b608d217f225fc25c831debc netboot-0.9.8.ebuild 481
+MD5 f7b31adec25510c7cc11490f8cf95e55 files/digest-netboot-0.9.8 65
diff --git a/sys-boot/netboot/files/digest-netboot-0.9.8 b/sys-boot/netboot/files/digest-netboot-0.9.8
new file mode 100644
index 000000000000..f28e0ea23399
--- /dev/null
+++ b/sys-boot/netboot/files/digest-netboot-0.9.8
@@ -0,0 +1 @@
+MD5 2c4c83c3d7743b73247e2acdda79919d netboot-0.9.8.tar.gz 966389
diff --git a/sys-boot/netboot/metadata.xml b/sys-boot/netboot/metadata.xml
new file mode 100644
index 000000000000..88653ddd7172
--- /dev/null
+++ b/sys-boot/netboot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>livecd</herd>
+</pkgmetadata>
diff --git a/sys-boot/netboot/netboot-0.9.8.ebuild b/sys-boot/netboot/netboot-0.9.8.ebuild
new file mode 100644
index 000000000000..3d5415449d6e
--- /dev/null
+++ b/sys-boot/netboot/netboot-0.9.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.9.8.ebuild,v 1.1 2004/10/06 05:40:12 zhen Exp $
+
+inherit eutils
+
+DESCRIPTION="x86 specific netbooting utility"
+HOMEPAGE="http://netboot.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND="sys-devel/autoconf"
+#RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc README version
+ cp -a FlashCard ${D}/usr/share/doc/${P}
+}