summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-10 06:09:56 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-10 06:09:56 +0000
commitef6d93897956c5a795e4334b838a6aa328eb3057 (patch)
tree2d230d561f54dcf5c993c45adb36b19b63fac577 /sys-boot/grub
parentepatch - fix unbalanced eshopts_pop #300360 (diff)
downloadgentoo-2-ef6d93897956c5a795e4334b838a6aa328eb3057.tar.gz
gentoo-2-ef6d93897956c5a795e4334b838a6aa328eb3057.tar.bz2
gentoo-2-ef6d93897956c5a795e4334b838a6aa328eb3057.zip
unify grub 2 ebuilds, replace aclocal calls to eaclocal, and only run autotools on live bzr ebuilds
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/grub-1.97.1.ebuild18
-rw-r--r--sys-boot/grub/grub-9999.ebuild14
2 files changed, 18 insertions, 14 deletions
diff --git a/sys-boot/grub/grub-1.97.1.ebuild b/sys-boot/grub/grub-1.97.1.ebuild
index 066b19fa3d7f..34a46c5d2fca 100644
--- a/sys-boot/grub/grub-1.97.1.ebuild
+++ b/sys-boot/grub/grub-1.97.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.97.1.ebuild,v 1.1 2009/11/11 04:13:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.97.1.ebuild,v 1.2 2010/01/10 06:09:56 vapier Exp $
-inherit autotools mount-boot eutils flag-o-matic toolchain-funcs
+inherit mount-boot eutils flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="svn://svn.sv.gnu.org/grub/trunk/grub2"
- inherit subversion
+ EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub"
+ inherit autotools bzr
SRC_URI=""
else
SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
@@ -32,7 +32,7 @@ QA_EXECSTACK="sbin/grub-probe sbin/grub-setup sbin/grub-mkdevicemap"
src_unpack() {
if [[ ${PV} == "9999" ]] ; then
- subversion_src_unpack
+ bzr_src_unpack
else
unpack ${A}
fi
@@ -41,8 +41,10 @@ src_unpack() {
epatch_user
# autogen.sh does more than just run autotools
- sed -i -e 's:^auto:eauto:' autogen.sh
- (. ./autogen.sh) || die
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i -e 's:^auto:eauto:' autogen.sh
+ (. ./autogen.sh) || die
+ fi
}
src_compile() {
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 8a50eac201d8..a3b073665a3d 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.16 2009/11/22 17:34:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.17 2010/01/10 06:09:56 vapier Exp $
-inherit autotools mount-boot eutils flag-o-matic toolchain-funcs
+inherit mount-boot eutils flag-o-matic toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub"
- inherit bzr
+ inherit autotools bzr
SRC_URI=""
else
SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
@@ -41,8 +41,10 @@ src_unpack() {
epatch_user
# autogen.sh does more than just run autotools
- sed -i -e 's:^auto:eauto:' autogen.sh
- (. ./autogen.sh) || die
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i -e '/^\(auto\|ac\)/s:^:e:' autogen.sh
+ (. ./autogen.sh) || die
+ fi
}
src_compile() {