summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-04-26 21:00:24 +0000
committerMike Gilbert <floppym@gentoo.org>2014-04-26 21:00:24 +0000
commitca3addae8aff83462647ea909fb4a4918a5a5e5f (patch)
tree78aee565f66bed4e4b98619359353c3f54a2680a /sys-boot/grub
parentClean up (diff)
downloadgentoo-2-ca3addae8aff83462647ea909fb4a4918a5a5e5f.tar.gz
gentoo-2-ca3addae8aff83462647ea909fb4a4918a5a5e5f.tar.bz2
gentoo-2-ca3addae8aff83462647ea909fb4a4918a5a5e5f.zip
Replace -O3 with -O2 to prevent segfault in grub-mkimage, bug 508758 by Roc Vallès.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-2.02_beta2.ebuild5
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild5
3 files changed, 14 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index c53681037062..790479325fa3 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.310 2014/04/15 22:47:35 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.311 2014/04/26 21:00:24 floppym Exp $
+
+ 26 Apr 2014; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2.ebuild,
+ grub-9999-r1.ebuild:
+ Replace -O3 with -O2 to prevent segfault in grub-mkimage, bug 508758 by Roc
+ Vallès.
15 Apr 2014; Mike Gilbert <floppym@gentoo.org> grub-2.02_beta2.ebuild,
grub-9999-r1.ebuild:
diff --git a/sys-boot/grub/grub-2.02_beta2.ebuild b/sys-boot/grub/grub-2.02_beta2.ebuild
index ef848f4b1c51..9f80eeb7899a 100644
--- a/sys-boot/grub/grub-2.02_beta2.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2.ebuild,v 1.6 2014/04/15 22:47:35 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2.ebuild,v 1.7 2014/04/26 21:00:24 floppym Exp $
EAPI=5
@@ -230,6 +230,9 @@ grub_configure() {
}
src_configure() {
+ # Bug 508758.
+ replace-flags -O3 -O2
+
# We don't want to leak flags onto boot code.
export HOST_CCASFLAGS=${CCASFLAGS}
export HOST_CFLAGS=${CFLAGS}
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index 2831f628e9b6..d930b9554b13 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.15 2014/04/15 22:47:35 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999-r1.ebuild,v 1.16 2014/04/26 21:00:24 floppym Exp $
EAPI=5
@@ -230,6 +230,9 @@ grub_configure() {
}
src_configure() {
+ # Bug 508758.
+ replace-flags -O3 -O2
+
# We don't want to leak flags onto boot code.
export HOST_CCASFLAGS=${CCASFLAGS}
export HOST_CFLAGS=${CFLAGS}