summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-07 17:37:04 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-07 17:37:04 +0000
commit2a0edb4e268eae417c3e8de71506b46226fff7b5 (patch)
tree92444b4a856b956522942d38b3e4150e669984d2 /sys-boot/grub
parentBump to a newer stable-queue snapshot. (diff)
downloadgentoo-2-2a0edb4e268eae417c3e8de71506b46226fff7b5.tar.gz
gentoo-2-2a0edb4e268eae417c3e8de71506b46226fff7b5.tar.bz2
gentoo-2-2a0edb4e268eae417c3e8de71506b46226fff7b5.zip
Version bump #305143 by Xake.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog7
-rw-r--r--sys-boot/grub/grub-1.97.2.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 4c442b084240..41bef1082094 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.131 2010/01/17 01:25:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.132 2010/03/07 17:37:04 vapier Exp $
+
+*grub-1.97.2 (07 Mar 2010)
+
+ 07 Mar 2010; Mike Frysinger <vapier@gentoo.org> +grub-1.97.2.ebuild:
+ Version bump #305143 by Xake.
17 Jan 2010; Mike Frysinger <vapier@gentoo.org> grub-1.97.1.ebuild,
grub-9999.ebuild:
diff --git a/sys-boot/grub/grub-1.97.2.ebuild b/sys-boot/grub/grub-1.97.2.ebuild
new file mode 100644
index 000000000000..dda4b6099765
--- /dev/null
+++ b/sys-boot/grub/grub-1.97.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.97.2.ebuild,v 1.1 2010/03/07 17:37:04 vapier Exp $
+
+# XXX: need to implement a grub.conf migration in pkg_postinst before we ~arch
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EBZR_REPO_URI="http://bzr.savannah.gnu.org/r/grub/trunk/grub"
+ inherit autotools bzr
+ SRC_URI=""
+else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+fi
+
+DESCRIPTION="GNU GRUB 2 boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+
+LICENSE="GPL-3"
+use multislot && SLOT="2" || SLOT="0"
+KEYWORDS=""
+IUSE="custom-cflags debug truetype multislot static"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r5
+ dev-libs/lzo
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ dev-lang/ruby"
+PROVIDE="virtual/bootloader"
+
+export STRIP_MASK="*/grub/*/*.mod"
+QA_EXECSTACK="sbin/grub-probe sbin/grub-setup sbin/grub-mkdevicemap"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ bzr_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.96-genkernel.patch #256335
+ epatch_user
+
+ # autogen.sh does more than just run autotools
+ # need to eautomake due to weirdness #296013
+ if [[ ${PV} == "9999" ]] ; then
+ sed -i \
+ -e '/^\(auto\|ac\)/s:^:e:' \
+ -e "s:^eautomake:`which automake`:" \
+ autogen.sh
+ (. ./autogen.sh) || die
+ fi
+}
+
+src_compile() {
+ use custom-cflags || unset CFLAGS CPPFLAGS LDFLAGS
+ use static && append-ldflags -static
+
+ econf \
+ --disable-werror \
+ --sbindir=/sbin \
+ --bindir=/bin \
+ --libdir=/$(get_libdir) \
+ --disable-efiemu \
+ $(use_enable truetype grub-mkfont) \
+ $(use_enable debug mm-debug) \
+ $(use_enable debug grub-emu) \
+ $(use_enable debug grub-emu-usb) \
+ $(use_enable debug grub-fstest)
+ emake -j1 || die "making regular stuff"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ cat <<-EOF >> "${D}"/lib*/grub/grub-mkconfig_lib
+ GRUB_DISTRIBUTOR="Gentoo"
+ EOF
+ if use multislot ; then
+ sed -i "s:grub-install:grub2-install:" "${D}"/sbin/grub-install || die
+ mv "${D}"/sbin/grub{,2}-install || die
+ mv "${D}"/usr/share/info/grub{,2}.info || die
+ fi
+}
+
+setup_boot_dir() {
+ local boot_dir=$1
+ local dir=${boot_dir}/grub
+
+ if [[ ! -e ${dir}/grub.cfg ]] ; then
+ einfo "Running: grub-mkconfig -o '${dir}/grub.cfg'"
+ grub-mkconfig -o "${dir}/grub.cfg"
+ fi
+
+ #local install=grub-install
+ #use multislot && install="grub2-install --grub-setup=/bin/true"
+ #einfo "Running: ${install} "
+ #${install}
+}
+
+pkg_postinst() {
+ if use multislot ; then
+ elog "You have installed grub2 with USE=multislot, so to coexist"
+ elog "with grub1, the grub2 install binary is named grub2-install."
+ fi
+ setup_boot_dir "${ROOT}"boot
+}