summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-09 08:13:57 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-09 08:13:57 +0000
commit3a09a380ef4470365e58aaf172a8dc633083f35c (patch)
treea20110c13e04001056e70b856e8b6543d8c57ca8 /sys-boot/dvhtool/dvhtool-1.0.1.ebuild
parentadded sys-boot category for bootloaders (diff)
downloadgentoo-2-3a09a380ef4470365e58aaf172a8dc633083f35c.tar.gz
gentoo-2-3a09a380ef4470365e58aaf172a8dc633083f35c.tar.bz2
gentoo-2-3a09a380ef4470365e58aaf172a8dc633083f35c.zip
moved from sys-apps to sys-boot
Diffstat (limited to 'sys-boot/dvhtool/dvhtool-1.0.1.ebuild')
-rw-r--r--sys-boot/dvhtool/dvhtool-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-boot/dvhtool/dvhtool-1.0.1.ebuild b/sys-boot/dvhtool/dvhtool-1.0.1.ebuild
new file mode 100644
index 000000000000..e930cf2d571f
--- /dev/null
+++ b/sys-boot/dvhtool/dvhtool-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/dvhtool/dvhtool-1.0.1.ebuild,v 1.1 2003/12/09 08:11:46 seemant Exp $
+
+DESCRIPTION="Dvhtool is the tool responsible for writing MIPS kernel(s) into the SGI volume header"
+HOMEPAGE="http://packages.debian.org/unstable/utils/dvhtool.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/dvhtool/dvhtool_1.0.1.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* mips"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}.orig
+ patch -p1 < ${FILESDIR}/dvhtool-1.0.1-2.diff || die
+}
+src_compile() {
+ cd ${S}.orig
+ econf
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ cd ${S}.orig
+ einstall
+
+}