summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-05-18 07:17:47 +0000
committerLance Albertson <ramereth@gentoo.org>2012-05-18 07:17:47 +0000
commit1a98162a0aaa549f3e68363d2429f6b9b1473778 (patch)
tree8533d8de94eeb283406e24b5b5ad3afcffba33a7 /sys-block
parentMarked ~ppc ~ppc64 for bug #402989. (diff)
downloadgentoo-2-1a98162a0aaa549f3e68363d2429f6b9b1473778.tar.gz
gentoo-2-1a98162a0aaa549f3e68363d2429f6b9b1473778.tar.bz2
gentoo-2-1a98162a0aaa549f3e68363d2429f6b9b1473778.zip
version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/megacli/ChangeLog9
-rw-r--r--sys-block/megacli/megacli-8.02.21.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/sys-block/megacli/ChangeLog b/sys-block/megacli/ChangeLog
index bab60e33eba8..d05c6c624d4e 100644
--- a/sys-block/megacli/ChangeLog
+++ b/sys-block/megacli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-block/megacli
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.12 2011/11/26 06:21:42 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/ChangeLog,v 1.13 2012/05/18 07:17:47 ramereth Exp $
+
+*megacli-8.02.21 (18 May 2012)
+
+ 18 May 2012; Lance Albertson <ramereth@gentoo.org> +megacli-8.02.21.ebuild:
+ Version bump
26 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> megacli-8.02.16.ebuild:
No more direct download possible, upstream has implemented mandatory
diff --git a/sys-block/megacli/megacli-8.02.21.ebuild b/sys-block/megacli/megacli-8.02.21.ebuild
new file mode 100644
index 000000000000..f81cd53e4039
--- /dev/null
+++ b/sys-block/megacli/megacli-8.02.21.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/megacli/megacli-8.02.21.ebuild,v 1.1 2012/05/18 07:17:47 ramereth Exp $
+
+EAPI="4"
+
+inherit rpm
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+HOMEPAGE="http://www.lsi.com/"
+SRC_URI="http://www.lsi.com/downloads/Public/MegaRAID%20Common%20Files/${PV}_MegaCLI.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+
+S="${WORKDIR}"
+
+RESTRICT="mirror fetch"
+
+QA_PRESTRIPPED="/opt/megacli/megacli"
+
+pkg_nofetch() {
+ einfo "Upstream has implement a mandatory clickthrough EULA for distfile download"
+ einfo "Please visit $SRC_URI"
+ einfo "And place $A in ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ unpack ./${PV}_Linux_MegaCLI/MegaCliLin.zip
+ rpm_unpack ./MegaCli-${PV}-1.noarch.rpm
+ rpm_unpack ./Lib_Utils-1.00-09.noarch.rpm
+}
+
+src_install() {
+ exeinto /opt/megacli
+ libsysfs=libsysfs.so.2.0.2
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64 libsysfs=x86_64/${libsysfs};;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} megacli
+
+ exeinto /opt/megacli/lib
+ doexe opt/lsi/3rdpartylibs/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ dodoc ${PV}_MegaCLI.txt
+
+ # Remove DT_RPATH
+ chrpath -d "${D}"/opt/megacli/megacli
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/${PV}_MegaCli.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}