summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 16:38:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-22 16:38:16 +0000
commit893a896eea4381730f50037a57c8b0ec979143dc (patch)
treefbac416e5c22e94e67390724140d99cc751641e6 /sys-block/partimage
parentVersion bumped. (diff)
downloadgentoo-2-893a896eea4381730f50037a57c8b0ec979143dc.tar.gz
gentoo-2-893a896eea4381730f50037a57c8b0ec979143dc.tar.bz2
gentoo-2-893a896eea4381730f50037a57c8b0ec979143dc.zip
Add patch from Fedora to build with glibc-2.10. Closes bug #270645.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-block/partimage')
-rw-r--r--sys-block/partimage/ChangeLog8
-rw-r--r--sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch12
-rw-r--r--sys-block/partimage/partimage-0.6.7.ebuild3
3 files changed, 20 insertions, 3 deletions
diff --git a/sys-block/partimage/ChangeLog b/sys-block/partimage/ChangeLog
index a0cef892937f..48ab3ec1b68f 100644
--- a/sys-block/partimage/ChangeLog
+++ b/sys-block/partimage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-block/partimage
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.39 2009/03/08 22:02:16 josejx Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/ChangeLog,v 1.40 2009/05/22 16:38:16 flameeyes Exp $
+
+ 22 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ partimage-0.6.7.ebuild, +files/partimage-0.6.7+glibc-2.10.patch:
+ Add patch from Fedora to build with glibc-2.10. Closes bug #270645.
08 Mar 2009; Joseph Jezak <josejx@gentoo.org> partimage-0.6.7.ebuild:
Marked ppc stable for bug #261081.
diff --git a/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch b/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch
new file mode 100644
index 000000000000..c8b2fed20ece
--- /dev/null
+++ b/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -Naur partimage-0.6.7/src/client/misc.cpp partimage-0.6.7-new/src/client/misc.cpp
+--- partimage-0.6.7/src/client/misc.cpp 2008-02-03 19:58:00.000000000 -0200
++++ partimage-0.6.7-new/src/client/misc.cpp 2009-02-26 12:57:45.000000000 -0300
+@@ -2372,7 +2372,7 @@
+
+ static char *sfdisk_line_to_partition_device(const char *line)
+ {
+- if (char *p = strchr(line, ':')) {
++ if (const char *p = strchr(line, ':')) {
+ while (p[-1] == ' ' && p > line) p--;
+ return strndup(line, p - line);
+ } else {
diff --git a/sys-block/partimage/partimage-0.6.7.ebuild b/sys-block/partimage/partimage-0.6.7.ebuild
index 510d69812d67..99b0e8a4f2d3 100644
--- a/sys-block/partimage/partimage-0.6.7.ebuild
+++ b/sys-block/partimage/partimage-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.7.ebuild,v 1.5 2009/03/08 22:02:16 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/partimage/partimage-0.6.7.ebuild,v 1.6 2009/05/22 16:38:16 flameeyes Exp $
WANT_AUTOMAKE="1.10"
@@ -56,6 +56,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.6.6-disable_header_check.patch || die
epatch "${FILESDIR}"/${P}-datadir-path.patch || die
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}+glibc-2.10.patch
}
src_compile() {