summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:12:49 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:12:49 +0000
commit4d05dfb7e76002b2bc1516d96eeb1d207aea6562 (patch)
tree0d24d7c7fcf51d86ed97513e230d9f24cd22848b /sys-auth
parentinitial add of oslo.config (as oslo-config) for sys-auth/keystone-2013.1 (diff)
downloadgentoo-2-4d05dfb7e76002b2bc1516d96eeb1d207aea6562.tar.gz
gentoo-2-4d05dfb7e76002b2bc1516d96eeb1d207aea6562.tar.bz2
gentoo-2-4d05dfb7e76002b2bc1516d96eeb1d207aea6562.zip
updating keystone to grizzly
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog8
-rw-r--r--sys-auth/keystone/keystone-2013.1.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 86ffe6b2a240..68d256b4d16f 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.11 2013/03/20 17:17:08 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.12 2013/04/10 16:12:49 prometheanfire Exp $
+
+*keystone-2013.1 (10 Apr 2013)
+
+ 10 Apr 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +keystone-2013.1.ebuild:
+ updating keystone to grizzly
*keystone-2012.2.3-r2 (20 Mar 2013)
diff --git a/sys-auth/keystone/keystone-2013.1.ebuild b/sys-auth/keystone/keystone-2013.1.ebuild
new file mode 100644
index 000000000000..771946de3a2a
--- /dev/null
+++ b/sys-auth/keystone/keystone-2013.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.ebuild,v 1.1 2013/04/10 16:12:49 prometheanfire Exp $
+
+EAPI=5
+#test restricted becaues of bad requirements given (old webob for instance)
+RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Keystone is the Openstack authentication, authorization, and
+service catalog written in Python."
+HOMEPAGE="https://launchpad.net/keystone"
+SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="folsom"
+KEYWORDS="~amd64 ~x86"
+IUSE="+sqlite mysql postgres ldap"
+#IUSE="+sqlite mysql postgres ldap test"
+REQUIRED_USE="|| ( ldap mysql postgres sqlite )"
+
+#todo, seperate out rdepend via use flags
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
+ <=dev-python/python-keystoneclient-0.3[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/python-daemon
+ >=dev-python/python-pam-0.1.4[${PYTHON_USEDEP}]
+ dev-python/routes[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ =dev-python/webob-1.2.3-r1[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite]
+ <=dev-python/sqlalchemy-0.7.9[sqlite] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql]
+ <=dev-python/sqlalchemy-0.7.9[mysql] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres]
+ <=dev-python/sqlalchemy-0.7.9[postgres] )
+ ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )"
+# test? ( dev-python/Babel
+# dev-python/decorator
+# dev-python/eventlet
+# dev-python/greenlet
+# dev-python/httplib2
+# dev-python/iso8601
+# dev-python/lxml
+# dev-python/netifaces
+# dev-python/nose
+# dev-python/nosexcover
+# dev-python/passlib
+# dev-python/paste
+# dev-python/pastedeploy
+# dev-python/python-pam
+# dev-python/repoze-lru
+# dev-python/routes
+# dev-python/sphinx
+# >=dev-python/sqlalchemy-migrate-0.7
+# dev-python/tempita
+# >=dev-python/webob-1.0.8
+# dev-python/webtest
+# )
+#PATCHES=( "${FILESDIR}"/keystone_test-requires.patch )
+#
+#python_test() {
+# "${PYTHON}" setup.py nosetests || die
+#}
+
+python_install() {
+ distutils-r1_python_install
+ newconfd "${FILESDIR}/keystone.confd" keystone
+ newinitd "${FILESDIR}/keystone.initd" keystone
+
+ diropts -m 0750
+ dodir /var/run/keystone /var/log/keystone /etc/keystone
+ keepdir /etc/keystone
+ insinto /etc/keystone
+ doins etc/keystone.conf.sample etc/logging.conf.sample
+ doins etc/default_catalog.templates etc/policy.json
+}