summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-05-06 15:57:35 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-05-06 15:57:35 +0000
commit13d8ab0b3bf922eedfa49956c08cdeb5eeb3173c (patch)
tree02695b5623fd007d75ff60768b069241393b9b3d /sys-auth
parentUnmask dev-python/pypy-2.0_beta2. (diff)
downloadgentoo-2-13d8ab0b3bf922eedfa49956c08cdeb5eeb3173c.tar.gz
gentoo-2-13d8ab0b3bf922eedfa49956c08cdeb5eeb3173c.tar.bz2
gentoo-2-13d8ab0b3bf922eedfa49956c08cdeb5eeb3173c.zip
keystone-2013.1-r1 for bug 467054 CVE-2013-1977
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/keystone/ChangeLog9
-rw-r--r--sys-auth/keystone/files/keystone-grizzly-1-CVE-2013-2006.patch41
-rw-r--r--sys-auth/keystone/keystone-2013.1-r1.ebuild (renamed from sys-auth/keystone/keystone-2013.1.ebuild)4
3 files changed, 51 insertions, 3 deletions
diff --git a/sys-auth/keystone/ChangeLog b/sys-auth/keystone/ChangeLog
index 83ff0181e29f..58ee084f4b0f 100644
--- a/sys-auth/keystone/ChangeLog
+++ b/sys-auth/keystone/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-auth/keystone
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.13 2013/04/11 07:17:05 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/ChangeLog,v 1.14 2013/05/06 15:57:35 prometheanfire Exp $
+
+*keystone-2013.1-r1 (06 May 2013)
+
+ 06 May 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +files/keystone-grizzly-1-CVE-2013-2006.patch, +keystone-2013.1-r1.ebuild,
+ -keystone-2013.1.ebuild:
+ keystone-2013.1-r1 for bug 467054 CVE-2013-1977
11 Apr 2013; Matthew Thode <prometheanfire@gentoo.org> keystone-9999.ebuild:
updating keystone 9999 to have better deps
diff --git a/sys-auth/keystone/files/keystone-grizzly-1-CVE-2013-2006.patch b/sys-auth/keystone/files/keystone-grizzly-1-CVE-2013-2006.patch
new file mode 100644
index 000000000000..d9b0b3472ceb
--- /dev/null
+++ b/sys-auth/keystone/files/keystone-grizzly-1-CVE-2013-2006.patch
@@ -0,0 +1,41 @@
+From c5037dd6b82909efaaa8720e8cfa8bdb8b4a0edd Mon Sep 17 00:00:00 2001
+From: Xuhan Peng <xuhanp@cn.ibm.com>
+Date: Fri, 12 Apr 2013 16:19:37 +0800
+Subject: [PATCH] Mark LDAP password and admin_token secret
+
+Add secret=True to LDAP password and admin_token
+of keystone configuration.
+
+Fix bug #1172195
+
+Change-Id: I8ef7f705e3f6b374ff427c20eb761892d5146a75
+(cherry picked from commit d43e2a51a1ed7adbed3c5ddf001d46bc4a824ae8)
+---
+ keystone/common/config.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/keystone/common/config.py b/keystone/common/config.py
+index edecee0..82c31e6 100644
+--- a/keystone/common/config.py
++++ b/keystone/common/config.py
+@@ -188,7 +188,7 @@ def configure():
+ register_cli_str('pydev-debug-host', default=None)
+ register_cli_int('pydev-debug-port', default=None)
+
+- register_str('admin_token', default='ADMIN')
++ register_str('admin_token', secret=True, default='ADMIN')
+ register_str('bind_host', default='0.0.0.0')
+ register_int('compute_port', default=8774)
+ register_int('admin_port', default=35357)
+@@ -271,7 +271,7 @@ def configure():
+ # ldap
+ register_str('url', group='ldap', default='ldap://localhost')
+ register_str('user', group='ldap', default=None)
+- register_str('password', group='ldap', default=None)
++ register_str('password', group='ldap', secret=True, default=None)
+ register_str('suffix', group='ldap', default='cn=example,cn=com')
+ register_bool('use_dumb_member', group='ldap', default=False)
+ register_str('dumb_member', group='ldap', default='cn=dumb,dc=nonexistent')
+--
+1.8.1.5
+
diff --git a/sys-auth/keystone/keystone-2013.1.ebuild b/sys-auth/keystone/keystone-2013.1-r1.ebuild
index 771946de3a2a..cf05507f7dbc 100644
--- a/sys-auth/keystone/keystone-2013.1.ebuild
+++ b/sys-auth/keystone/keystone-2013.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1.ebuild,v 1.1 2013/04/10 16:12:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/keystone/keystone-2013.1-r1.ebuild,v 1.1 2013/05/06 15:57:35 prometheanfire Exp $
EAPI=5
#test restricted becaues of bad requirements given (old webob for instance)
@@ -69,7 +69,7 @@ RDEPEND="${DEPEND}
# >=dev-python/webob-1.0.8
# dev-python/webtest
# )
-#PATCHES=( "${FILESDIR}"/keystone_test-requires.patch )
+PATCHES=( "${FILESDIR}"/keystone-grizzly-1-CVE-2013-2006.patch )
#
#python_test() {
# "${PYTHON}" setup.py nosetests || die