summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-17 17:58:01 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-17 17:58:01 +0000
commit00367ae58196714204412d04c81ee0f225ef6195 (patch)
treed8133c275331d180c9f1c8f5a5fb130d508300f3 /sys-auth
parentbring ~amd64-fbsd keywords to latest versions too (diff)
downloadgentoo-2-00367ae58196714204412d04c81ee0f225ef6195.tar.gz
gentoo-2-00367ae58196714204412d04c81ee0f225ef6195.tar.bz2
gentoo-2-00367ae58196714204412d04c81ee0f225ef6195.zip
Add epatch_user support.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-pam-ldapd/ChangeLog5
-rw-r--r--sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/sys-auth/nss-pam-ldapd/ChangeLog b/sys-auth/nss-pam-ldapd/ChangeLog
index 74056655ae13..54f2dbf1c1cc 100644
--- a/sys-auth/nss-pam-ldapd/ChangeLog
+++ b/sys-auth/nss-pam-ldapd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-auth/nss-pam-ldapd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/ChangeLog,v 1.8 2013/04/05 15:04:50 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/ChangeLog,v 1.9 2013/04/17 17:58:01 radhermit Exp $
+
+ 17 Apr 2013; Tim Harder <radhermit@gentoo.org> nss-pam-ldapd-0.9.0.ebuild:
+ Add epatch_user support.
*nss-pam-ldapd-0.9.0 (05 Apr 2013)
diff --git a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild
index 868388d914b8..2765f674c022 100644
--- a/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild
+++ b/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild,v 1.1 2013/04/05 15:04:50 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-pam-ldapd/nss-pam-ldapd-0.9.0.ebuild,v 1.2 2013/04/17 17:58:01 radhermit Exp $
EAPI=4
-inherit multilib user
+inherit eutils multilib user
DESCRIPTION="NSS module for name lookups using LDAP"
HOMEPAGE="http://arthurdejong.org/nss-pam-ldapd/"
@@ -28,6 +28,11 @@ pkg_setup() {
enewuser nslcd -1 -1 -1 nslcd
}
+src_prepare() {
+ # support user patches
+ epatch_user
+}
+
src_configure() {
# nss libraries always go in /lib on Gentoo
myconf="--enable-warnings