summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-17 22:54:30 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-17 22:54:30 +0000
commit7702602a062f244df58c8808f9d3d09d8c664aa2 (patch)
tree8fd193055d4ec2045709b23ddd229d99a5d87c78 /sys-auth/pam_fprint
parentMasking qbittorrent-2.5.0 beta releases (diff)
downloadgentoo-2-7702602a062f244df58c8808f9d3d09d8c664aa2.tar.gz
gentoo-2-7702602a062f244df58c8808f9d3d09d8c664aa2.tar.bz2
gentoo-2-7702602a062f244df58c8808f9d3d09d8c664aa2.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth/pam_fprint')
-rw-r--r--sys-auth/pam_fprint/ChangeLog11
-rw-r--r--sys-auth/pam_fprint/files/pam_fprint-0.2-headers.patch12
-rw-r--r--sys-auth/pam_fprint/metadata.xml10
-rw-r--r--sys-auth/pam_fprint/pam_fprint-0.2.ebuild35
4 files changed, 68 insertions, 0 deletions
diff --git a/sys-auth/pam_fprint/ChangeLog b/sys-auth/pam_fprint/ChangeLog
new file mode 100644
index 000000000000..2b6157112eda
--- /dev/null
+++ b/sys-auth/pam_fprint/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/pam_fprint
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_fprint/ChangeLog,v 1.1 2010/10/17 22:54:30 xmw Exp $
+
+*pam_fprint-0.2 (17 Oct 2010)
+
+ 17 Oct 2010; Michael Weber <xmw@gentoo.org> +pam_fprint-0.2.ebuild,
+ +files/pam_fprint-0.2-headers.patch, +metadata.xml:
+ Initial import, fixes bug 227671, thanks to Jan Buecken and others on this
+ bug.
+
diff --git a/sys-auth/pam_fprint/files/pam_fprint-0.2-headers.patch b/sys-auth/pam_fprint/files/pam_fprint-0.2-headers.patch
new file mode 100644
index 000000000000..9ff6e551ee87
--- /dev/null
+++ b/sys-auth/pam_fprint/files/pam_fprint-0.2-headers.patch
@@ -0,0 +1,12 @@
+Add definition of free and setenv, Michael Weber <xmw@gentoo.org> Oct 18th, 2010
+
+--- pam_fprint-0.2/src/pam_fprint.c
++++ pam_fprint-0.2/src/pam_fprint.c
+@@ -22,6 +22,7 @@
+ #include <sys/types.h>
+ #include <pwd.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ #include <fprint.h>
+
diff --git a/sys-auth/pam_fprint/metadata.xml b/sys-auth/pam_fprint/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/sys-auth/pam_fprint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/sys-auth/pam_fprint/pam_fprint-0.2.ebuild b/sys-auth/pam_fprint/pam_fprint-0.2.ebuild
new file mode 100644
index 000000000000..2bd243b8dea2
--- /dev/null
+++ b/sys-auth/pam_fprint/pam_fprint-0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_fprint/pam_fprint-0.2.ebuild,v 1.1 2010/10/17 22:54:30 xmw Exp $
+
+EAPI=3
+
+inherit autotools eutils multilib
+
+DESCRIPTION="a simple PAM module which uses libfprint's functionality for authentication"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Pam_fprint"
+SRC_URI="mirror://sourceforge/fprint/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-auth/libfprint
+ sys-libs/pam"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-headers.patch
+
+ # adjust /lib/security to architecture
+ sed -i -e "/^pammoddir=/s:=.*:=\"${EPREFIX}\"/$(get_libdir)/security:" \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ newbin src/pamtest pamtest.fprint || die
+ dodoc AUTHORS ChangeLog NEWS README || die
+}