summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-06 05:29:07 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-06 05:29:07 +0000
commitdf9a2f03eb65c6f9251cef479caabeadab726069 (patch)
treec99e10ed566ae9008d50a818380d1f60bf4fcf7d /sys-auth/bioapi
parentVersion bump <http://my.opera.com/desktopteam/blog/2008/09/05/9-60-beta-1-rc>. (diff)
downloadgentoo-2-df9a2f03eb65c6f9251cef479caabeadab726069.tar.gz
gentoo-2-df9a2f03eb65c6f9251cef479caabeadab726069.tar.bz2
gentoo-2-df9a2f03eb65c6f9251cef479caabeadab726069.zip
Apply fix by kouyu for missing return value #236654.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-auth/bioapi')
-rw-r--r--sys-auth/bioapi/ChangeLog8
-rw-r--r--sys-auth/bioapi/bioapi-1.2.3-r1.ebuild83
-rw-r--r--sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch16
3 files changed, 106 insertions, 1 deletions
diff --git a/sys-auth/bioapi/ChangeLog b/sys-auth/bioapi/ChangeLog
index 1d4ff03a9efd..16708e168e93 100644
--- a/sys-auth/bioapi/ChangeLog
+++ b/sys-auth/bioapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/bioapi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.7 2008/02/27 10:24:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/ChangeLog,v 1.8 2008/09/06 05:29:07 vapier Exp $
+
+*bioapi-1.2.3-r1 (06 Sep 2008)
+
+ 06 Sep 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/bioapi-1.2.3-enroll-ret.patch, +bioapi-1.2.3-r1.ebuild:
+ Apply fix by kouyu for missing return value #236654.
27 Feb 2008; Mike Frysinger <vapier@gentoo.org> bioapi-1.2.3.ebuild:
Add missing eutils inherit for enewgroup as pointed out by Shufeng Zheng.
diff --git a/sys-auth/bioapi/bioapi-1.2.3-r1.ebuild b/sys-auth/bioapi/bioapi-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..a2edc1d4d5ec
--- /dev/null
+++ b/sys-auth/bioapi/bioapi-1.2.3-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/bioapi/bioapi-1.2.3-r1.ebuild,v 1.1 2008/09/06 05:29:07 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Framework for biometric-based authentication"
+HOMEPAGE="http://code.google.com/p/bioapi-linux/"
+SRC_URI="http://bioapi-linux.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="bioapi"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt3"
+
+DEPEND="qt3? ( =x11-libs/qt-3* )"
+
+S=${WORKDIR}/bioapi-linux
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-enroll-ret.patch #236654
+}
+
+src_compile() {
+ econf $(use_with qt3 Qt-dir /usr/qt/3) || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake SKIPCONFIG=true DESTDIR="${D}" install || die "install failed"
+ dodoc README
+ dohtml *.htm
+
+ # rename generic binaries
+ mv "${D}"/usr/bin/{,BioAPI}Sample || die
+ if use qt3 ; then
+ mv "${D}"/usr/bin/{,BioAPI}QSample || die
+ fi
+}
+
+pkg_config() {
+ mds_install -s /usr/$(get_libdir)
+ mod_install -fi /usr/$(get_libdir)/libbioapi100.so
+ mod_install -fi /usr/$(get_libdir)/libbioapi_dummy100.so
+ mod_install -fi /usr/$(get_libdir)/libpwbsp.so
+ use qt3 && mod_install -fi /usr/$(get_libdir)/libqtpwbsp.so
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/var/bioapi ]] && [[ ! -e ${ROOT}/var/lib/bioapi ]] ; then
+ einfo "Moving /var/bioapi to /var/lib/bioapi"
+ dodir /var/lib
+ mv "${ROOT}"/var/bioapi "${ROOT}"/var/lib/bioapi
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some generic-named programs have been renamed:"
+ einfo " Sample -> BioAPISample"
+ einfo " QSample -> BioAPIQSample"
+
+ if [[ ${ROOT} == "/" ]] ; then
+ pkg_config
+ else
+ ewarn "You will need to run 'emerge --config bioapi' before"
+ ewarn " you can use bioapi properly."
+ fi
+
+ # XXX: this can't be correct ...
+ enewgroup bioapi
+ chgrp bioapi "${ROOT}"/var/lib/bioapi -R
+ chmod g+w,o= "${ROOT}"/var/lib/bioapi -R
+ einfo "Note: users using bioapi must be in group bioapi."
+}
+
+pkg_prerm() {
+ mod_install -fu libbioapi100.so
+ mod_install -fu libbioapi_dummy100.so
+ mod_install -fu libpwbsp.so
+ use qt3 && mod_install -fu libqtpwbsp.so
+}
diff --git a/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch b/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch
new file mode 100644
index 000000000000..e077c135d63f
--- /dev/null
+++ b/sys-auth/bioapi/files/bioapi-1.2.3-enroll-ret.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/236654
+
+make sure we return 0 when things work
+
+patch by kouyu
+
+--- bioapi-linux/apps/NonGUI_Sample/main.c
++++ bioapi-linux/apps/NonGUI_Sample/main.c
+@@ -234,6 +234,7 @@
+ }
+
+ OutputToFile(userName, EnrolledTemplate);
++ return 0;
+ }
+ }
+