summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Bennett <spb@gentoo.org>2007-02-27 02:43:34 +0000
committerStephen Bennett <spb@gentoo.org>2007-02-27 02:43:34 +0000
commitfe4ef47884ee0398d02d4c4f61cc92b59393ecaa (patch)
tree119fd816c729e5a53c98f7185666f0846c0de185 /sys-apps
parentamd64 stable, security bug 167730 (diff)
downloadgentoo-2-fe4ef47884ee0398d02d4c4f61cc92b59393ecaa.tar.gz
gentoo-2-fe4ef47884ee0398d02d4c4f61cc92b59393ecaa.tar.bz2
gentoo-2-fe4ef47884ee0398d02d4c4f61cc92b59393ecaa.zip
Remove selinux logic from ebuild
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/ChangeLog6
-rw-r--r--sys-apps/paludis/paludis-0.20.0.ebuild6
2 files changed, 7 insertions, 5 deletions
diff --git a/sys-apps/paludis/ChangeLog b/sys-apps/paludis/ChangeLog
index 43cdb2cb65e3..4e97eb49784a 100644
--- a/sys-apps/paludis/ChangeLog
+++ b/sys-apps/paludis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/paludis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.48 2007/02/24 04:24:46 pioto Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.49 2007/02/27 02:43:34 spb Exp $
+
+ 27 Feb 2007; Stephen Bennett <spb@gentoo.org> paludis-0.20.0.ebuild:
+ Remove selinux logic from the ebuild; it's now built unconditionally and
+ switched at runtime
*paludis-0.20.0 (24 Feb 2007)
diff --git a/sys-apps/paludis/paludis-0.20.0.ebuild b/sys-apps/paludis/paludis-0.20.0.ebuild
index a664b8d183ac..55d782409ba3 100644
--- a/sys-apps/paludis/paludis-0.20.0.ebuild
+++ b/sys-apps/paludis/paludis-0.20.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.20.0.ebuild,v 1.1 2007/02/24 04:24:46 pioto Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.20.0.ebuild,v 1.2 2007/02/27 02:43:34 spb Exp $
inherit bash-completion eutils flag-o-matic
@@ -11,11 +11,10 @@ SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
-IUSE="contrarius cran doc glsa inquisitio pink qa ruby selinux zsh-completion"
+IUSE="contrarius cran doc glsa inquisitio pink qa ruby zsh-completion"
COMMON_DEPEND="
>=app-shells/bash-3.1
- selinux? ( sys-libs/libselinux )
qa? ( dev-libs/pcre++ >=dev-libs/libxml2-2.6 app-crypt/gnupg )
inquisitio? ( dev-libs/pcre++ )
glsa? ( >=dev-libs/libxml2-2.6 )
@@ -56,7 +55,6 @@ src_compile() {
$(use_enable doc doxygen ) \
$(use_enable !mips sandbox ) \
$(use_enable pink) \
- $(use_enable selinux) \
$(use_enable qa) \
$(use_enable ruby) \
$(use_enable glsa) \