summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-05 06:06:21 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-05 06:06:21 +0000
commitfb7ad8a1c3b55054b6c6b78c68fc4eaf2c5feb01 (patch)
tree083eb66fbf67fa150ec3025bf9c1d39bf20dbf18 /sys-apps
parentold (diff)
downloadgentoo-2-fb7ad8a1c3b55054b6c6b78c68fc4eaf2c5feb01.tar.gz
gentoo-2-fb7ad8a1c3b55054b6c6b78c68fc4eaf2c5feb01.tar.bz2
gentoo-2-fb7ad8a1c3b55054b6c6b78c68fc4eaf2c5feb01.zip
Version bump #175708 by Raul Porcel.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/findutils/ChangeLog9
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.2.303
-rw-r--r--sys-apps/findutils/files/digest-findutils-4.3.33
-rw-r--r--sys-apps/findutils/findutils-4.2.30.ebuild65
-rw-r--r--sys-apps/findutils/findutils-4.3.3.ebuild62
5 files changed, 141 insertions, 1 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 08c9ac19c2ef..7522e1111733 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.97 2007/02/10 18:44:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.98 2007/05/05 06:06:21 vapier Exp $
+
+*findutils-4.3.3 (05 May 2007)
+*findutils-4.2.30 (05 May 2007)
+
+ 05 May 2007; Mike Frysinger <vapier@gentoo.org> +findutils-4.2.30.ebuild,
+ +findutils-4.3.3.ebuild:
+ Version bump #175708 by Raul Porcel.
*findutils-4.3.2-r1 (10 Feb 2007)
diff --git a/sys-apps/findutils/files/digest-findutils-4.2.30 b/sys-apps/findutils/files/digest-findutils-4.2.30
new file mode 100644
index 000000000000..0610d01b91f1
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.2.30
@@ -0,0 +1,3 @@
+MD5 c35ff6502e0b3514c99089cb5d333c25 findutils-4.2.30.tar.gz 1188123
+RMD160 bd0079088e65b90c16897f8f3a64ad8a0d1d040f findutils-4.2.30.tar.gz 1188123
+SHA256 344b9cbb4034907f80398c6a6d3724507ff4b519036f13bb811d12f702043af4 findutils-4.2.30.tar.gz 1188123
diff --git a/sys-apps/findutils/files/digest-findutils-4.3.3 b/sys-apps/findutils/files/digest-findutils-4.3.3
new file mode 100644
index 000000000000..1ec4bbd5c073
--- /dev/null
+++ b/sys-apps/findutils/files/digest-findutils-4.3.3
@@ -0,0 +1,3 @@
+MD5 ff0e65422ef615ad14cbd0582384ad34 findutils-4.3.3.tar.gz 1688202
+RMD160 1dddd4e1bb7845479435cdd392f2aa685396713f findutils-4.3.3.tar.gz 1688202
+SHA256 b40e88d3d2fe17be04fe9e39be36b7e9e74ee673ab041fb2c5294c80b43c034d findutils-4.3.3.tar.gz 1688202
diff --git a/sys-apps/findutils/findutils-4.2.30.ebuild b/sys-apps/findutils/findutils-4.2.30.ebuild
new file mode 100644
index 000000000000..72278f0bc436
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.2.30.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.30.ebuild,v 1.1 2007/05/05 06:06:21 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+SELINUX_PATCH="findutils-4.2.24-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls build selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
+ econf $(use_enable nls) ${myconf} || die "configure failed"
+ emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" libexecdir="${D}/usr/lib/find" install || die
+
+ rm -rf "${D}"/usr/var
+ use build \
+ && rm -rf "${D}"/usr/share \
+ || dodoc NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "Please note that the locate and updatedb binaries"
+ ewarn "are now provided by slocate, not findutils."
+}
diff --git a/sys-apps/findutils/findutils-4.3.3.ebuild b/sys-apps/findutils/findutils-4.3.3.ebuild
new file mode 100644
index 000000000000..8fbf1bec223d
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.3.ebuild,v 1.1 2007/05/05 06:06:21 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+SELINUX_PATCH="findutils-4.3.1-selinux.diff"
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="http://www.gnu.org/software/findutils/findutils.html"
+# SRC_URI="mirror://gnu/${PN}/${P}.tar.gz mirror://gentoo/${P}.tar.gz"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't build or install locate because it conflicts with slocate,
+ # which is a secure version of locate. See bug 18729
+ sed -i '/^SUBDIRS/s/locate//' Makefile.in
+
+ # Patches for selinux
+ use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
+
+ if ! has userpriv ${FEATURES} ; then
+ sed -i '/access.exp/d' find/testsuite/Makefile.in
+ rm -f find/testsuite/find.gnu/access.{exp,xo}
+ fi
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ local myconf
+ use userland_GNU || myconf=" --program-prefix=g"
+
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
+ myconf="${myconf} --without-included-regex"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ --libexecdir=/usr/$(get_libdir)/find \
+ ${myconf} \
+ || die "configure failed"
+ emake AR="$(tc-getAR)" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README TODO ChangeLog
+}