summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-08-16 21:23:57 +0000
committerMike Frysinger <vapier@gentoo.org>2010-08-16 21:23:57 +0000
commitd041a412922844bff3a5e46e793cdd68abe6d527 (patch)
tree6a3b18017d858522aa6bca4c69892207076afe41 /sys-apps
parentold (diff)
downloadgentoo-2-d041a412922844bff3a5e46e793cdd68abe6d527.tar.gz
gentoo-2-d041a412922844bff3a5e46e793cdd68abe6d527.tar.bz2
gentoo-2-d041a412922844bff3a5e46e793cdd68abe6d527.zip
Add more fixes from upstream, and fix default shell config #333005 by Eugene Shalygin.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog9
-rw-r--r--sys-apps/busybox/busybox-1.17.1-r1.ebuild263
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-mdev.patch49
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-sed.patch61
4 files changed, 376 insertions, 6 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index b842e651f72f..e75bcade8f00 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.253 2010/08/15 17:29:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.254 2010/08/16 21:23:57 vapier Exp $
+
+*busybox-1.17.1-r1 (16 Aug 2010)
+
+ 16 Aug 2010; Mike Frysinger <vapier@gentoo.org> +busybox-1.17.1-r1.ebuild,
+ +files/busybox-1.17.1-mdev.patch, files/busybox-1.17.1-sed.patch:
+ Add more fixes from upstream, and fix default shell config #333005 by Eugene
+ Shalygin.
15 Aug 2010; Mike Frysinger <vapier@gentoo.org> busybox-1.17.1.ebuild:
Disable rfkill by default #332803 by Hans Nieser.
diff --git a/sys-apps/busybox/busybox-1.17.1-r1.ebuild b/sys-apps/busybox/busybox-1.17.1-r1.ebuild
new file mode 100644
index 000000000000..331bd31a0ee3
--- /dev/null
+++ b/sys-apps/busybox/busybox-1.17.1-r1.ebuild
@@ -0,0 +1,263 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.1-r1.ebuild,v 1.1 2010/08/16 21:23:57 vapier Exp $
+
+EAPI=2
+inherit eutils flag-o-matic savedconfig toolchain-funcs
+
+################################################################################
+# BUSYBOX ALTERNATE CONFIG MINI-HOWTO
+#
+# Busybox can be modified in many different ways. Here's a few ways to do it:
+#
+# (1) Emerge busybox with FEATURES=keepwork so the work directory won't
+# get erased afterwards. Add a definition like ROOT=/my/root/path to the
+# start of the line if you're installing to somewhere else than the root
+# directory. This command will save the default configuration to
+# ${PORTAGE_CONFIGROOT} (or ${ROOT} if ${PORTAGE_CONFIGROOT} is not
+# defined), and it will tell you that it has done this. Note the location
+# where the config file was saved.
+#
+# FEATURES=keepwork USE=savedconfig emerge busybox
+#
+# (2) Go to the work directory and change the configuration of busybox using its
+# menuconfig feature.
+#
+# cd /var/tmp/portage/busybox*/work/busybox-*
+# make menuconfig
+#
+# (3) Save your configuration to the default location and copy it to the
+# one of the locations listed in /usr/portage/eclass/savedconfig.eclass
+#
+# (4) Emerge busybox with USE=savedconfig to use the configuration file you
+# just generated.
+#
+################################################################################
+#
+# (1) Alternatively skip the above steps and simply emerge busybox without
+# USE=savedconfig.
+#
+# (2) Edit the file it saves by hand. ${ROOT}"/etc/portage/savedconfig/${CATEGORY}/${PF}
+#
+# (3) Remerge busybox as using USE=savedconfig.
+#
+################################################################################
+
+#SNAPSHOT=20040726
+SNAPSHOT=""
+
+DESCRIPTION="Utilities for rescue and embedded systems"
+HOMEPAGE="http://www.busybox.net/"
+if [[ -n ${SNAPSHOT} ]] ; then
+ MY_P=${PN}
+ SRC_URI="http://www.busybox.net/downloads/snapshots/${PN}-${SNAPSHOT}.tar.bz2"
+else
+ MY_P=${PN}-${PV/_/-}
+ SRC_URI="http://www.busybox.net/downloads/${MY_P}.tar.bz2"
+fi
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug ipv6 make-symlinks +mdev -pam selinux static elibc_glibc"
+RESTRICT="test"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( sys-libs/pam )"
+
+S=${WORKDIR}/${MY_P}
+
+busybox_config_option() {
+ case $1 in
+ y) sed -i -e "s:.*\<CONFIG_$2\>.*set:CONFIG_$2=y:g" .config;;
+ n) sed -i -e "s:CONFIG_$2=y:# CONFIG_$2 is not set:g" .config;;
+ *) use $1 \
+ && busybox_config_option y $2 \
+ || busybox_config_option n $2
+ return 0
+ ;;
+ esac
+ einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
+}
+
+src_prepare() {
+ unset KBUILD_OUTPUT #88088
+
+ # patches go here!
+ epatch "${FILESDIR}"/busybox-1.17.0-bb.patch
+ epatch "${FILESDIR}"/busybox-${PV}-*.patch
+
+ # flag cleanup
+ sed -i -r \
+ -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
+ Makefile.flags || die
+ #sed -i '/bbsh/s:^//::' include/applets.h
+ sed -i '/^#error Aborting compilation./d' applets/applets.c || die
+ use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
+ sed -i \
+ -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
+ -e "/^CC/s:=.*:= $(tc-getCC):" \
+ -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
+ Makefile || die
+
+ # check for a busybox config before making one of our own.
+ # if one exist lets return and use it.
+
+ restore_config .config
+ if [ -f .config ]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ ewarn "Could not locate user configfile, so we will save a default one"
+ fi
+
+ # setup the config file
+ emake -j1 allyesconfig > /dev/null
+ busybox_config_option n DMALLOC
+ busybox_config_option n FEATURE_SUID_CONFIG
+ busybox_config_option n BUILD_AT_ONCE
+ busybox_config_option n BUILD_LIBBUSYBOX
+ busybox_config_option n NOMMU
+ busybox_config_option n MONOTONIC_SYSCALL
+
+ # If these are not set and we are using a uclibc/busybox setup
+ # all calls to system() will fail.
+ busybox_config_option y ASH
+ busybox_config_option n HUSH
+
+ # disable ipv6 applets
+ if ! use ipv6; then
+ busybox_config_option n FEATURE_IPV6
+ busybox_config_option n TRACEROUTE6
+ busybox_config_option n PING6
+ fi
+
+ if use static && use pam ; then
+ ewarn "You cannot have USE='static pam'. Assuming static is more important."
+ fi
+ use static \
+ && busybox_config_option n PAM \
+ || busybox_config_option pam PAM
+ busybox_config_option static STATIC
+ busybox_config_option debug DEBUG
+ use debug \
+ && busybox_config_option y NO_DEBUG_LIB \
+ && busybox_config_option n DMALLOC \
+ && busybox_config_option n EFENCE
+
+ busybox_config_option selinux SELINUX
+
+ # default a bunch of uncommon options to off
+ local opt
+ for opt in \
+ CRONTAB \
+ DC DEVFSD DNSD DPKG \
+ FAKEIDENTD FBSPLASH FOLD FTP{GET,PUT} \
+ HOSTID HUSH \
+ INETD INOTIFYD IPCALC \
+ LASH LOCALE_SUPPORT LOGNAME LPD \
+ MSH \
+ OD \
+ RFKILL \
+ SLATTACH SULOGIN \
+ TASKSET TCPSVD \
+ RPM RPM2CPIO \
+ UDPSVD UUDECODE UUENCODE
+ do
+ busybox_config_option n ${opt}
+ done
+
+ emake -j1 oldconfig > /dev/null
+}
+
+src_compile() {
+ unset KBUILD_OUTPUT #88088
+ export SKIP_STRIP=y
+
+ emake busybox || die "build failed"
+ if ! use static && ! use pam ; then
+ mv busybox_unstripped{,.bak}
+ emake CONFIG_STATIC=y busybox || die "static build failed"
+ mv busybox_unstripped bb
+ mv busybox_unstripped{.bak,}
+ fi
+}
+
+src_install() {
+ unset KBUILD_OUTPUT #88088
+ save_config .config
+
+ into /
+ newbin busybox_unstripped busybox || die
+ if use static || use pam ; then
+ dosym busybox /bin/bb || die
+ dosym bb /bin/busybox.static || die
+ else
+ dobin bb || die
+ fi
+ if use mdev; then
+ dodir /$(get_libdir)/mdev/
+ use make-symlinks || dosym /bin/bb /sbin/mdev
+ cp "${S}"/examples/mdev_fat.conf "${D}"/etc/mdev.conf
+
+ exeinto /$(get_libdir)/mdev/
+ doexe "${FILESDIR}"/mdev/*
+
+ insinto /$(get_libdir)/rcscripts/addons
+ doins "${FILESDIR}"/mdev-start.sh || die
+ newinitd "${FILESDIR}"/mdev.rc mdev || die
+ fi
+
+ # bundle up the symlink files for use later
+ emake install || die
+ rm _install/bin/busybox
+ tar cf busybox-links.tar -C _install . || : #;die
+ insinto /usr/share/${PN}
+ doins busybox-links.tar || die
+ newins .config ${PF}.config || die
+
+ dodoc AUTHORS README TODO
+
+ cd docs || die
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html
+
+ cd ../examples || die
+ docinto examples
+ dodoc inittab depmod.pl *.conf *.script undeb unrpm
+
+ cd bootfloppy || die
+ docinto bootfloppy
+ dodoc $(find . -type f)
+}
+
+pkg_preinst() {
+ if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
+ ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
+ ewarn "If you are creating a binary only and not merging this is probably ok."
+ ewarn "set env VERY_BRAVE_OR_VERY_DUMB=yes if this is realy what you want."
+ die "silly options will destroy your system"
+ fi
+
+ if use make-symlinks ; then
+ mv "${D}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use make-symlinks ; then
+ cd "${T}" || die
+ mkdir _install
+ tar xf busybox-links.tar -C _install || die
+ cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ fi
+
+ echo
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ echo
+}
diff --git a/sys-apps/busybox/files/busybox-1.17.1-mdev.patch b/sys-apps/busybox/files/busybox-1.17.1-mdev.patch
new file mode 100644
index 000000000000..e20192cfffe2
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.17.1-mdev.patch
@@ -0,0 +1,49 @@
+diff -urpN busybox-1.17.1/testsuite/mdev.tests busybox-1.17.1-mdev/testsuite/mdev.tests
+--- busybox-1.17.1/testsuite/mdev.tests 2010-07-06 04:25:54.000000000 +0200
++++ busybox-1.17.1-mdev/testsuite/mdev.tests 2010-08-16 14:28:26.192074223 +0200
+@@ -38,6 +38,16 @@ brw-rw---- 1 0 0 8,0 sda
+ SKIP=
+
+ # continuing to use directory structure from prev test
++optional STATIC FEATURE_MDEV_CONF FEATURE_LS_TIMESTAMPS FEATURE_LS_USERNAME
++testing "mdev deletes /block/sda" \
++ "env - PATH=$PATH ACTION=remove DEVPATH=/block/sda chroot mdev.testdir /mdev 2>&1;
++ ls -ln mdev.testdir/dev | $FILTER_LS" \
++"\
++" \
++ "" ""
++SKIP=
++
++# continuing to use directory structure from prev test
+ rm -rf mdev.testdir/dev/*
+ echo ".* 1:1 666" >mdev.testdir/etc/mdev.conf
+ echo "sda 2:2 444" >>mdev.testdir/etc/mdev.conf
+diff -urpN busybox-1.17.1/util-linux/mdev.c busybox-1.17.1-mdev/util-linux/mdev.c
+--- busybox-1.17.1/util-linux/mdev.c 2010-07-06 04:25:54.000000000 +0200
++++ busybox-1.17.1-mdev/util-linux/mdev.c 2010-08-16 14:28:26.193074080 +0200
+@@ -132,6 +132,7 @@ static void make_device(char *path, int
+ major = -1;
+ }
+ }
++ /* else: for delete, -1 still deletes the node, but < -1 suppresses that */
+
+ /* Determine device name, type, major and minor */
+ device_name = (char*) bb_basename(path);
+@@ -279,7 +280,7 @@ static void make_device(char *path, int
+ if (aliaslink == '!' && s == a+1) {
+ val = st;
+ /* "!": suppress node creation/deletion */
+- major = -1;
++ major = -2;
+ }
+ else if (aliaslink == '>' || aliaslink == '=') {
+ val = st;
+@@ -379,7 +380,7 @@ static void make_device(char *path, int
+ free(command);
+ }
+
+- if (delete && major >= 0) {
++ if (delete && major >= -1) {
+ if (ENABLE_FEATURE_MDEV_RENAME && alias) {
+ if (aliaslink == '>')
+ unlink(device_name);
diff --git a/sys-apps/busybox/files/busybox-1.17.1-sed.patch b/sys-apps/busybox/files/busybox-1.17.1-sed.patch
index 1b523c2ce8b2..15b77064aa6f 100644
--- a/sys-apps/busybox/files/busybox-1.17.1-sed.patch
+++ b/sys-apps/busybox/files/busybox-1.17.1-sed.patch
@@ -1,6 +1,6 @@
diff -urpN busybox-1.17.1/editors/sed.c busybox-1.17.1-sed/editors/sed.c
--- busybox-1.17.1/editors/sed.c 2010-07-06 04:25:53.000000000 +0200
-+++ busybox-1.17.1-sed/editors/sed.c 2010-08-01 04:15:39.000000000 +0200
++++ busybox-1.17.1-sed/editors/sed.c 2010-08-16 16:27:49.966074102 +0200
@@ -61,6 +61,10 @@
#include "libbb.h"
#include "xregex.h"
@@ -25,7 +25,36 @@ diff -urpN busybox-1.17.1/editors/sed.c busybox-1.17.1-sed/editors/sed.c
sed_cmd->in_match = !(
/* has the ending line come, or is this a single address command? */
(sed_cmd->end_line ?
-@@ -1270,9 +1277,6 @@ static void add_cmd_block(char *cmdstr)
+@@ -985,6 +992,8 @@ static void process_files(void)
+ }
+
+ /* actual sedding */
++ //bb_error_msg("pattern_space:'%s' next_line:'%s' cmd:%c",
++ //pattern_space, next_line, sed_cmd->cmd);
+ switch (sed_cmd->cmd) {
+
+ /* Print line number */
+@@ -1111,10 +1120,16 @@ static void process_files(void)
+ {
+ int len;
+ /* If no next line, jump to end of script and exit. */
++ /* http://www.gnu.org/software/sed/manual/sed.html:
++ * "Most versions of sed exit without printing anything
++ * when the N command is issued on the last line of
++ * a file. GNU sed prints pattern space before exiting
++ * unless of course the -n command switch has been
++ * specified. This choice is by design."
++ */
+ if (next_line == NULL) {
+- free(next_line);
+- next_line = NULL;
+- goto discard_line;
++ //goto discard_line;
++ goto discard_commands; /* GNU behavior */
+ }
+ /* Append next_line, read new next_line. */
+ len = strlen(pattern_space);
+@@ -1270,9 +1285,6 @@ static void add_cmd_block(char *cmdstr)
int sed_main(int argc, char **argv) MAIN_EXTERNALLY_VISIBLE;
int sed_main(int argc UNUSED_PARAM, char **argv)
{
@@ -35,7 +64,7 @@ diff -urpN busybox-1.17.1/editors/sed.c busybox-1.17.1-sed/editors/sed.c
unsigned opt;
llist_t *opt_e, *opt_f;
int status = EXIT_SUCCESS;
-@@ -1292,6 +1296,7 @@ int sed_main(int argc UNUSED_PARAM, char
+@@ -1292,6 +1304,7 @@ int sed_main(int argc UNUSED_PARAM, char
opt_e = opt_f = NULL;
opt_complementary = "e::f::" /* can occur multiple times */
"nn"; /* count -n */
@@ -45,8 +74,30 @@ diff -urpN busybox-1.17.1/editors/sed.c busybox-1.17.1-sed/editors/sed.c
//argc -= optind;
diff -urpN busybox-1.17.1/testsuite/sed.tests busybox-1.17.1-sed/testsuite/sed.tests
--- busybox-1.17.1/testsuite/sed.tests 2010-07-06 04:25:54.000000000 +0200
-+++ busybox-1.17.1-sed/testsuite/sed.tests 2010-08-01 04:19:26.000000000 +0200
-@@ -270,11 +270,16 @@ testing "sed a cmd ended by double backs
++++ busybox-1.17.1-sed/testsuite/sed.tests 2010-08-16 16:27:49.967074313 +0200
+@@ -80,10 +80,18 @@ test x"$SKIP_KNOWN_BUGS" = x"" && {
+ # Query: how does this interact with no newline at EOF?
+ testing "sed n (flushes pattern space, terminates early)" "sed -e 'n;p'" \
+ "a\nb\nb\nc\n" "" "a\nb\nc\n"
+-# N does _not_ flush pattern space, therefore c is still in there @ script end.
+-testing "sed N (doesn't flush pattern space when terminating)" "sed -e 'N;p'" \
+- "a\nb\na\nb\nc\n" "" "a\nb\nc\n"
+ }
++# non-GNU sed: N does _not_ flush pattern space, therefore c is eaten @ script end
++# GNU sed: N flushes pattern space, therefore c is printed too @ script end
++testing "sed N (flushes pattern space (GNU behavior))" "sed -e 'N;p'" \
++ "a\nb\na\nb\nc\n" "" "a\nb\nc\n"
++
++testing "sed N test2" "sed ':a;N;s/\n/ /;ta'" \
++ "a b c\n" "" "a\nb\nc\n"
++
++testing "sed N test3" "sed 'N;s/\n/ /'" \
++ "a b\nc\n" "" "a\nb\nc\n"
++
+ testing "sed address match newline" 'sed "/b/N;/b\\nc/i woo"' \
+ "a\nwoo\nb\nc\nd\n" "" "a\nb\nc\nd\n"
+
+@@ -270,11 +278,16 @@ testing "sed a cmd ended by double backs
| two \\
'