summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-07-14 23:05:55 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-07-14 23:05:55 +0000
commitc672320b019948d6d6f93979fc3df9a1c0b342e2 (patch)
tree890b91a8957cdbdc6f369279c9e1fa8914357b80 /sys-apps
parentadded kernel 2.6.26 patches, solving bug #231809. (diff)
downloadgentoo-2-c672320b019948d6d6f93979fc3df9a1c0b342e2.tar.gz
gentoo-2-c672320b019948d6d6f93979fc3df9a1c0b342e2.tar.bz2
gentoo-2-c672320b019948d6d6f93979fc3df9a1c0b342e2.zip
removed old revision.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r5 i686)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcfclock/ChangeLog6
-rw-r--r--sys-apps/pcfclock/files/pcfclock-0.44-udev.patch79
-rw-r--r--sys-apps/pcfclock/pcfclock-0.44-r2.ebuild53
3 files changed, 5 insertions, 133 deletions
diff --git a/sys-apps/pcfclock/ChangeLog b/sys-apps/pcfclock/ChangeLog
index 34382c98da3a..d01db752bf35 100644
--- a/sys-apps/pcfclock/ChangeLog
+++ b/sys-apps/pcfclock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/pcfclock
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/ChangeLog,v 1.8 2008/07/14 23:04:18 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/ChangeLog,v 1.9 2008/07/14 23:05:54 sbriesen Exp $
+
+ 14 Jul 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ -files/pcfclock-0.44-udev.patch, -pcfclock-0.44-r2.ebuild:
+ removed old revision.
*pcfclock-0.44-r4 (14 Jul 2008)
diff --git a/sys-apps/pcfclock/files/pcfclock-0.44-udev.patch b/sys-apps/pcfclock/files/pcfclock-0.44-udev.patch
deleted file mode 100644
index d7058cfe3cbc..000000000000
--- a/sys-apps/pcfclock/files/pcfclock-0.44-udev.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- linux/pcfclock.c.orig 2004-05-17 18:26:12.000000000 +0200
-+++ linux/pcfclock.c 2006-08-02 20:54:39.000000000 +0200
-@@ -56,6 +56,9 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
- #include <linux/device.h>
- #endif
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+#include <linux/moduleparam.h>
-+#endif
-
- #include <asm/uaccess.h>
- #include <asm/semaphore.h>
-@@ -93,6 +96,26 @@
-
- static struct pcfclock_struct pcfclock_table[PCFCLOCK_NO];
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+# define CLASS_CREATE(owner, name) class_create(owner, name)
-+# define CLASS_DESTROY(class) class_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_device_create(class, NULL, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_device_destroy(class, dev)
-+static struct class *pcfclock_class;
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,13)
-+# define CLASS_CREATE(owner, name) class_create(owner, name)
-+# define CLASS_DESTROY(class) class_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_device_create(class, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_device_destroy(class, dev)
-+static struct class *pcfclock_class;
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+# define CLASS_CREATE(owner, name) class_simple_create(owner, name)
-+# define CLASS_DESTROY(class) class_simple_destroy(class)
-+# define CLASS_DEVICE_CREATE(class, dev, device, fmt, rest) class_simple_device_add(class, dev, device, fmt, rest)
-+# define CLASS_DEVICE_DESTROY(class, dev) class_simple_device_remove(dev)
-+static struct class_simple *pcfclock_class;
-+#endif
-+
- /*
- * The radio clock transmits data only to the PC when requested. While the
- * time signal is received for the first time no communication between the PC
-@@ -401,7 +424,11 @@
- static int parport_nr[PCFCLOCK_NO] = {[0 ... PCFCLOCK_NO - 1] = PCFCLOCK_PARPORT_UNSPEC };
- static char *parport[PCFCLOCK_NO] = { NULL, };
-
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,17)
-+module_param_array(parport, charp, NULL, 0);
-+#else
- MODULE_PARM(parport, "1-" __MODULE_STRING(PCFCLOCK_NO) "s");
-+#endif
-
- #ifndef MODULE
- static int __init
-@@ -442,6 +469,7 @@
- return 1;
-
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
-+ CLASS_DEVICE_CREATE(pcfclock_class, MKDEV(PCFCLOCK_MAJOR, n), NULL, "pcfclock%d", n);
- devfs_mk_cdev(MKDEV(PCFCLOCK_MAJOR, n), S_IFCHR | S_IRUGO, "pcfclocks/%d", n);
- #else
- sprintf(name, "%d", n);
-@@ -509,6 +537,7 @@
- printk(KERN_ERR "pcfclock: unable to get major %d\n", PCFCLOCK_MAJOR);
- return -EIO;
- }
-+ pcfclock_class = CLASS_CREATE(THIS_MODULE, "pcfclock");
- devfs_mk_dir("pcfclocks");
- #else
- if (devfs_register_chrdev(PCFCLOCK_MAJOR, "pcfclock", &pcfclock_fops)) {
-@@ -563,9 +592,11 @@
- for (n = 0; n < PCFCLOCK_NO; n++) {
- if (pcfclock_table[n].dev != NULL) {
- parport_unregister_device(pcfclock_table[n].dev);
-+ CLASS_DEVICE_DESTROY(pcfclock_class, MKDEV(PCFCLOCK_MAJOR, n));
- devfs_remove("pcfclocks/%d", n);
- }
- }
-+ CLASS_DESTROY(pcfclock_class);
- devfs_remove("pcfclocks");
- #else
- devfs_unregister(devfs_handle);
diff --git a/sys-apps/pcfclock/pcfclock-0.44-r2.ebuild b/sys-apps/pcfclock/pcfclock-0.44-r2.ebuild
deleted file mode 100644
index 9682d0358f26..000000000000
--- a/sys-apps/pcfclock/pcfclock-0.44-r2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcfclock/pcfclock-0.44-r2.ebuild,v 1.1 2006/08/02 19:10:26 sbriesen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="driver for the parallel port radio clock sold by Conrad Electronic"
-HOMEPAGE="http://www-stud.ims.uni-stuttgart.de/~voegelas/pcf.html"
-SRC_URI="http://www-stud.ims.uni-stuttgart.de/~voegelas/pcfclock/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc"
-IUSE=""
-
-DEPEND="virtual/linux-sources"
-
-pkg_setup() {
- CONFIG_CHECK="PARPORT"
- linux-mod_pkg_setup
- BUILD_TARGETS="all"
- ECONF_PARAMS="--with-linux=${KERNEL_DIR}"
- MODULE_NAMES="pcfclock(::${S}/linux)"
- MODULESD_PCFCLOCK_ENABLED="yes"
- MODULESD_PCFCLOCK_EXAMPLES=( "pcfclock parport=0,none,none" )
- MODULESD_PCFCLOCK_ALIASES=(
- "char-major-181 pcfclock"
- "/dev/pcfclock0 char-major-181"
- "/dev/pcfclock1 char-major-181"
- "/dev/pcfclock2 char-major-181"
- )
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-udev.patch"
- convert_to_m "linux/Makefile.in"
-}
-
-src_install() {
- linux-mod_src_install
- dosbin pcfdate/pcfdate
- doman {linux,pcfdate}/*.[48]
- dodoc AUTHORS ChangeLog NEWS README THANKS
-
- # Add configuration for udev
- if [ -e ${ROOT}dev/.udev ]; then
- dodir /etc/udev/rules.d
- echo 'KERNEL=="pcfclock*", NAME="%k", MODE="0444"' \
- > "${D}/etc/udev/rules.d/55-${PN}.rules"
- fi
-}