summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-27 20:07:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-27 20:07:36 +0000
commitc3c7583baed45c7311790e669762b4668973e2d1 (patch)
tree1613c0afe0913a8a75c09cc2a0e5ea64ff7408a9 /sys-apps
parentadd new version (diff)
downloadgentoo-2-c3c7583baed45c7311790e669762b4668973e2d1.tar.gz
gentoo-2-c3c7583baed45c7311790e669762b4668973e2d1.tar.bz2
gentoo-2-c3c7583baed45c7311790e669762b4668973e2d1.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/usb_modeswitch/ChangeLog10
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-2.1.0_p20140129.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/sys-apps/usb_modeswitch/ChangeLog b/sys-apps/usb_modeswitch/ChangeLog
index fdd13b28c40d..f2cd7788214a 100644
--- a/sys-apps/usb_modeswitch/ChangeLog
+++ b/sys-apps/usb_modeswitch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/usb_modeswitch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.50 2013/09/10 06:36:35 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.51 2014/02/27 20:07:36 ssuominen Exp $
+
+*usb_modeswitch-2.1.0_p20140129 (27 Feb 2014)
+
+ 27 Feb 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +usb_modeswitch-2.1.0_p20140129.ebuild:
+ Version bump.
*usb_modeswitch-2.0.1_p20130807 (10 Sep 2013)
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-2.1.0_p20140129.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-2.1.0_p20140129.ebuild
new file mode 100644
index 000000000000..93032df70826
--- /dev/null
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-2.1.0_p20140129.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-2.1.0_p20140129.ebuild,v 1.1 2014/02/27 20:07:36 ssuominen Exp $
+
+EAPI=5
+inherit eutils linux-info toolchain-funcs udev systemd
+
+MY_PN=${PN/_/-}
+MY_P=${MY_PN}-${PV/_p*}
+DATA_VER=${PV/*_p}
+
+DESCRIPTION="USB_ModeSwitch is a tool for controlling 'flip flop' (multiple devices) USB gear like UMTS sticks"
+HOMEPAGE="http://www.draisberghof.de/usb_modeswitch/ http://www.draisberghof.de/usb_modeswitch/device_reference.txt"
+SRC_URI="http://www.draisberghof.de/${PN}/${MY_P}.tar.bz2
+ http://www.draisberghof.de/${PN}/${MY_PN}-data-${DATA_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="jimtcl"
+
+COMMON_DEPEND="virtual/udev
+ virtual/libusb:1"
+RDEPEND="${COMMON_DEPEND}
+ jimtcl? ( dev-lang/jimtcl )
+ !jimtcl? ( dev-lang/tcl )" # usb_modeswitch script is tcl
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="~USB_SERIAL"
+
+src_prepare() {
+ sed -i -e '/install.*BIN/s:-s::' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ SYSDIR="${D}/$(systemd_get_unitdir)" \
+ UDEVDIR="${D}/$(get_udevdir)" \
+ $(usex jimtcl install-shared install)
+
+ # Even if we set SYSDIR above, the Makefile is causing automagic detection of `systemctl` binary,
+ # which is why we need to force the .service file to be installed:
+ systemd_dounit ${PN}@.service
+
+ dodoc ChangeLog README
+
+ pushd ../${MY_PN}-data-${DATA_VER} >/dev/null
+ emake \
+ DESTDIR="${D}" \
+ RULESDIR="${D}/$(get_udevdir)/rules.d" \
+ files-install db-install
+ docinto data
+ dodoc ChangeLog README
+ popd >/dev/null
+}