summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2010-08-14 18:41:41 +0000
committerAnthony G. Basile <blueness@gentoo.org>2010-08-14 18:41:41 +0000
commit8c3ab4467ead1467d72513d8c7c8b6ee24ba5d5e (patch)
treef9bfd3daf88c03bd809cd98fc271a139e09a3550 /sys-apps
parentalpha/ia64/sh/sparc stable wrt #314899 (diff)
downloadgentoo-2-8c3ab4467ead1467d72513d8c7c8b6ee24ba5d5e.tar.gz
gentoo-2-8c3ab4467ead1467d72513d8c7c8b6ee24ba5d5e.tar.bz2
gentoo-2-8c3ab4467ead1467d72513d8c7c8b6ee24ba5d5e.zip
Version bump and fix bug #332471.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gradm/ChangeLog8
-rw-r--r--sys-apps/gradm/files/gradm-2.2.0.201008112235.patch30
-rw-r--r--sys-apps/gradm/gradm-2.2.0.201008112235.ebuild57
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-apps/gradm/ChangeLog b/sys-apps/gradm/ChangeLog
index 59f2f3db2686..f7b94c1b7a0e 100644
--- a/sys-apps/gradm/ChangeLog
+++ b/sys-apps/gradm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/gradm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/ChangeLog,v 1.125 2010/08/12 09:24:15 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/ChangeLog,v 1.126 2010/08/14 18:41:40 blueness Exp $
+
+*gradm-2.2.0.201008112235 (14 Aug 2010)
+
+ 14 Aug 2010; Anthony G. Basile <blueness@gentoo.org>
+ +gradm-2.2.0.201008112235.ebuild, +files/gradm-2.2.0.201008112235.patch:
+ Version bump and fix bug #332471.
12 Aug 2010; Markus Meier <maekke@gentoo.org>
gradm-2.1.14.201005041005.ebuild:
diff --git a/sys-apps/gradm/files/gradm-2.2.0.201008112235.patch b/sys-apps/gradm/files/gradm-2.2.0.201008112235.patch
new file mode 100644
index 000000000000..b8d892816582
--- /dev/null
+++ b/sys-apps/gradm/files/gradm-2.2.0.201008112235.patch
@@ -0,0 +1,30 @@
+--- Makefile.orig 2010-08-13 21:39:07.000000000 -0400
++++ Makefile 2010-08-13 21:40:54.000000000 -0400
+@@ -18,16 +18,16 @@
+ BISON=/usr/bin/bison
+ #YACC := $(shell if [ -x $(BYACC) ]; then echo $(BYACC); else echo $(BISON); fi)
+ YACC=$(BISON)
+-MKNOD=/bin/mknod
++MKNOD=true
+ #for dietlibc
+ #CC=/usr/bin/diet /usr/bin/gcc
+ CC=/usr/bin/gcc
+ FIND=/usr/bin/find
+-STRIP=/usr/bin/strip
++STRIP=true
+ LIBS := $(shell if [ "`uname -m`" != "sparc64" ]; then echo "-lfl" ; else echo "" ; fi)
+ OPT_FLAGS := $(shell if [ "`uname -m`" != "sparc64" ] && [ "`uname -m`" != "x86_64" ]; then echo "-O2" ; else echo "-O2 -m64" ; fi)
+ CFLAGS := $(OPT_FLAGS) -DGRSEC_DIR=\"$(GRSEC_DIR)\" -D_LARGEFILE64_SOURCE
+-LDFLAGS=
++LDFLAGS+=
+ INSTALL = /usr/bin/install -c
+
+ # FHS
+@@ -134,6 +134,7 @@
+ $(MKNOD) -m 0622 $(DESTDIR)/dev/grsec c 1 13 ; \
+ fi \
+ fi
++ @mkdir -p $(DESTDIR)/etc/udev/rules.d
+ @if [ -d $(DESTDIR)/etc/udev/rules.d ] ; then \
+ echo "ACTION!=\"add|change\", GOTO=\"permissions_end\"" > $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
+ echo "KERNEL==\"grsec\", MODE=\"0622\"" >> $(DESTDIR)/etc/udev/rules.d/80-grsec.rules ; \
diff --git a/sys-apps/gradm/gradm-2.2.0.201008112235.ebuild b/sys-apps/gradm/gradm-2.2.0.201008112235.ebuild
new file mode 100644
index 000000000000..2cbd6b9d4ca4
--- /dev/null
+++ b/sys-apps/gradm/gradm-2.2.0.201008112235.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gradm/gradm-2.2.0.201008112235.ebuild,v 1.1 2010/08/14 18:41:40 blueness Exp $
+
+EAPI=2
+
+inherit flag-o-matic toolchain-funcs versionator
+
+MY_PV="$(replace_version_separator 3 -)"
+
+DESCRIPTION="Administrative interface for the grsecurity Role Based Access Control system"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ pam? ( virtual/pam )
+ || ( sys-apps/paxctl sys-apps/chpax )"
+
+S="${WORKDIR}/${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.patch"
+
+ append-ldflags -Wl,-z,now
+}
+
+src_compile() {
+ local target
+ use pam || target="nopam"
+
+ emake ${target} CC="$(tc-getCC)" OPT_FLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR="${D}" || die "einstall failed"
+ fperms 711 /sbin/gradm
+}
+
+pkg_postinst() {
+ local UDEVADM="/sbin/udevadm"
+ if [[ -x ${UDEVADM} ]] ; then
+ $UDEVADM trigger --action=add --sysname-match=grsec
+ fi
+ einfo
+ ewarn
+ ewarn "Be sure to set a password with 'gradm -P' before enabling learning mode"
+ ewarn "This version of gradm is only supported with hardened-sources >= 2.6.32-r10"
+ ewarn
+ einfo
+}