summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 09:17:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 09:17:22 +0000
commit6d1199c71ec18c40d90940307139850a3117fd9c (patch)
tree0ccc592a60b69d97557b4f23fa7f8ddf2ad80427 /sys-apps
parentrepoman fix (diff)
downloadgentoo-2-6d1199c71ec18c40d90940307139850a3117fd9c.tar.gz
gentoo-2-6d1199c71ec18c40d90940307139850a3117fd9c.tar.bz2
gentoo-2-6d1199c71ec18c40d90940307139850a3117fd9c.zip
sed expression fixes
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/procps/ChangeLog11
-rw-r--r--sys-apps/procps/procps-2.0.10-r1.ebuild39
-rw-r--r--sys-apps/procps/procps-2.0.11.ebuild36
-rw-r--r--sys-apps/procps/procps-3.1.5.ebuild19
4 files changed, 71 insertions, 34 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index 3a6a74173766..fa426d6a4d0f 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for sys-apps/procps
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.19 2003/02/09 02:16:56 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.20 2003/02/10 09:17:22 seemant Exp $
+
+*procps-3.1.5 (21 Dec 2002)
+
+ 09 Feb 2003; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
+
+ Changed sed expression delimiters to : where applicable, closing bug
+ #15006 by Blu3 <david+gentoo.org@blue-labs.org>
09 Feb 2003; Guy Martin <gmsoft@gentoo.org> :
Added hppa to keywords.
-*procps-3.1.5 (21 Dec 2002)
-
21 Dec 2002; Brandon Low <lostlogic@gentoo.org> procps-3.1.5.ebuild :
Upstream bump...
diff --git a/sys-apps/procps/procps-2.0.10-r1.ebuild b/sys-apps/procps/procps-2.0.10-r1.ebuild
index a0893eff91e2..7c4793d1e7ed 100644
--- a/sys-apps/procps/procps-2.0.10-r1.ebuild
+++ b/sys-apps/procps/procps-2.0.10-r1.ebuild
@@ -1,16 +1,22 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.10-r1.ebuild,v 1.9 2003/02/09 02:16:56 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.10-r1.ebuild,v 1.10 2003/02/10 09:17:22 seemant Exp $
+
+IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="Standard informational utilities and process-handling tools"
SRC_URI="http://surriel.com/${PN}/${P}.tar.bz2"
HOMEPAGE="http://surriel.com/procps/"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND} >=sys-devel/gettext-0.10.35"
+
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha mips hppa"
-SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35"
src_unpack() {
unpack ${A}
@@ -20,18 +26,29 @@ src_unpack() {
# Use the CFLAGS from /etc/make.conf.
# remove /etc/X11/applnk/Desktop/top.app from makefile
mv Makefile Makefile.orig
- sed -e "s/-O3/${CFLAGS}/" -e 's/all: config/all: /' \
- -e "s:--strip::" -e 's/$.DESKTOP.//' Makefile.orig > Makefile
+ sed \
+ -e "s:-O3:${CFLAGS}:" \
+ -e 's|all: config|all: |' \
+ -e "s:--strip::" \
+ -e 's:$.DESKTOP.::' \
+ Makefile.orig > Makefile
- # WARNING! In case of a version bump, check the line below that removes a line from the Makefile file.
+ # WARNING! In case of a version bump, check the line below that
+ # removes a line from the Makefile file.
cd ${S}/ps
mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" -e "s:/var/.*man/:${D}var/.*man/:" -e "s:-lproc:-lproc -L${D}lib:" \
+ sed \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:/var/.*man/:${D}var/.*man/:" \
+ -e "s:-lproc:-lproc -L${D}lib:" \
Makefile.orig > Makefile
cd ${S}/proc
mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+ sed \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:--strip::" \
+ Makefile.orig > Makefile
}
src_compile() {
@@ -65,4 +82,4 @@ pkg_postinst() {
einfo "NOTE: By default \"ps\" and \"top\" no longer"
einfo "show threads. You can use the '-m' flag"
einfo "in ps or the 'H' key in top to show them"
-}
+}
diff --git a/sys-apps/procps/procps-2.0.11.ebuild b/sys-apps/procps/procps-2.0.11.ebuild
index 40b7d4c8ee75..409a2cdb096a 100644
--- a/sys-apps/procps/procps-2.0.11.ebuild
+++ b/sys-apps/procps/procps-2.0.11.ebuild
@@ -1,16 +1,19 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.11.ebuild,v 1.2 2003/02/09 02:16:56 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.11.ebuild,v 1.3 2003/02/10 09:17:22 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Standard informational utilities and process-handling tools"
SRC_URI="http://surriel.com/${PN}/${P}.tar.bz2"
HOMEPAGE="http://surriel.com/procps/"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND} >=sys-devel/gettext-0.10.35"
+
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
-SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35"
src_unpack() {
unpack ${A}
@@ -20,18 +23,29 @@ src_unpack() {
# Use the CFLAGS from /etc/make.conf.
# remove /etc/X11/applnk/Desktop/top.app from makefile
mv Makefile Makefile.orig
- sed -e "s/-O3/${CFLAGS}/" -e 's/all: config/all: /' \
- -e "s:--strip::" -e 's/$.DESKTOP.//' Makefile.orig > Makefile
+ sed \
+ -e "s:-O3:${CFLAGS}:" \
+ -e 's/all: config/all: /' \
+ -e "s:--strip::" \
+ -e 's:$.DESKTOP.::' \
+ Makefile.orig > Makefile
- # WARNING! In case of a version bump, check the line below that removes a line from the Makefile file.
+ # WARNING! In case of a version bump, check the line below that
+ # removes a line from the Makefile file.
cd ${S}/ps
mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" -e "s:/var/.*man/:${D}var/.*man/:" -e "s:-lproc:-lproc -L${D}lib:" \
+ sed \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:/var/.*man/:${D}var/.*man/:" \
+ -e "s:-lproc:-lproc -L${D}lib:" \
Makefile.orig > Makefile
cd ${S}/proc
mv Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+ sed \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:--strip::" \
+ Makefile.orig > Makefile
}
src_compile() {
@@ -65,4 +79,4 @@ pkg_postinst() {
einfo "NOTE: By default \"ps\" and \"top\" no longer"
einfo "show threads. You can use the '-m' flag"
einfo "in ps or the 'H' key in top to show them"
-}
+}
diff --git a/sys-apps/procps/procps-3.1.5.ebuild b/sys-apps/procps/procps-3.1.5.ebuild
index 6870551b61c7..636f12aeccd4 100644
--- a/sys-apps/procps/procps-3.1.5.ebuild
+++ b/sys-apps/procps/procps-3.1.5.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.1.5.ebuild,v 1.2 2003/02/09 02:16:56 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-3.1.5.ebuild,v 1.3 2003/02/10 09:17:22 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Standard informational utilities and process-handling tools -ps top tload snice vmstat free w watch uptime pmap skill pkill kill pgrep sysctl"
SRC_URI="http://${PN}.sf.net/${P}.tar.gz"
HOMEPAGE="http://procps.sourceforge.net/"
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND} >=sys-devel/gettext-0.10.35"
-
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
-SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10.35"
src_unpack() {
unpack ${A}
@@ -21,12 +22,12 @@ src_unpack() {
# Use the CFLAGS from /etc/make.conf.
for file in `find . -iname "Makefile"`;do
mv ${file} ${file}.orig
- sed -e "s/-O2/${CFLAGS}/" ${file}.orig > ${file}
+ sed -e "s:-O2:${CFLAGS}:" ${file}.orig > ${file}
done
}
src_compile() {
- emake
+ emake || die
}
src_install() {
@@ -43,4 +44,4 @@ pkg_postinst() {
einfo "NOTE: By default \"ps\" and \"top\" no longer"
einfo "show threads. You can use the '-m' flag"
einfo "in ps or the 'H' key in top to show them"
-}
+}