summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-05-14 07:37:24 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-05-14 07:37:24 +0000
commit58d303dd31ae4ce7f50f60a4ce9985a3349051f1 (patch)
tree0c9a251809148b44b84e7ebf3e678e4251ddefd2 /sys-apps
parentTime to say goodbye... (diff)
downloadgentoo-2-58d303dd31ae4ce7f50f60a4ce9985a3349051f1.tar.gz
gentoo-2-58d303dd31ae4ce7f50f60a4ce9985a3349051f1.tar.bz2
gentoo-2-58d303dd31ae4ce7f50f60a4ce9985a3349051f1.zip
Fix compiling with linux-headers-2.6.21, Bug #178474.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/fxload/ChangeLog6
-rw-r--r--sys-apps/fxload/files/fxload-20020411-linux-headers-2.6.21.patch12
-rw-r--r--sys-apps/fxload/fxload-20020411.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/sys-apps/fxload/ChangeLog b/sys-apps/fxload/ChangeLog
index 2742b45063f2..90f53a89ad74 100644
--- a/sys-apps/fxload/ChangeLog
+++ b/sys-apps/fxload/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/fxload
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/ChangeLog,v 1.14 2007/05/01 09:41:54 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/ChangeLog,v 1.15 2007/05/14 07:37:24 zzam Exp $
+
+ 14 May 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/fxload-20020411-linux-headers-2.6.21.patch, fxload-20020411.ebuild:
+ Fix compiling with linux-headers-2.6.21, Bug #178474.
01 May 2007; Markus Rothe <corsair@gentoo.org> fxload-20020411.ebuild:
Stable on ppc64; bug #175141
diff --git a/sys-apps/fxload/files/fxload-20020411-linux-headers-2.6.21.patch b/sys-apps/fxload/files/fxload-20020411-linux-headers-2.6.21.patch
new file mode 100644
index 000000000000..e608b9d73caa
--- /dev/null
+++ b/sys-apps/fxload/files/fxload-20020411-linux-headers-2.6.21.patch
@@ -0,0 +1,12 @@
+diff -ru fxload-2002_04_11-orig/ezusb.c fxload-2002_04_11/ezusb.c
+--- fxload-2002_04_11-orig/ezusb.c 2007-05-14 09:27:19.000000000 +0200
++++ fxload-2002_04_11/ezusb.c 2007-05-14 09:30:24.000000000 +0200
+@@ -29,7 +29,7 @@
+ # include <sys/ioctl.h>
+
+ # include <linux/version.h>
+-# include <linux/usb.h>
++# include <linux/usb/ch9.h>
+ # include <linux/usbdevice_fs.h>
+
+ # include "ezusb.h"
diff --git a/sys-apps/fxload/fxload-20020411.ebuild b/sys-apps/fxload/fxload-20020411.ebuild
index b3c9363b6b95..7df7c30d5764 100644
--- a/sys-apps/fxload/fxload-20020411.ebuild
+++ b/sys-apps/fxload/fxload-20020411.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/fxload-20020411.ebuild,v 1.19 2007/05/01 09:41:54 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fxload/fxload-20020411.ebuild,v 1.20 2007/05/14 07:37:24 zzam Exp $
inherit eutils
@@ -24,7 +24,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- if has_version ">=sys-kernel/linux-headers-2.6.19"; then
+ if has_version ">=sys-kernel/linux-headers-2.6.21"; then
+ epatch ${FILESDIR}/${P}-linux-headers-2.6.21.patch
+ elif has_version ">=sys-kernel/linux-headers-2.6.19"; then
epatch ${FILESDIR}/${P}-linux-headers-2.6.19.patch
fi
}