summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-01 17:17:48 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-01 17:17:48 +0000
commitbc85fe308265f7cd66371991dd48bff9b9ce2693 (patch)
treebf7bc8944b978b40bb016cf6d63ee9e9085bd692 /sys-apps/xinetd
parentAdded XML-Parser to dependencies (diff)
downloadgentoo-2-bc85fe308265f7cd66371991dd48bff9b9ce2693.tar.gz
gentoo-2-bc85fe308265f7cd66371991dd48bff9b9ce2693.tar.bz2
gentoo-2-bc85fe308265f7cd66371991dd48bff9b9ce2693.zip
New stable release
A fix for a potential buffer overflow in the string handling library.
Diffstat (limited to 'sys-apps/xinetd')
-rw-r--r--sys-apps/xinetd/files/digest-xinetd-2.3.01
-rwxr-xr-xsys-apps/xinetd/files/xinetd-run-2.3.028
-rw-r--r--sys-apps/xinetd/xinetd-2.3.0.ebuild46
3 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/xinetd/files/digest-xinetd-2.3.0 b/sys-apps/xinetd/files/digest-xinetd-2.3.0
new file mode 100644
index 000000000000..0204640db050
--- /dev/null
+++ b/sys-apps/xinetd/files/digest-xinetd-2.3.0
@@ -0,0 +1 @@
+MD5 f9e4363a0838ae3e5065b1c0c2b307a8 xinetd-2.3.0.tar.gz
diff --git a/sys-apps/xinetd/files/xinetd-run-2.3.0 b/sys-apps/xinetd/files/xinetd-run-2.3.0
new file mode 100755
index 000000000000..26fcefcbf0f1
--- /dev/null
+++ b/sys-apps/xinetd/files/xinetd-run-2.3.0
@@ -0,0 +1,28 @@
+#!/bin/sh
+#remove stale pid files
+if [ -e /var/run/xinetd.pid ]
+then
+ mypids="`cat /var/run/xinetd.pid`"
+ myrun=`/sbin/pidof xinetd`
+ ok=0
+ for x in $mypids
+ do
+ if [ "$myrun" = "$x" ]
+ then
+ #this is a running xinetd process, pidfile ok
+ ok=1
+ fi
+ done
+ if [ "$ok" = "0" ]
+ then
+ #bogus pidfile, remove
+ rm /var/run/xinetd.pid
+ fi
+fi
+if [ ! -e /var/run/xinetd.pid ]
+then
+ /usr/sbin/xinetd -pidfile /var/run/xinetd.pid
+ /usr/bin/sleep 1
+fi
+exec /usr/bin/watchpid `cat /var/run/xinetd.pid`
+
diff --git a/sys-apps/xinetd/xinetd-2.3.0.ebuild b/sys-apps/xinetd/xinetd-2.3.0.ebuild
new file mode 100644
index 000000000000..1070ac5af2e5
--- /dev/null
+++ b/sys-apps/xinetd/xinetd-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.3.0.ebuild,v 1.1 2001/07/01 17:17:48 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Replacement for inetd."
+HOMEPAGE="http://www.xinetd.org"
+SRC_URI="http://www.xinetd.org/${A}"
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )"
+
+RDEPEND="virtual/glibc
+ sys-devel/perl"
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcpd`" ]
+ then
+ myconf="--with-libwrap"
+ fi
+ try ./configure --with-loadavg --with-inet6 --prefix=/usr --mandir=/usr/share/man --host=${CHOST} $myconf
+ # Parallel make does not work
+ try make
+
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr MANDIR=${D}/usr/share/man install
+ dodoc CHANGELOG README COPYRIGHT
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/xinetd ${FILESDIR}/svc-xinetd
+ insinto /etc
+ #doins ${FILESDIR}/xinetd.conf
+ exeinto /var/lib/supervise/services/xinetd
+ newexe ${FILESDIR}/xinetd-run-${PV} run
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/xconv.pl
+}
+
+
+
+