summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-24 05:26:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-24 05:26:29 +0000
commit793e48b940df1f66a7d8c5a5894504aaf2ab1f92 (patch)
tree3090b2dfe68024cf3ba7fae3c8eed923bab35f76 /sys-apps/xinetd
parentupdated to handle the new inet.security file (diff)
downloadgentoo-2-793e48b940df1f66a7d8c5a5894504aaf2ab1f92.tar.gz
gentoo-2-793e48b940df1f66a7d8c5a5894504aaf2ab1f92.tar.bz2
gentoo-2-793e48b940df1f66a7d8c5a5894504aaf2ab1f92.zip
conversion from /etc/svc.d to /etc/supervise and /var/supervise
Diffstat (limited to 'sys-apps/xinetd')
-rwxr-xr-xsys-apps/xinetd/files/xinetd4
-rw-r--r--sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild8
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/xinetd/files/xinetd b/sys-apps/xinetd/files/xinetd
index b3069bc91c42..999655f810e1 100755
--- a/sys-apps/xinetd/files/xinetd
+++ b/sys-apps/xinetd/files/xinetd
@@ -43,13 +43,13 @@ supervise_start() {
prepconfig
ebegin "Starting ${SERVICE} supervised"
- /usr/bin/svc -u /etc/svc.d/control/xinetd
+ /usr/bin/svc -u /etc/supervise/xinetd
eend $? "Error starting ${SERVICE} supervised."
}
supervise_stop() {
ebegin "Stopping ${SERVICE} supervised"
- /usr/bin/svc -d /etc/svc.d/control/xinetd
+ /usr/bin/svc -d /etc/supervise/xinetd
eend $? "Error stopping ${SERVICE}. supervised"
}
diff --git a/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild b/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild
index 32465272c36d..300f1be6efc1 100644
--- a/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild
+++ b/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild,v 1.1 2000/12/23 00:29:43 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xinetd/xinetd-2.1.8.8_p3-r3.ebuild,v 1.2 2000/12/24 05:26:26 drobbins Exp $
P=xinetd-2.1.8.8p3
A=${P}.tar.gz
@@ -29,10 +29,10 @@ src_install() {
doexe ${FILESDIR}/xinetd
insinto /etc
# doins ${FILESDIR}/xinetd.conf
- dodir /etc/svc.d/control
- exeinto /etc/svc.d/services/xinetd
+ dodir /etc/supervise
+ exeinto /var/supervise/xinetd
newexe ${FILESDIR}/xinetd-run run
- ln -s ../services/xinetd ${D}/etc/svc.d/control/xinetd
+ ln -s /var/supervise/xinetd /etc/supervise/xinetd
}