summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-26 00:58:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-26 00:58:20 +0000
commit479054aaa3e79368e8f12581bc8d22a6dd001631 (patch)
tree97366e819d25b1ccae29bf4fa27dbad110ff6028 /sys-apps/vbetool
parentBump to 2.24.0 (diff)
downloadgentoo-2-479054aaa3e79368e8f12581bc8d22a6dd001631.tar.gz
gentoo-2-479054aaa3e79368e8f12581bc8d22a6dd001631.tar.bz2
gentoo-2-479054aaa3e79368e8f12581bc8d22a6dd001631.zip
Fix build with --as-needed.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'sys-apps/vbetool')
-rw-r--r--sys-apps/vbetool/ChangeLog6
-rw-r--r--sys-apps/vbetool/files/vbetool-1.0-build.patch18
-rw-r--r--sys-apps/vbetool/vbetool-1.0.ebuild9
3 files changed, 27 insertions, 6 deletions
diff --git a/sys-apps/vbetool/ChangeLog b/sys-apps/vbetool/ChangeLog
index 306d23ee8d58..b94d29c4b27f 100644
--- a/sys-apps/vbetool/ChangeLog
+++ b/sys-apps/vbetool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/vbetool
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.13 2008/08/07 21:55:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/ChangeLog,v 1.14 2008/11/26 00:58:20 flameeyes Exp $
+
+ 26 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/vbetool-1.0-build.patch, vbetool-1.0.ebuild:
+ Fix build with --as-needed.
07 Aug 2008; Markus Meier <maekke@gentoo.org> vbetool-1.0.ebuild:
amd64/x86 stable, bug #231739
diff --git a/sys-apps/vbetool/files/vbetool-1.0-build.patch b/sys-apps/vbetool/files/vbetool-1.0-build.patch
new file mode 100644
index 000000000000..69d2f7b341ba
--- /dev/null
+++ b/sys-apps/vbetool/files/vbetool-1.0-build.patch
@@ -0,0 +1,18 @@
+Index: vbetool-1.0/Makefile.am
+===================================================================
+--- vbetool-1.0.orig/Makefile.am
++++ vbetool-1.0/Makefile.am
+@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = foreign
+
+ sbin_PROGRAMS = vbetool
+
+-vbetool_LDADD = $(libdir)/libpci.a
++vbetool_LDADD = -lpci -lz -lx86
+
+ man_MANS = vbetool.1
+ vbetool_SOURCES = vbetool.c $(x86)
+@@ -14,4 +14,3 @@ maintainer-clean-local:
+ $(RM) Makefile.in aclocal.m4 config.h.in stamp-h.in configure
+
+ AM_CFLAGS = -g -Wall -pedantic -std=gnu99
+-AM_LDFLAGS = -lz -lx86
diff --git a/sys-apps/vbetool/vbetool-1.0.ebuild b/sys-apps/vbetool/vbetool-1.0.ebuild
index 3af6e1e42fe6..8f44e95c497a 100644
--- a/sys-apps/vbetool/vbetool-1.0.ebuild
+++ b/sys-apps/vbetool/vbetool-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-1.0.ebuild,v 1.3 2008/08/07 21:55:48 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vbetool/vbetool-1.0.ebuild,v 1.4 2008/11/26 00:58:20 flameeyes Exp $
inherit eutils flag-o-matic autotools
@@ -21,11 +21,10 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- #epatch ${FILESDIR}/${P}-pci-compile-fix.patch
- sed -i \
- -e '/vbetool_LDADD/s,$(libdir)/libpci.a,-lpci,' \
- "${S}/Makefile.am"
cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-build.patch
+
eautoreconf
}