summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-07-15 20:42:00 +0000
committerMichael Januszewski <spock@gentoo.org>2008-07-15 20:42:00 +0000
commit29c2ff3b8e490884fc21d4403b10f4c5ad0bab8a (patch)
tree3a8a2772d82f1f6e83edb17a1817925b9e5dd52c /sys-apps/v86d
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-29c2ff3b8e490884fc21d4403b10f4c5ad0bab8a.tar.gz
gentoo-2-29c2ff3b8e490884fc21d4403b10f4c5ad0bab8a.tar.bz2
gentoo-2-29c2ff3b8e490884fc21d4403b10f4c5ad0bab8a.zip
Fix compilation with -x86emu and klibc-1.5.12 (bug #231839).
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc9 x86_64)
Diffstat (limited to 'sys-apps/v86d')
-rw-r--r--sys-apps/v86d/ChangeLog7
-rw-r--r--sys-apps/v86d/v86d-0.1.5.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 454bde329a1d..03aa45471d9a 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.15 2008/05/31 12:37:21 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.16 2008/07/15 20:42:00 spock Exp $
+
+*v86d-0.1.5.1 (15 Jul 2008)
+
+ 15 Jul 2008; Michał Januszewski <spock@gentoo.org> +v86d-0.1.5.1.ebuild:
+ Fix compilation with -x86emu and klibc-1.5.12 (bug #231839).
31 May 2008; Michał Januszewski <spock@gentoo.org> v86d-0.1.5.ebuild:
Fix bug #224243.
diff --git a/sys-apps/v86d/v86d-0.1.5.1.ebuild b/sys-apps/v86d/v86d-0.1.5.1.ebuild
new file mode 100644
index 000000000000..15459f8df5d2
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.5.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.5.1.ebuild,v 1.1 2008/07/15 20:42:00 spock Exp $
+
+inherit linux-info multilib
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ local myconf=""
+ if use x86emu ; then
+ myconf="--with-x86emu"
+ fi
+
+ ./configure --with-klibc $(use_with debug) ${myconf}
+ make KDIR=${KV_DIR} || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}