summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-03-13 21:19:39 +0000
committerRoy Marples <uberlord@gentoo.org>2007-03-13 21:19:39 +0000
commitd1639e50d2ae8e9ec0ae825527d7c2c48205edb9 (patch)
tree6491dbb667b82e8400174840e5f841b061b2f80d /sys-apps/sysvinit
parentVersion bump (diff)
downloadgentoo-2-d1639e50d2ae8e9ec0ae825527d7c2c48205edb9.tar.gz
gentoo-2-d1639e50d2ae8e9ec0ae825527d7c2c48205edb9.tar.bz2
gentoo-2-d1639e50d2ae8e9ec0ae825527d7c2c48205edb9.zip
Bump for non bash scripts.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/ChangeLog8
-rw-r--r--sys-apps/sysvinit/files/digest-sysvinit-2.86-r86
-rwxr-xr-xsys-apps/sysvinit/files/reboot.sh6
-rwxr-xr-xsys-apps/sysvinit/files/shutdown.sh6
-rw-r--r--sys-apps/sysvinit/sysvinit-2.86-r8.ebuild96
5 files changed, 115 insertions, 7 deletions
diff --git a/sys-apps/sysvinit/ChangeLog b/sys-apps/sysvinit/ChangeLog
index 946cdfa0ea5f..7e97b7f1f09a 100644
--- a/sys-apps/sysvinit/ChangeLog
+++ b/sys-apps/sysvinit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sysvinit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.46 2007/03/13 14:12:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.47 2007/03/13 21:19:39 uberlord Exp $
+
+*sysvinit-2.86-r8 (13 Mar 2007)
+
+ 13 Mar 2007; Roy Marples <uberlord@gentoo.org> files/reboot.sh,
+ files/shutdown.sh, +sysvinit-2.86-r8.ebuild:
+ Bump for non bash scripts.
13 Mar 2007; Raúl Porcel <armin76@gentoo.org> sysvinit-2.86-r7.ebuild:
x86 stable
diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.86-r8 b/sys-apps/sysvinit/files/digest-sysvinit-2.86-r8
new file mode 100644
index 000000000000..7fc9a567296b
--- /dev/null
+++ b/sys-apps/sysvinit/files/digest-sysvinit-2.86-r8
@@ -0,0 +1,6 @@
+MD5 650af823f937d386e81520b1741d4d45 sysvinit-2.86-kexec.patch 4139
+RMD160 5f8e9ccd3a39701cf47a1a541c78a4be971d46fc sysvinit-2.86-kexec.patch 4139
+SHA256 936245ef3060939bec3099efc006009336b3672422c1de41983b277ab5ddac47 sysvinit-2.86-kexec.patch 4139
+MD5 7d5d61c026122ab791ac04c8a84db967 sysvinit-2.86.tar.gz 99009
+RMD160 46587ab51390b5c8cd3179a3690f86efdbe9b4b9 sysvinit-2.86.tar.gz 99009
+SHA256 035f98fae17d9cff002993c564ccc83dc4ed136127172caeff872b6abdb679d8 sysvinit-2.86.tar.gz 99009
diff --git a/sys-apps/sysvinit/files/reboot.sh b/sys-apps/sysvinit/files/reboot.sh
index aeade86dfab9..4557adc971fa 100755
--- a/sys-apps/sysvinit/files/reboot.sh
+++ b/sys-apps/sysvinit/files/reboot.sh
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
opts="-dpk"
-[[ ${RC_DOWN_INTERFACE} == "yes" ]] && opts="${opts}i"
+[ "${RC_DOWN_INTERFACE}" = "yes" ] && opts="${opts}i"
-/sbin/reboot "${opts}"
+/sbin/reboot "${opts}" 2>/dev/null
# hmm, if the above failed, that's kind of odd ...
-# so let's force a reboot
+# unless it's busybox
/sbin/reboot -f
diff --git a/sys-apps/sysvinit/files/shutdown.sh b/sys-apps/sysvinit/files/shutdown.sh
index 4197d387e8dc..502ef5273cd6 100755
--- a/sys-apps/sysvinit/files/shutdown.sh
+++ b/sys-apps/sysvinit/files/shutdown.sh
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
opts="-d"
-[[ ${INIT_HALT} != "HALT" ]] && opts="${opts}p"
-[[ ${RC_DOWN_INTERFACE} == "yes" ]] && opts="${opts}i"
-[[ ${RC_DOWN_HARDDISK} == "yes" ]] && opts="${opts}h"
+[ "${INIT_HALT}" != "HALT" ] && opts="${opts}p"
+[ "${RC_DOWN_INTERFACE}" = "yes" ] && opts="${opts}i"
+[ "${RC_DOWN_HARDDISK}" = "yes" ] && opts="${opts}h"
/sbin/halt "${opts}"
diff --git a/sys-apps/sysvinit/sysvinit-2.86-r8.ebuild b/sys-apps/sysvinit/sysvinit-2.86-r8.ebuild
new file mode 100644
index 000000000000..8d9e2e1c7c47
--- /dev/null
+++ b/sys-apps/sysvinit/sysvinit-2.86-r8.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86-r8.ebuild,v 1.1 2007/03/13 21:19:39 uberlord Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="/sbin/init - parent of all processes"
+HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
+SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
+ ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
+ http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 arm hppa ~ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="selinux ibm static"
+
+RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ cp "${FILESDIR}"/change_console.{c,8} src/ || die
+ epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-shutdown-usage.patch
+ epatch "${FILESDIR}"/sysvinit-2.86-off-by-one.patch
+ epatch "${DISTDIR}"/sysvinit-2.86-kexec.patch
+ #epatch "${FILESDIR}"/sysvinit-2.86-POSIX-1003.1e.patch #5818
+ epatch "${FILESDIR}"/sysvinit-2.86-execl.patch
+ epatch "${FILESDIR}"/sysvinit-2.86-utmp-64bit.patch
+ epatch "${FILESDIR}/${P}"-shutdown-single.patch
+ cd src
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ use selinux && epatch "${FILESDIR}"/${PV}-selinux-1.patch
+
+ # Mung inittab for specific architectures
+ cd "${WORKDIR}"
+ cp "${FILESDIR}"/inittab . || die "cp inittab"
+ local insert=""
+ if use ibm ; then
+ insert="#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
+ insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
+ fi
+ use ppc && insert="#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux"
+ use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
+ use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
+ (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
+ [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ # Note: The LCRYPT define below overrides the test in
+ # sysvinit's Makefile. This is because sulogin must be linked
+ # to libcrypt in any case, but when building stage2 in
+ # catalyst, /usr/lib/libcrypt.a isn't available. In truth
+ # this doesn't change how sulogin is built since ld would use
+ # the shared obj by default anyway! The other option is to
+ # refrain from building sulogin, but that isn't a good option.
+ # (09 Jul 2004 agriffis)
+ emake -C src \
+ CC="$(tc-getCC)" \
+ DISTRO="Gentoo" \
+ LCRYPT="-lcrypt" \
+ all change_console \
+ || die
+}
+
+src_install() {
+ dodoc README doc/*
+
+ cd src
+ make install DISTRO="Gentoo" ROOT="${D}" || die "make install"
+
+ into /
+ dosbin change_console || die
+ doman change_console.8
+
+ insinto /etc
+ doins "${WORKDIR}"/inittab || die "inittab"
+
+ doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
+}
+
+pkg_postinst() {
+ # Reload init to fix unmounting problems of / on next reboot.
+ # This is really needed, as without the new version of init cause init
+ # not to quit properly on reboot, and causes a fsck of / on next reboot.
+ if [[ ${ROOT} == / ]] ; then
+ # Do not return an error if this fails
+ /sbin/telinit U &>/dev/null
+ fi
+}