summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2010-01-20 02:09:05 +0000
committerWilliam Hubbs <williamh@gentoo.org>2010-01-20 02:09:05 +0000
commit331a11977823e42963a823c4b99292c8d8cbe8b1 (patch)
treeb9d432643d3ee807b3bebd3dabcf13416f1ec518 /sys-apps/sysvinit
parentVersion bump (diff)
downloadgentoo-2-331a11977823e42963a823c4b99292c8d8cbe8b1.tar.gz
gentoo-2-331a11977823e42963a823c4b99292c8d8cbe8b1.tar.bz2
gentoo-2-331a11977823e42963a823c4b99292c8d8cbe8b1.zip
removed old versions
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/ChangeLog7
-rw-r--r--sys-apps/sysvinit/sysvinit-2.86-r12.ebuild93
-rw-r--r--sys-apps/sysvinit/sysvinit-2.87-r1.ebuild83
-rw-r--r--sys-apps/sysvinit/sysvinit-2.87-r2.ebuild83
-rw-r--r--sys-apps/sysvinit/sysvinit-2.87.ebuild83
5 files changed, 6 insertions, 343 deletions
diff --git a/sys-apps/sysvinit/ChangeLog b/sys-apps/sysvinit/ChangeLog
index 68a2d410c64b..5dbeac2d11d9 100644
--- a/sys-apps/sysvinit/ChangeLog
+++ b/sys-apps/sysvinit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sysvinit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.67 2010/01/08 18:41:03 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.68 2010/01/20 02:09:05 williamh Exp $
+
+ 20 Jan 2010; William Hubbs <williamh@gentoo.org>
+ -sysvinit-2.86-r12.ebuild, -sysvinit-2.87.ebuild,
+ -sysvinit-2.87-r1.ebuild, -sysvinit-2.87-r2.ebuild:
+ removed old versions
*sysvinit-2.87-r3 (08 Jan 2010)
diff --git a/sys-apps/sysvinit/sysvinit-2.86-r12.ebuild b/sys-apps/sysvinit/sysvinit-2.86-r12.ebuild
deleted file mode 100644
index fde345dedb86..000000000000
--- a/sys-apps/sysvinit/sysvinit-2.86-r12.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86-r12.ebuild,v 1.1 2008/12/17 22:47:15 cardoe Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
- ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
- http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux ibm static kernel_FreeBSD"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd "${S}"
- cp "${FILESDIR}"/change_console.{c,8} src/ || die
- epatch "${FILESDIR}"/${P}-docs.patch
- epatch "${FILESDIR}"/${P}-shutdown-usage.patch
- epatch "${FILESDIR}"/${P}-off-by-one.patch
- epatch "${DISTDIR}"/${P}-kexec.patch
- epatch "${FILESDIR}"/${P}-execl.patch
- epatch "${FILESDIR}"/${P}-utmp-64bit.patch
- epatch "${FILESDIR}"/${P}-shutdown-single.patch
- epatch "${FILESDIR}"/${P}-utmp-smp.patch
- epatch "${FILESDIR}"/${P}-build.patch
- use selinux && epatch "${FILESDIR}"/${PV}-selinux-1.patch
-
- # Mung inittab for specific architectures
- cd "${WORKDIR}"
- cp "${FILESDIR}"/inittab-2.86-r12 inittab || die "cp inittab"
- local insert=""
- use ppc && insert='#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux'
- use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
- use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
- use s390 && insert='s0:12345:respawn:/sbin/agetty 38400 console'
- if use ibm ; then
- insert="${insert}#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
- insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
- fi
- (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
- if use kernel_FreeBSD ; then
- sed -i \
- -e 's/linux/cons25/g' \
- -e 's/ttyS0/cuaa0/g' \
- -e 's/ttyS1/cuaa1/g' \
- inittab #121786
- fi
- [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
- use static && append-ldflags -static
- emake -C src \
- CC="$(tc-getCC)" \
- all change_console \
- || die
-}
-
-src_install() {
- emake -C src \
- install \
- ROOT="${D}" \
- || die "make install"
- dodoc README doc/*
-
- into /
- dosbin src/change_console || die
- doman src/change_console.8
-
- insinto /etc
- doins "${WORKDIR}"/inittab || die "inittab"
-
- doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
-}
-
-pkg_postinst() {
- # Reload init to fix unmounting problems of / on next reboot.
- # This is really needed, as without the new version of init cause init
- # not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
- # Do not return an error if this fails
- /sbin/telinit U &>/dev/null
- fi
-}
diff --git a/sys-apps/sysvinit/sysvinit-2.87-r1.ebuild b/sys-apps/sysvinit/sysvinit-2.87-r1.ebuild
deleted file mode 100644
index c7501fe93416..000000000000
--- a/sys-apps/sysvinit/sysvinit-2.87-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.87-r1.ebuild,v 1.1 2009/11/11 21:51:27 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-PATCH_VER="1"
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="mirror://debian/pool/main/s/sysvinit/${PN}_${PV}dsf.orig.tar.gz
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-F="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
- ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
- http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux ibm static kernel_FreeBSD"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-S=${WORKDIR}/${P}dsf
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
- sed -i '/^STRIP/s|=.*|=:|' src/Makefile
-
- # Mung inittab for specific architectures
- cd "${WORKDIR}"
- cp "${FILESDIR}"/inittab-2.86-r12 inittab || die "cp inittab"
- local insert=""
- use ppc && insert='#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux'
- use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
- use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
- use s390 && insert='s0:12345:respawn:/sbin/agetty 38400 console'
- if use ibm ; then
- insert="${insert}#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
- insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
- fi
- (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
- if use kernel_FreeBSD ; then
- sed -i \
- -e 's/linux/cons25/g' \
- -e 's/ttyS0/cuaa0/g' \
- -e 's/ttyS1/cuaa1/g' \
- inittab #121786
- fi
- [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
- tc-export CC
- use static && append-ldflags -static
- emake -C src || die
-}
-
-src_install() {
- emake -C src \
- install \
- ROOT="${D}" \
- || die "make install"
- dodoc README doc/*
-
- insinto /etc
- doins "${WORKDIR}"/inittab || die "inittab"
-
- doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
-}
-
-pkg_postinst() {
- # Reload init to fix unmounting problems of / on next reboot.
- # This is really needed, as without the new version of init cause init
- # not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
- # Do not return an error if this fails
- /sbin/telinit U &>/dev/null
- fi
-}
diff --git a/sys-apps/sysvinit/sysvinit-2.87-r2.ebuild b/sys-apps/sysvinit/sysvinit-2.87-r2.ebuild
deleted file mode 100644
index 758ced8d4e25..000000000000
--- a/sys-apps/sysvinit/sysvinit-2.87-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.87-r2.ebuild,v 1.1 2010/01/08 16:55:06 williamh Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-PATCH_VER="1"
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="mirror://debian/pool/main/s/sysvinit/${PN}_${PV}dsf.orig.tar.gz
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-F="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
- ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
- http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux ibm static kernel_FreeBSD"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-S=${WORKDIR}/${P}dsf
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
- sed -i '/^STRIP/s|=.*|=:|' src/Makefile
-
- # Mung inittab for specific architectures
- cd "${WORKDIR}"
- cp "${FILESDIR}"/inittab-${PV} inittab || die "cp inittab"
- local insert=""
- use ppc && insert='#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux'
- use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
- use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
- use s390 && insert='s0:12345:respawn:/sbin/agetty 38400 console'
- if use ibm ; then
- insert="${insert}#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
- insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
- fi
- (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
- if use kernel_FreeBSD ; then
- sed -i \
- -e 's/linux/cons25/g' \
- -e 's/ttyS0/cuaa0/g' \
- -e 's/ttyS1/cuaa1/g' \
- inittab #121786
- fi
- [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
- tc-export CC
- use static && append-ldflags -static
- emake -C src || die
-}
-
-src_install() {
- emake -C src \
- install \
- ROOT="${D}" \
- || die "make install"
- dodoc README doc/*
-
- insinto /etc
- doins "${WORKDIR}"/inittab || die "inittab"
-
- doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
-}
-
-pkg_postinst() {
- # Reload init to fix unmounting problems of / on next reboot.
- # This is really needed, as without the new version of init cause init
- # not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
- # Do not return an error if this fails
- /sbin/telinit U &>/dev/null
- fi
-}
diff --git a/sys-apps/sysvinit/sysvinit-2.87.ebuild b/sys-apps/sysvinit/sysvinit-2.87.ebuild
deleted file mode 100644
index 2ca96342d5eb..000000000000
--- a/sys-apps/sysvinit/sysvinit-2.87.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.87.ebuild,v 1.1 2009/10/18 08:55:36 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-PATCH_VER="1"
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="mirror://debian/pool/main/s/sysvinit/${PN}_${PV}dsf.orig.tar.gz
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-F="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
- ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
- http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux ibm static kernel_FreeBSD"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-S=${WORKDIR}/${P}dsf
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
- sed -i '/^STRIP/s|=.*|=:|' src/Makefile
-
- # Mung inittab for specific architectures
- cd "${WORKDIR}"
- cp "${FILESDIR}"/inittab-2.86-r12 inittab || die "cp inittab"
- local insert=""
- use ppc && insert='#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux'
- use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
- use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
- use s390 && insert='s0:12345:respawn:/sbin/agetty 38400 console'
- if use ibm ; then
- insert="${insert}#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
- insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
- fi
- (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
- if use kernel_FreeBSD ; then
- sed -i \
- -e 's/linux/cons25/g' \
- -e 's/ttyS0/cuaa0/g' \
- -e 's/ttyS1/cuaa1/g' \
- inittab #121786
- fi
- [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
- tc-export CC
- use static && append-ldflags -static
- emake -C src || die
-}
-
-src_install() {
- emake -C src \
- install \
- ROOT="${D}" \
- || die "make install"
- dodoc README doc/*
-
- insinto /etc
- doins "${WORKDIR}"/inittab || die "inittab"
-
- doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
-}
-
-pkg_postinst() {
- # Reload init to fix unmounting problems of / on next reboot.
- # This is really needed, as without the new version of init cause init
- # not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [[ ${ROOT} == / ]] ; then
- # Do not return an error if this fails
- /sbin/telinit U &>/dev/null
- fi
-}