summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-07-20 16:57:58 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-07-20 16:57:58 +0000
commit399a3a7ccab98e85925661e524c0dc0661342be8 (patch)
tree760d4fd7a9a36d7f3f9cd6190aaab5b4c77889c8 /sys-apps/sg3_utils
parentVersion bumped. (diff)
downloadgentoo-2-399a3a7ccab98e85925661e524c0dc0661342be8.tar.gz
gentoo-2-399a3a7ccab98e85925661e524c0dc0661342be8.tar.bz2
gentoo-2-399a3a7ccab98e85925661e524c0dc0661342be8.zip
Better fix for bug 231089; some packages look for sgutils2
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/ChangeLog8
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.27-r1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/sg3_utils/ChangeLog b/sys-apps/sg3_utils/ChangeLog
index 3f974865fd74..a40ad3a7d5a3 100644
--- a/sys-apps/sg3_utils/ChangeLog
+++ b/sys-apps/sg3_utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sg3_utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.52 2009/07/15 18:45:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/ChangeLog,v 1.53 2009/07/20 16:57:58 nirbheek Exp $
+
+*sg3_utils-1.27-r1 (20 Jul 2009)
+
+ 20 Jul 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +sg3_utils-1.27-r1.ebuild:
+ Better fix for bug 231089; some packages look for sgutils2
15 Jul 2009; nixnut <nixnut@gentoo.org> sg3_utils-1.27.ebuild:
ppc stable #273076
diff --git a/sys-apps/sg3_utils/sg3_utils-1.27-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.27-r1.ebuild
new file mode 100644
index 000000000000..3c34f21e0fad
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.27-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.27-r1.ebuild,v 1.1 2009/07/20 16:57:58 nirbheek Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README.doc examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/{scsi,sas}* || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${D}"/usr/$(get_libdir)/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${path}/${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}