summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-21 22:12:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-21 22:12:37 +0000
commit1dcb4618b3150e2b786c97cec05c430b8bef0252 (patch)
tree0ffc62b0d473a2cf4117724e000b8f2442b0d55f /sys-apps/rlocate
parentold (diff)
downloadgentoo-2-1dcb4618b3150e2b786c97cec05c430b8bef0252.tar.gz
gentoo-2-1dcb4618b3150e2b786c97cec05c430b8bef0252.tar.bz2
gentoo-2-1dcb4618b3150e2b786c97cec05c430b8bef0252.zip
Version bump.
(Portage version: 2.1_pre9-r1)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.13
-rw-r--r--sys-apps/rlocate/files/rlocate-0.5.1-build.patch35
-rw-r--r--sys-apps/rlocate/rlocate-0.5.1.ebuild48
4 files changed, 93 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 3a383ad07aed..c7416161180f 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.14 2006/04/15 18:17:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.15 2006/04/21 22:12:37 vapier Exp $
+
+*rlocate-0.5.1 (21 Apr 2006)
+
+ 21 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.5.1-build.patch, +rlocate-0.5.1.ebuild:
+ Version bump.
*rlocate-0.5.0-r1 (15 Apr 2006)
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.1 b/sys-apps/rlocate/files/digest-rlocate-0.5.1
new file mode 100644
index 000000000000..6cfd4dd2d94a
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.1
@@ -0,0 +1,3 @@
+MD5 618dc98cd9c13468e8b8e1ca5f0eabbc rlocate-0.5.1.tar.gz 177793
+RMD160 c870ce852b6e3cf0bec4724b10773f6cfc8e9e24 rlocate-0.5.1.tar.gz 177793
+SHA256 35be2d758f63ed2b552c658861848387a1db7c854a47c4e5a595cb6f13145450 rlocate-0.5.1.tar.gz 177793
diff --git a/sys-apps/rlocate/files/rlocate-0.5.1-build.patch b/sys-apps/rlocate/files/rlocate-0.5.1-build.patch
new file mode 100644
index 000000000000..e5247099b6db
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.5.1-build.patch
@@ -0,0 +1,35 @@
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -190,9 +190,9 @@
+ rlocate.h rlocate.c cmds.c cmds.h conf.c conf.h utils.c \
+ utils.h
+
+-SUBDIRS = rlocate-daemon rlocate-module rlocate-scripts
++SUBDIRS = rlocate-daemon rlocate-scripts
+ EXTRA_DIST = rlocate.cron rlocate-scripts
+-AM_CFLAGS = -O2 -Wall
++AM_CFLAGS = -Wall
+ all: all-recursive
+
+ .SUFFIXES:
+--- src/rlocate-daemon/Makefile.in
++++ src/rlocate-daemon/Makefile.in
+@@ -169,7 +169,7 @@
+ -DRLOCATE_GRP=\"$(rlocate_group)\"
+
+ rlocated_SOURCES = ../pidfile.h ../pidfile.c rlocated.c
+-AM_CFLAGS = -O2 -Wall
++AM_CFLAGS = -Wall
+ all: all-am
+
+ .SUFFIXES:
+--- src/rlocate-scripts/Makefile.in
++++ src/rlocate-scripts/Makefile.in
+@@ -343,7 +343,6 @@
+ rm $(srcdir)/rlocate-checkpoint.temp
+
+ install-exec-hook:
+- -/usr/sbin/groupadd $(rlocate_group)
+ chown $(root_uid):$(rlocate_group) $(DESTDIR)$(bindir)/rlocate-checkpoint
+ chmod 2755 $(DESTDIR)$(bindir)/rlocate-checkpoint
+
diff --git a/sys-apps/rlocate/rlocate-0.5.1.ebuild b/sys-apps/rlocate/rlocate-0.5.1.ebuild
new file mode 100644
index 000000000000..0f5248742e2c
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.1.ebuild,v 1.1 2006/04/21 22:12:37 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.1-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}