summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 23:39:00 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-28 23:39:00 +0000
commit33f3f1dd00e0e9d2fc612e0b1069a204a4e9c041 (patch)
tree1da3c98c86411da7505063ac19a9003396e5cd70 /sys-apps/pcsc-lite
parentDelete older ebuilds. (diff)
downloadgentoo-2-33f3f1dd00e0e9d2fc612e0b1069a204a4e9c041.tar.gz
gentoo-2-33f3f1dd00e0e9d2fc612e0b1069a204a4e9c041.tar.bz2
gentoo-2-33f3f1dd00e0e9d2fc612e0b1069a204a4e9c041.zip
Version bump (bug #325863).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pcsc-lite')
-rw-r--r--sys-apps/pcsc-lite/ChangeLog10
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.6.1.ebuild71
2 files changed, 79 insertions, 2 deletions
diff --git a/sys-apps/pcsc-lite/ChangeLog b/sys-apps/pcsc-lite/ChangeLog
index dbeba0aa087d..724a14b8a2d9 100644
--- a/sys-apps/pcsc-lite/ChangeLog
+++ b/sys-apps/pcsc-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pcsc-lite
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.81 2009/10/05 16:02:08 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/ChangeLog,v 1.82 2010/06/28 23:39:00 arfrever Exp $
+
+*pcsc-lite-1.6.1 (28 Jun 2010)
+
+ 28 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pcsc-lite-1.5.3.ebuild, -pcsc-lite-1.5.4.ebuild, +pcsc-lite-1.6.1.ebuild:
+ Version bump (bug #325863).
05 Oct 2009; Raúl Porcel <armin76@gentoo.org> pcsc-lite-1.5.5.ebuild:
arm/ia64/m68k/s390/sh/sparc stable wrt #283378
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.6.1.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.6.1.ebuild
new file mode 100644
index 000000000000..e96252c80dcd
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.6.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.6.1.ebuild,v 1.1 2010/06/28 23:39:00 arfrever Exp $
+
+EAPI="3"
+
+inherit multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit autotools subversion
+ ESVN_REPO_URI="svn://svn.debian.org/pcsclite/trunk"
+ S="${WORKDIR}/trunk"
+else
+ STUPID_NUM="3298"
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="hal static usb"
+
+RDEPEND="usb? ( virtual/libusb:0 )
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if use hal && use usb; then
+ ewarn "The usb and hal USE flags cannot be enabled at the same time"
+ ewarn "Disabling the effect of USE=usb"
+ fi
+}
+
+if [[ "${PV}" == "9999" ]]; then
+ src_prepare() {
+ S="${WORKDIR}/trunk/PCSC"
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+ }
+fi
+
+src_configure() {
+ local myconf
+ if use hal; then
+ myconf="--enable-libhal --disable-libusb"
+ else
+ myconf="--disable-libhal $(use_enable usb libusb)"
+ fi
+
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ ${myconf} \
+ $(use_enable static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepalldocs
+
+ dodoc AUTHORS DRIVERS HELP README SECURITY ChangeLog
+
+ newinitd "${FILESDIR}/pcscd-init" pcscd
+ newconfd "${FILESDIR}/pcscd-confd" pcscd
+}