summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-02-14 21:00:41 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-02-14 21:00:41 +0000
commit9785c0ff75007fd8ea20eae94e736e60b2b8b0c2 (patch)
tree01c55f8a0fcaf72922f4543e49df7312a604bdce /sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild
parentFixup for pcsc-lite-1.4 (diff)
downloadgentoo-2-9785c0ff75007fd8ea20eae94e736e60b2b8b0c2.tar.gz
gentoo-2-9785c0ff75007fd8ea20eae94e736e60b2b8b0c2.tar.bz2
gentoo-2-9785c0ff75007fd8ea20eae94e736e60b2b8b0c2.zip
Version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild')
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild
new file mode 100644
index 000000000000..addba98ccc43
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.4.0.ebuild,v 1.1 2007/02/14 21:00:41 alonbl Exp $
+
+inherit multilib
+
+STUPID_NUM="1884"
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --enable-usbdropdir="/usr/$(get_libdir)/readers/usb" \
+ --enable-muscledropdir="/usr/share/pcsc/services" \
+ --enable-runpid="/var/run/pcscd.pid" \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}