summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-26 05:24:30 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-26 05:24:30 +0000
commit8d8e4aa13ee05c575e7a57471615f390df8737d6 (patch)
tree3a8d271e0531b5ecd2516e6af465dd66edd9ef3c /sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild
parentFix manifest and Files/ (diff)
downloadgentoo-2-8d8e4aa13ee05c575e7a57471615f390df8737d6.tar.gz
gentoo-2-8d8e4aa13ee05c575e7a57471615f390df8737d6.tar.bz2
gentoo-2-8d8e4aa13ee05c575e7a57471615f390df8737d6.zip
Version bump #145108 by Alon Bar-Lev.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild')
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild
new file mode 100644
index 000000000000..952c93a2f099
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcsc-lite/pcsc-lite-1.3.2.ebuild,v 1.1 2006/08/26 05:24:30 vapier Exp $
+
+inherit multilib
+
+STUPID_NUM=1738
+MY_P="${PN}-${PV/_/-}"
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://www.linuxnet.com/middle.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~x86"
+IUSE="static debug"
+
+RDEPEND="!static? ( dev-libs/libusb )"
+DEPEND="dev-libs/libusb
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf \
+ --enable-usbdropdir=/usr/$(get_libdir)/readers/usb \
+ --enable-muscledropdir=/usr/share/pcsc/services \
+ $(use_enable debug) \
+ $(use_enable static) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog DRIVERS HELP INSTALL NEWS README SECURITY
+ dodoc doc/*.pdf doc/README.DAEMON
+ docinto sample
+ dodoc src/utils/README src/utils/sample.*
+ rm -r "${D}"/usr/doc
+
+ newinitd "${FILESDIR}"/pcscd-init pcscd
+ newconfd "${FILESDIR}"/pcscd-confd pcscd
+}
+
+pkg_postinst() {
+ ewarn "You should run 'revdep-rebuild --library libpcsclite.so.0'"
+}