summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-02-10 00:30:43 +0000
committerMike Frysinger <vapier@gentoo.org>2007-02-10 00:30:43 +0000
commit97596d803958c79073ee86ef6ace03a2bcd76d64 (patch)
treede3074d2a359ea04c583cc1649ef8221cd086f3b /sys-apps/pciutils
parentVersion bump. (diff)
downloadgentoo-2-97596d803958c79073ee86ef6ace03a2bcd76d64.tar.gz
gentoo-2-97596d803958c79073ee86ef6ace03a2bcd76d64.tar.bz2
gentoo-2-97596d803958c79073ee86ef6ace03a2bcd76d64.zip
Add a -q (quiet) flag to update-pciids and have th cronjob use it #164800 by Horst Prote.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog10
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.4-r13
-rw-r--r--sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch41
-rwxr-xr-xsys-apps/pciutils/files/pciutils.cron2
-rw-r--r--sys-apps/pciutils/pciutils-2.2.4-r1.ebuild41
5 files changed, 95 insertions, 2 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 9326804d2657..bf812dfcb53a 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.90 2007/01/07 01:40:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.91 2007/02/10 00:30:42 vapier Exp $
+
+*pciutils-2.2.4-r1 (10 Feb 2007)
+
+ 10 Feb 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/pciutils-2.2.4-update-pciids.patch, files/pciutils.cron,
+ +pciutils-2.2.4-r1.ebuild:
+ Add a -q (quiet) flag to update-pciids and have th cronjob use it #164800 by
+ Horst Prote.
07 Jan 2007; Mike Frysinger <vapier@gentoo.org>
files/pciutils-2.2.4-link.patch:
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.4-r1 b/sys-apps/pciutils/files/digest-pciutils-2.2.4-r1
new file mode 100644
index 000000000000..1ce68229c366
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.4-r1
@@ -0,0 +1,3 @@
+MD5 5629fdb049f189fb853e7021f85553d2 pciutils-2.2.4.tar.gz 210706
+RMD160 27db4b23a07a02b28b64e01fbe1c74cefa887cc0 pciutils-2.2.4.tar.gz 210706
+SHA256 62fc07f688c6d17f0cf8baa540e42be6117530360c2df491ec02031973506a9f pciutils-2.2.4.tar.gz 210706
diff --git a/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch b/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch
new file mode 100644
index 000000000000..f875f8a825c0
--- /dev/null
+++ b/sys-apps/pciutils/files/pciutils-2.2.4-update-pciids.patch
@@ -0,0 +1,41 @@
+--- update-pciids.sh
++++ update-pciids.sh
+@@ -1,5 +1,7 @@
+ #!/bin/sh
+
++[ "$1" = "-q" ] && quiet="true" || quiet="false"
++
+ set -e
+ SRC="http://pciids.sourceforge.net/v2.2/pci.ids"
+ DEST=pci.ids
+@@ -8,6 +8,13 @@
+ PCI_COMPRESSED_IDS=
+ GREP=grep
+
++# if pci.ids is read-only (because the filesystem is read-only),
++# then just skip this whole process.
++if ! touch ${DEST} >&2 >/dev/null ; then
++ ${quiet} || echo "${DEST} is read-only, exiting."
++ exit 0
++fi
++
+ if [ -n "$PCI_COMPRESSED_IDS" ] ; then
+ DECOMP="cat"
+ SRC="$SRC.gz"
+@@ -22,8 +24,10 @@
+
+ if which curl >/dev/null ; then
+ DL="curl -o $DEST.new $SRC"
++ ${quiet} && DL="$DL -s -S"
+ elif which wget >/dev/null ; then
+ DL="wget -O $DEST.new $SRC"
++ ${quiet} && DL="$DL -q"
+ elif which lynx >/dev/null ; then
+ DL="eval lynx -source $SRC >$DEST.new"
+ else
+@@ -59,4 +66,4 @@
+ mv $DEST.neww $DEST
+ rm $DEST.new
+
+-echo "Done."
++${quiet} || echo "Done."
diff --git a/sys-apps/pciutils/files/pciutils.cron b/sys-apps/pciutils/files/pciutils.cron
index 8d41816dbe5f..4c6942365253 100755
--- a/sys-apps/pciutils/files/pciutils.cron
+++ b/sys-apps/pciutils/files/pciutils.cron
@@ -1,2 +1,2 @@
#!/bin/sh
-exec /usr/sbin/update-pciids
+exec /usr/sbin/update-pciids -q
diff --git a/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild b/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild
new file mode 100644
index 000000000000..1c73171d4aee
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild,v 1.1 2007/02/10 00:30:42 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.3-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.4.patch
+ epatch "${FILESDIR}"/${P}-link.patch #160421
+ epatch "${FILESDIR}"/${P}-update-pciids.patch
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ dolib lib/libpci.* || die "libpci failed"
+ insinto /usr/include/pci
+ doins lib/{config,header,pci,types}.h || die "headers failed"
+
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids || die
+}