summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2005-06-13 21:29:30 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2005-06-13 21:29:30 +0000
commit3db17f1f944660d204b5501aa37b98d489882981 (patch)
treeb15737a6c7a0796c990a90e77eaa0bc318b1e9b0 /sys-apps/paxctl/paxctl-0.3-r1.ebuild
parentMarking 0.3.7 stable on x86 (diff)
downloadgentoo-2-3db17f1f944660d204b5501aa37b98d489882981.tar.gz
gentoo-2-3db17f1f944660d204b5501aa37b98d489882981.tar.bz2
gentoo-2-3db17f1f944660d204b5501aa37b98d489882981.zip
- return EXIT_FAILURE when paxctl fails to do as requested
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-apps/paxctl/paxctl-0.3-r1.ebuild')
-rw-r--r--sys-apps/paxctl/paxctl-0.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/paxctl/paxctl-0.3-r1.ebuild b/sys-apps/paxctl/paxctl-0.3-r1.ebuild
new file mode 100644
index 000000000000..7290f5c3222d
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.3-r1.ebuild,v 1.1 2005/06/13 21:29:30 kevquinn Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ia64 ~mips ~ppc64"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/libc >=sys-devel/binutils-2.14.90.0.8-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-error-codes.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}